summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-04-06 18:08:44 +0000
committerEric Andersen <andersen@codepoet.org>2006-04-06 18:08:44 +0000
commit768304767b039b5b0d7c3c4a45a4fce04e1d0f81 (patch)
tree2ede8927ccb6a801707c88254b886349084646ef /toolchain/gdb
parentafd4b07278e22cf67566d20b25b61cf15646cfae (diff)
akvadrako writes:
The term gdb-client is deceptive - although it parallels the gdb-server name, it is actually a full fledged gdb version. I want to use it to debug uClibc core files on my host system. Although I haven't got that to work yet, I wasted time figuring out how to do build gdb for the host not realizing it already had a target. With this documentation change, things would have been a lot clearer to me.
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Config.in8
-rw-r--r--toolchain/gdb/gdb.mk36
2 files changed, 22 insertions, 22 deletions
diff --git a/toolchain/gdb/Config.in b/toolchain/gdb/Config.in
index 737eb07f6..9c1caf4c1 100644
--- a/toolchain/gdb/Config.in
+++ b/toolchain/gdb/Config.in
@@ -14,16 +14,16 @@ config BR2_PACKAGE_GDB_SERVER
Build the gdbserver stub to run on the target.
A full gdb is needed to debug the progam.
-config BR2_PACKAGE_GDB_CLIENT
- bool "Build gdb client for the Host"
+config BR2_PACKAGE_GDB_HOST
+ bool "Build gdb for the Host"
default n
help
- Build gdb to run on the host to debug programs running on the target.
+ Build gdb to run on the host to debug programs run on the target.
choice
prompt "GDB debugger Version"
default BR2_GDB_VERSION_6_3
- depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_CLIENT
+ depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_HOST
help
Select the version of gdb you wish to use.
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index af67b7434..02fc53179 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -159,15 +159,15 @@ gdbserver-dirclean:
######################################################################
#
-# gdb client
+# gdb on host
#
######################################################################
-GDB_CLIENT_DIR:=$(TOOL_BUILD_DIR)/gdbclient-$(GDB_VERSION)
+GDB_HOST_DIR:=$(TOOL_BUILD_DIR)/gdbhost-$(GDB_VERSION)
-$(GDB_CLIENT_DIR)/.configured: $(GDB_DIR)/.unpacked
- mkdir -p $(GDB_CLIENT_DIR)
- (cd $(GDB_CLIENT_DIR); \
+$(GDB_HOST_DIR)/.configured: $(GDB_DIR)/.unpacked
+ mkdir -p $(GDB_HOST_DIR)
+ (cd $(GDB_HOST_DIR); \
gdb_cv_func_sigsetjmp=yes \
$(GDB_DIR)/configure \
--prefix=$(STAGING_DIR) \
@@ -180,26 +180,26 @@ $(GDB_CLIENT_DIR)/.configured: $(GDB_DIR)/.unpacked
--without-included-gettext \
--enable-threads \
);
- touch $(GDB_CLIENT_DIR)/.configured
+ touch $(GDB_HOST_DIR)/.configured
-$(GDB_CLIENT_DIR)/gdb/gdb: $(GDB_CLIENT_DIR)/.configured
- $(MAKE) -C $(GDB_CLIENT_DIR)
- strip $(GDB_CLIENT_DIR)/gdb/gdb
+$(GDB_HOST_DIR)/gdb/gdb: $(GDB_HOST_DIR)/.configured
+ $(MAKE) -C $(GDB_HOST_DIR)
+ strip $(GDB_HOST_DIR)/gdb/gdb
-$(TARGET_CROSS)gdb: $(GDB_CLIENT_DIR)/gdb/gdb
- install -c $(GDB_CLIENT_DIR)/gdb/gdb $(TARGET_CROSS)gdb
+$(TARGET_CROSS)gdb: $(GDB_HOST_DIR)/gdb/gdb
+ install -c $(GDB_HOST_DIR)/gdb/gdb $(TARGET_CROSS)gdb
ln -snf ../../bin/$(REAL_GNU_TARGET_NAME)-gdb \
$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/gdb
ln -snf $(REAL_GNU_TARGET_NAME)-gdb \
$(STAGING_DIR)/bin/$(GNU_TARGET_NAME)-gdb
-gdbclient: $(TARGET_CROSS)gdb
+gdbhost: $(TARGET_CROSS)gdb
-gdbclient-clean:
- $(MAKE) -C $(GDB_CLIENT_DIR) clean
+gdbhost-clean:
+ $(MAKE) -C $(GDB_HOST_DIR) clean
-gdbclient-dirclean:
- rm -rf $(GDB_CLIENT_DIR)
+gdbhost-dirclean:
+ rm -rf $(GDB_HOST_DIR)
@@ -216,6 +216,6 @@ ifeq ($(strip $(BR2_PACKAGE_GDB_SERVER)),y)
TARGETS+=gdbserver
endif
-ifeq ($(strip $(BR2_PACKAGE_GDB_CLIENT)),y)
-TARGETS+=gdbclient
+ifeq ($(strip $(BR2_PACKAGE_GDB_HOST)),y)
+TARGETS+=gdbhost
endif