summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2011-02-24 21:37:48 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-28 10:26:17 +0100
commit816303a49dc249584b9f3f29a1c38642d6685997 (patch)
tree4e744e4b04134a3d1a8c624c2e57e288f4cb422e /toolchain/gdb
parent57ab28928bd8979fa34751bc1c248a1af00ce1f9 (diff)
gdb: depend on host-expat to fix remote debugging
This patch fixes the following error when using GDB with gdbserver: warning: Can not parse XML target description; XML support was disabled at compile time Remote 'g' packet reply is too long: <very long line of hex chars> [remote debugging does not work] Use $(HOST_CONFIGURE_OPTS) so expat is found. Signed-off-by: Bjørn Forsman <bjorn.forsman@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/gdb.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 739ebbe99..caf3e364d 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -183,6 +183,7 @@ $(GDB_HOST_DIR)/.configured: $(GDB_DIR)/.unpacked
(cd $(GDB_HOST_DIR); \
gdb_cv_func_sigsetjmp=yes \
bash_cv_have_mbstate_t=yes \
+ $(HOST_CONFIGURE_OPTS) \
$(GDB_DIR)/configure $(QUIET) \
--cache-file=/dev/null \
--prefix=$(STAGING_DIR) \
@@ -207,7 +208,7 @@ $(TARGET_CROSS)gdb: $(GDB_HOST_DIR)/gdb/gdb
ln -snf $(REAL_GNU_TARGET_NAME)-gdb \
$(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-gdb
-gdbhost: $(TARGET_CROSS)gdb
+gdbhost: host-expat $(TARGET_CROSS)gdb
gdbhost-source: $(DL_DIR)/$(GDB_SOURCE)