summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-30 13:34:42 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-30 13:34:42 +0000
commit92bd25c9eb14eafb1beb8f41af71fef1e545922a (patch)
tree6574d5baaa0bcf3d9c02287c75d020932674e5bd /toolchain/gdb
parent81ddf3d083e6f238de66bc9c504c814de56d9545 (diff)
toolchain: fix up GNU_TARGET_NAME link and target_utils location
The GNU_TARGET_NAME symlink and target_utils location were not correctly adjusted to match the move of the toolchain to $(STAGING_DIR)/usr, creating dangling symlinks.
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/gdb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 6e46c0bd1..11a394117 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -169,9 +169,9 @@ $(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_SERVER_DIR)/gdbserver
ifeq ($(BR2_CROSS_TOOLCHAIN_TARGET_UTILS),y)
- mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/target_utils
+ mkdir -p $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils
install -c $(GDB_SERVER_DIR)/gdbserver \
- $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/target_utils/gdbserver
+ $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils/gdbserver
endif
install -c -D $(GDB_SERVER_DIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver