summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-18 05:26:51 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-18 11:58:19 +0100
commitc4494d72899156cd3204516b5da371c1758efeca (patch)
tree6786ab29ab9c9d9352c95312759f89a7076546d1 /toolchain/gdb
parent84a6f5342ad51045143e7698b676909a4e8ee431 (diff)
gdb: drop local stripping in favor of top level
Since the top level takes care of stripping for us, and some file formats cannot be stripped safely (like FLAT which will error out), simply punt the manual stripping from the gdb package. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/gdb.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index c4fef8946..54c390597 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -97,7 +97,6 @@ $(GDB_TARGET_DIR)/gdb/gdb: $(GDB_TARGET_DIR)/.configured
gdb_cv_var_elf=yes \
$(MAKE) CC="$(TARGET_CC)" MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_TARGET_DIR)
- $(STRIPCMD) $(GDB_TARGET_DIR)/gdb/gdb
$(TARGET_DIR)/usr/bin/gdb: $(GDB_TARGET_DIR)/gdb/gdb
install -c -D $(GDB_TARGET_DIR)/gdb/gdb $(TARGET_DIR)/usr/bin/gdb
@@ -152,7 +151,6 @@ $(GDB_SERVER_DIR)/.configured: $(GDB_DIR)/.unpacked
$(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
$(MAKE) CC="$(TARGET_CC)" MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_SERVER_DIR)
- $(STRIPCMD) $(GDB_SERVER_DIR)/gdbserver
$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_SERVER_DIR)/gdbserver
ifeq ($(BR2_CROSS_TOOLCHAIN_TARGET_UTILS),y)