summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-12-15 15:28:48 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-12-15 15:28:48 +0000
commite2e4950b2d9334e6380e32cf30c7c7968747ccc0 (patch)
treec2d61eb791929dadfeaaade08db87c2551d6d51f /toolchain/gdb
parent060dca08f9d90d78415dd1a7ce693e92d66f0d6b (diff)
toolchain: use same gdb Config.in for internal/external toolchains
We used to use different gdb configs for internal and external toolchains because mconf won't source the same file twice. This works, but is kind of sub optimal, as people forget to keep them in sync. Fix it to use the same file for both situations by shuffling around the config options a bit. Should work identical to before (except for the newer gdb versions available for ext).
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Config.in.254
-rw-r--r--toolchain/gdb/gdb.mk5
2 files changed, 0 insertions, 59 deletions
diff --git a/toolchain/gdb/Config.in.2 b/toolchain/gdb/Config.in.2
deleted file mode 100644
index 6eafa6079..000000000
--- a/toolchain/gdb/Config.in.2
+++ /dev/null
@@ -1,54 +0,0 @@
-# Keep this in sync with Config.in
-# Why don't you use Config.in in the first place?
-
-comment "Gdb Options"
-
-config BR2_PACKAGE_GDB
- bool "Build gdb debugger for the Target"
- select BR2_PACKAGE_NCURSES
- help
- Build the full gdb debugger to run on the target.
-
-config BR2_PACKAGE_GDB_SERVER
- bool "Build gdb server for the Target"
- help
- Build the gdbserver stub to run on the target.
- A full gdb is needed to debug the progam.
-
-config BR2_PACKAGE_GDB_HOST
- bool "Build gdb for the Host"
- help
- Build gdb to run on the host to debug programs run on the target.
-
-choice
- prompt "GDB debugger Version"
- default BR2_GDB_VERSION_6_3
- depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_HOST
- help
- Select the version of gdb you wish to use.
-
- config BR2_EXT_GDB_VERSION_6_2_1
- bool "gdb 6.2.1"
-
- config BR2_EXT_GDB_VERSION_6_3
- bool "gdb 6.3"
-
- config BR2_EXT_GDB_VERSION_6_4
- bool "gdb 6.4"
-
- config BR2_EXT_GDB_VERSION_6_5
- bool "gdb 6.5"
-
- config BR2_EXT_GDB_VERSION_SNAPSHOT
- bool "gdb snapshot"
-
-endchoice
-
-config BR2_EXT_GDB_VERSION
- string
- default "6.2.1" if BR2_EXT_GDB_VERSION_6_2_1
- default "6.3" if BR2_EXT_GDB_VERSION_6_3
- default "6.4" if BR2_EXT_GDB_VERSION_6_4
- default "6.5" if BR2_EXT_GDB_VERSION_6_5
- default "6.6" if BR2_EXT_GDB_VERSION_6_6
- default "snapshot" if BR2_EXT_GDB_VERSION_SNAPSHOT
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 66e0b4179..f239dba01 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -3,13 +3,8 @@
# gdb
#
######################################################################
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
GDB_VERSION:=$(strip $(subst ",, $(BR2_GDB_VERSION)))
#"))
-else
-GDB_VERSION:=$(strip $(subst ",, $(BR2_EXT_GDB_VERSION)))
-#"))
-endif
ifeq ($(GDB_VERSION),snapshot)
# Be aware that this changes daily....