summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorPaulius Zaleckas <paulius.zaleckas@gmail.com>2010-04-29 22:19:20 +0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-01 22:53:41 +0200
commitee39d53ce343c2d8e4603f40a9d3aaba6d5ef8ff (patch)
tree5445e94720e122e60c4da45ac85690d57fb39a2b /toolchain/gdb
parentbb73ce22225306a4484c45fc359ebe7b64512501 (diff)
Fix GDB BFD test linking
When compiling GDB for target (in my case i386) it links wrong BFD library from host OS. This prevents GDB from compiling support for ELF and thus GDB is unusable on target. More about this issue was already posted at: http://lists.uclibc.org/pipermail/buildroot/2009-March/026585.html Fix this issue by forcing ELF support. Signed-off-by: Paulius Zaleckas <paulius.zaleckas@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/gdb.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 5e91d981d..5725067c2 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -93,6 +93,8 @@ endif
touch $@
$(GDB_TARGET_DIR)/gdb/gdb: $(GDB_TARGET_DIR)/.configured
+ # force ELF support since it fails due to BFD linking problems
+ gdb_cv_var_elf=yes \
$(MAKE) CC=$(TARGET_CC) MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_TARGET_DIR)
$(STRIPCMD) $(GDB_TARGET_DIR)/gdb/gdb