summaryrefslogtreecommitdiff
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-10-09 19:44:31 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-10 09:46:36 +0200
commit2e57043b4d1659b54cd5954ad98884e1a1c3848a (patch)
tree5f09411deabe7c0c3ac5699ca9431b05083ec061 /toolchain/toolchain-external
parentce1940ddea7d82e5da1e0b8c14395a1302d29086 (diff)
external-toolchain: Slightly optimize toolchain extraction
Some CodeSourcery toolchains contain a huge number of locales that are not useful, even though they account for 70-80% of the total toolchain size. By skipping the extraction of those useless locales, we make the toolchain extraction process slightly faster, and also make the output directory size a lot smaller (host/opt/ is 213 MB instead of 1.5 GB with a 2010.09 ARM CodeSourcery toolchain). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/ext-tool.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 6e34e05e9..828791660 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -250,7 +250,8 @@ $(DL_DIR)/$(TOOLCHAIN_EXTERNAL_SOURCE):
$(TOOLCHAIN_EXTERNAL_DIR)/.extracted: $(DL_DIR)/$(TOOLCHAIN_EXTERNAL_SOURCE)
mkdir -p $(@D)
- $(INFLATE$(suffix $(TOOLCHAIN_EXTERNAL_SOURCE))) $^ | $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+ $(INFLATE$(suffix $(TOOLCHAIN_EXTERNAL_SOURCE))) $^ | \
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 --exclude='usr/lib/locale/*' -C $(@D) $(TAR_OPTIONS) -
$(Q)touch $@
endif