summaryrefslogtreecommitdiff
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorStany MARCEL <stanypub@gmail.com>2011-11-01 01:53:38 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-11-02 11:46:07 +0100
commitd64c4ed3f787802d2b3953a5db787984d9a6626e (patch)
tree53f5c4e852b462cfedeefd97aab39bf5ae4c9f77 /toolchain/toolchain-external
parent9d885487ea49824293ebb410b571dc2f590f56f4 (diff)
toolchain: Correct test for external tools symlink creation
When the external tools chain is installed in a path that match one of the first case test, all symlink are created to the external wrapper. The proposed solution is to test only the base name not the full path. Signed-off-by: Stany MARCEL <stanypub@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/ext-tool.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 828791660..572917ff0 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -318,9 +318,9 @@ $(STAMP_DIR)/ext-toolchain-installed: $(TOOLCHAIN_EXTERNAL_DEPENDENCIES)
$(HOST_DIR)/usr/bin/ext-toolchain-wrapper: $(STAMP_DIR)/ext-toolchain-installed
mkdir -p $(HOST_DIR)/usr/bin; cd $(HOST_DIR)/usr/bin; \
for i in $(TOOLCHAIN_EXTERNAL_CROSS)*; do \
- case "$$i" in \
+ base=$${i##*/}; \
+ case "$$base" in \
*cc|*cc-*|*++|*++-*|*cpp) \
- base=$${i##*/}; \
ln -sf $(@F) $$base; \
;; \
*) \