summaryrefslogtreecommitdiff
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-05-13 11:41:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-05-13 11:51:43 +0200
commite7e0d0771c3e6d962fc4a336e1fa7a709e6635b0 (patch)
treec37e1cd189a5b156f7c65c987aaa6186856a93ab /toolchain/toolchain-external
parente89b2626797bc25c415914491339b14defc091e7 (diff)
external-toolchain: Add MIPS CodeSourcery 2011.03
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/Config.in24
-rw-r--r--toolchain/toolchain-external/ext-tool.mk3
2 files changed, 27 insertions, 0 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 8e3f7989c..079c097aa 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -59,6 +59,29 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2009Q1
- ARMv4T, little endian, soft-float, glibc
- ARMv7-A, Thumb 2, little endian, soft-float, glibc
+config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
+ bool "CodeSourcery MIPS 2011.03"
+ depends on BR2_mips || BR2_mipsel
+ select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+ select BR2_INSTALL_LIBSTDCPP
+ help
+ Toolchain for the MIPS architecture, from CodeSourcery. It
+ uses gcc 4.5.2, binutils 2.20.51, glibc 2.13, uClibc 0.9.30
+ and gdb 7.2.50, kernel headers 2.6.38. It has support for
+ the following variants:
+ - MIPS32 O32 big endian glibc
+ - MIPS32 O32 little endian glibc
+ - MIPS32 big endian soft float glibc
+ - MIPS32 little endian soft float glibc
+ - MIPS32 big endian microMIPS glibc
+ - MIPS32 little endian microMIPS glibc
+ - MIPS32 big endian soft float microMIPS glibc
+ - MIPS32 little endian soft float microMIPS glibc
+ - MIPS32 big endian uclibc
+ - MIPS32 little endian uclibc
+ - MIPS32 big endian soft float uclibc
+ - MIPS32 little endian soft float uclibc
+
config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
bool "CodeSourcery MIPS 4.4"
depends on BR2_mips || BR2_mipsel
@@ -151,6 +174,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
default "mips-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
+ default "mips-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
default "powerpc-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009
default "sh-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_SH201009
default $(BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX) \
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 53fff614c..6d12ba7d3 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -177,6 +177,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.03-41-arm-none-linux-gnueabi-i686-pc-linux-gn
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
TOOLCHAIN_EXTERNAL_SITE=http://www.codesourcery.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103),y)
+TOOLCHAIN_EXTERNAL_SITE=http://www.codesourcery.com/sgpp/lite/mips/portal/package8715/public/mips-linux-gnu/
+TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.03-53-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009),y)
TOOLCHAIN_EXTERNAL_SITE=http://www.codesourcery.com/sgpp/lite/power/portal/package7703/public/powerpc-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=freescale-2010.09-55-powerpc-linux-gnu-i686-pc-linux-gnu.tar.bz2