summaryrefslogtreecommitdiff
path: root/toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 11:47:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 23:54:43 +0100
commit3a24927a0e6f041a018085b5a7fc50312001fddc (patch)
tree3ef525d640c1809fbb9a11799a29a89736ae4028 /toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch
parent9f21bfee0877be5ec1e3fe3a8cb98fa7de539827 (diff)
uclibc: add avr32 special version
* Add a new 0.9.30-avr32-2.1.5 version of uClibc in Config.in * Add a patch for 0.9.20-avr32-2.1.5 * Select a different UCLIBC_SITE for avr32 versions in uclibc.mk * Add the LINKRELAX=y configuration option to the uClibc .config file in uclibc.mk Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch')
-rw-r--r--toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch b/toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch
new file mode 100644
index 000000000..eb8888470
--- /dev/null
+++ b/toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch
@@ -0,0 +1,29 @@
+--- uClibc-0.9.30.1.orig/extra/scripts/unifdef.c
++++ uClibc-0.9.30.1/extra/scripts/unifdef.c
+@@ -206,7 +206,7 @@ static void done(void);
+ static void error(const char *);
+ static int findsym(const char *);
+ static void flushline(bool);
+-static Linetype getline(void);
++static Linetype get_line(void);
+ static Linetype ifeval(const char **);
+ static void ignoreoff(void);
+ static void ignoreon(void);
+@@ -512,7 +512,7 @@ process(void)
+
+ for (;;) {
+ linenum++;
+- lineval = getline();
++ lineval = get_line();
+ trans_table[ifstate[depth]][lineval]();
+ debug("process %s -> %s depth %d",
+ linetype_name[lineval],
+@@ -526,7 +526,7 @@ process(void)
+ * help from skipcomment().
+ */
+ static Linetype
+-getline(void)
++get_line(void)
+ {
+ const char *cp;
+ int cursym;