summaryrefslogtreecommitdiff
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-09-30 07:29:35 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-09-30 07:29:35 +0000
commit21eb2bfd61770291cff73fb8abc4e3296aad10f4 (patch)
tree26045a5822d528ec8d3e504766092cae6e89ce24 /toolchain/uClibc
parentcaf7ca606bebe661cf289855f0f3e9eff562e3df (diff)
uclibc: install headers after building headers in configure part
This patch will run "make headers install_headers" instead of the old "make headers install_dev". The latter requires a cross compiler available in uClibc versions > 0.9.29, and the cross compiler is not available at the configuration time of uClibc. Spotted and fixed by Bernhard Fischer. Tested-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/uclibc.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index dba5a96d9..e39e157c6 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -434,7 +434,7 @@ $(UCLIBC_DIR)/.configured: $(LINUX_HEADERS_DIR)/.configured $(UCLIBC_DIR)/.confi
DEVEL_PREFIX=/usr/ \
RUNTIME_PREFIX=$(TOOL_BUILD_DIR)/uClibc_dev/ \
HOSTCC="$(HOSTCC)" \
- headers install_dev
+ headers install_headers
# Install the kernel headers to the first stage gcc include dir
# if necessary
ifeq ($(LINUX_HEADERS_IS_KERNEL),y)