summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2009-01-12 12:54:30 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2009-01-12 12:54:30 +0000
commit215e91f132fcd8da2b90a0e1635d6f4f67084727 (patch)
treee2fbc56f313c3a7529985504449282df4fedf3a6 /toolchain
parent729cf4f6c3652ede8c30b4d2e4ac5eacca12679d (diff)
toolchain/external-toolchain/ext-tool.mk: Support non sysroot-able toolchains
Only copy the sysroot files if the toolchain was built with sysroot support. Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 8ff4722f3..1c9197b95 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -46,8 +46,8 @@ copy_toolchain_lib_root = \
copy_toolchain_sysroot = \
SYSROOT_DIR=`$(TARGET_CC) -v 2>&1 | grep ^Configured | tr " " "\n" | grep -- "--with-sysroot" | cut -f2 -d=`; \
- cp -a $${SYSROOT_DIR}/* $(STAGING_DIR)/ ; \
- find $(STAGING_DIR) -type d | xargs chmod 755
+ if [ -n "$${SYSROOT_DIR}" ]; then cp -a $${SYSROOT_DIR}/* $(STAGING_DIR)/ ; \
+ find $(STAGING_DIR) -type d | xargs chmod 755; fi
uclibc: dependencies $(TARGET_DIR)/lib/$(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C)))
@@ -59,4 +59,4 @@ $(TARGET_DIR)/lib/$(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C))):
for libs in $(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIBS))); do \
$(call copy_toolchain_lib_root, $$libs, /lib, $(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
done
- $(call copy_toolchain_sysroot) \ No newline at end of file
+ $(call copy_toolchain_sysroot)