summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 00:26:23 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 08:46:51 +0200
commit28aa0b47fb5bcb46ddcc24fdb5cc5466c094024f (patch)
treea38061b6020f55d705350b5e986bb240a31dcb41 /toolchain
parent3026e9930eaf9b287aa69c4ed7adfe34913afda3 (diff)
external toolchain: copy the C++ standard library if needed
Obey the BR2_INSTALL_LIBSTDCPP configuration option to copy the C++ standard library to the target. Suggested by Lionel Landwerlin <lionel.landwerlin@openwide.fr>. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 6df48f0b0..e772cda7e 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -190,6 +190,10 @@ else
EXTERNAL_LIBS+=ld-linux.so libnss_files.so
endif
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+EXTERNAL_LIBS+=libstdc++.so
+endif
+
SYSROOT_DIR=$(shell LANG=C $(TARGET_CC) -v 2>&1 | grep ^Configured | tr " " "\n" | grep -- "--with-sysroot" | cut -f2 -d=)
$(STAMP_DIR)/ext-toolchain-installed: