summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 00:25:35 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 08:46:43 +0200
commit3026e9930eaf9b287aa69c4ed7adfe34913afda3 (patch)
tree828e90bf17e3c31d880e459c4645e56e0fc406cf /toolchain
parent0afd2103f0dab1b86896890446e8999c72cef465 (diff)
external toolchain: do not copy useless symbolic links
Do not copy .so symbolic links to target when not needed. Only copy .so.X symbolic links and the library itself. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 0e1deb620..6df48f0b0 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -46,7 +46,7 @@ copy_toolchain_lib_root = \
STRIP="$(strip $4)"; \
\
LIB_DIR="$${SYSROOT_DIR}/lib" ; \
- for FILE in `find $${LIB_DIR} -maxdepth 1 -type l -name "$${LIB}*"`; do \
+ for FILE in `find $${LIB_DIR} -maxdepth 1 -name "$${LIB}.*"`; do \
LIB=`basename $${FILE}`; \
while test \! -z "$${LIB}"; do \
rm -fr $(TARGET_DIR)$${DST}/$${LIB}; \