summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-06-17 13:46:54 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-06-17 13:46:54 +0200
commit627fc43262ec3efaa01f2140ee0710e7ee4b07e2 (patch)
treedb5a1cbe17daf277029cde34af883043b25b0a23 /toolchain
parentb2c419106620042a7660a0a6995fa259856ce58b (diff)
parent9456b58a8b3b4efdd8038a68370acf618aa9465b (diff)
Merge branch 'external-toolchain' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/external-toolchain/Config.in25
-rw-r--r--toolchain/external-toolchain/ext-tool.mk75
2 files changed, 77 insertions, 23 deletions
diff --git a/toolchain/external-toolchain/Config.in b/toolchain/external-toolchain/Config.in
index 71dad0d76..efc8378c0 100644
--- a/toolchain/external-toolchain/Config.in
+++ b/toolchain/external-toolchain/Config.in
@@ -1,22 +1,17 @@
#
if BR2_TOOLCHAIN_EXTERNAL
-config BR2_TOOLCHAIN_EXTERNAL_LIB_C
- string "The core C library from the external toolchain"
- default "libc.so.0"
- help
- Specify the core C shared library found in the external
- toolchain. This is required in addition to any other
- libraries to be copied.
+choice
+ prompt "External toolchain C library"
+ default BR2_TOOLCHAIN_EXTERNAL_UCLIBC
-config BR2_TOOLCHAIN_EXTERNAL_LIBS
- string "Libraries to copy from the external toolchain"
- default "ld-uClibc.so.0 libcrypt.so.0 libdl.so.0 libgcc_s.so libm.so.0 libnsl.so.0 libpthread.so.0 libresolv.so.0 librt.so.0 libutil.so.0"
- help
- A space separated list of the shared libraries to be copied
- from the external toolchain into the root filesystem. Only
- the top-level name is needed, i.e. libc.so, libpthread.so as
- the actual shared library symlinked to will be copied also.
+config BR2_TOOLCHAIN_EXTERNAL_UCLIBC
+ bool "uClibc"
+
+config BR2_TOOLCHAIN_EXTERNAL_GLIBC
+ bool "glibc"
+
+endchoice
config BR2_TOOLCHAIN_EXTERNAL_STRIP
bool
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 1c9197b95..b904775f4 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -21,7 +21,6 @@ copy_toolchain_lib_root = \
for FILE in `find $${LIB_DIR} -maxdepth 1 -type l -name "$${LIB}*"`; do \
LIB=`basename $${FILE}`; \
while test \! -z "$${LIB}"; do \
- echo "copy_toolchain_lib_root lib=$${LIB} dst=$${DST}"; \
rm -fr $(TARGET_DIR)$${DST}/$${LIB}; \
mkdir -p $(TARGET_DIR)$${DST}; \
if test -h $${LIB_DIR}/$${LIB}; then \
@@ -49,14 +48,74 @@ copy_toolchain_sysroot = \
if [ -n "$${SYSROOT_DIR}" ]; then cp -a $${SYSROOT_DIR}/* $(STAGING_DIR)/ ; \
find $(STAGING_DIR) -type d | xargs chmod 755; fi
-uclibc: dependencies $(TARGET_DIR)/lib/$(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C)))
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
+EXTERNAL_LIBC=libc.so.0
+EXTERNAL_LIBS=ld-uClibc.so.0 libcrypt.so.0 libdl.so.0 libgcc_s.so libm.so.0 libnsl.so.0 libpthread.so.0 libresolv.so.0 librt.so.0 libutil.so.0
+else
+EXTERNAL_LIBC=libc.so.6
+EXTERNAL_LIBS=ld-linux.so.3 libcrypt.so.1 libdl.so.2 libgcc_s.so.1 libm.so.6 libnsl.so.1 libpthread.so.0 libresolv.so.2 librt.so.1 libutil.so.1 libnss_files.so.2
+endif
-$(TARGET_DIR)/lib/$(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C))):
-#"))
+check_clibrary = \
+ if ! test -f `$(TARGET_CC) -print-file-name=$(EXTERNAL_LIBC)` ; then \
+ echo "Incorrect selection of the C library"; \
+ exit -1; \
+ fi
+
+# 1: Buildroot option name
+# 2: message
+check_glibc_feature = \
+ if [ x$($(1)) != x"y" ] ; then \
+ echo "$(2) available in C library, please enable $(1)" ; \
+ exit 1 ; \
+ fi
+
+check_glibc = \
+ $(call check_glibc_feature,BR2_LARGEFILE,Large file support) ;\
+ $(call check_glibc_feature,BR2_INET_IPV6,IPv6 support) ;\
+ $(call check_glibc_feature,BR2_INET_RPC,RPC support) ;\
+ $(call check_glibc_feature,BR2_ENABLE_LOCALE,Locale support) ;\
+ $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support)
+
+# 1: uClibc macro name
+# 2: Buildroot option name
+# 3: uClibc config file
+# 4: message
+check_uclibc_feature = \
+ IS_IN_LIBC=`grep -q "\#define $(1) 1" $(3) && echo y` ; \
+ if [ x$($(2)) != x"y" -a x$${IS_IN_LIBC} == x"y" ] ; then \
+ echo "$(4) available in C library, please enable $(2)" ; \
+ exit 1 ; \
+ fi ; \
+ if [ x$($(2)) == x"y" -a x$${IS_IN_LIBC} != x"y" ] ; then \
+ echo "$(4) not available in C library, please disable $(2)" ; \
+ exit 1 ; \
+ fi
+
+check_uclibc = \
+ SYSROOT_DIR=`$(TARGET_CC) -v 2>&1 | grep ^Configured | tr " " "\n" | grep -- "--with-sysroot" | cut -f2 -d=`; \
+ UCLIBC_CONFIG_FILE=$${SYSROOT_DIR}/usr/include/bits/uClibc_config.h ; \
+ $(call check_uclibc_feature,__UCLIBC_HAS_LFS__,BR2_LARGEFILE,$${UCLIBC_CONFIG_FILE},Large file support) ;\
+ $(call check_uclibc_feature,__UCLIBC_HAS_IPV6__,BR2_INET_IPV6,$${UCLIBC_CONFIG_FILE},IPv6 support) ;\
+ $(call check_uclibc_feature,__UCLIBC_HAS_RPC__,BR2_INET_RPC,$${UCLIBC_CONFIG_FILE},RPC support) ;\
+ $(call check_uclibc_feature,__UCLIBC_HAS_LOCALE__,BR2_ENABLE_LOCALE,$${UCLIBC_CONFIG_FILE},Locale support) ;\
+ $(call check_uclibc_feature,__UCLIBC_HAS_WCHAR__,BR2_USE_WCHAR,$${UCLIBC_CONFIG_FILE},Wide char support) ;\
+
+uclibc: dependencies $(TARGET_DIR)/lib/$(EXTERNAL_LIBC)
+
+$(TARGET_DIR)/lib/$(EXTERNAL_LIBC):
+ @echo "Checking external toolchain settings"
+ @$(call check_clibrary)
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
+ @$(call check_uclibc)
+else
+ @$(call check_glibc)
+endif
mkdir -p $(TARGET_DIR)/lib
- @$(call copy_toolchain_lib_root, $(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C))), /lib, $(BR2_TOOLCHAIN_EXTERNAL_STRIP))
-#")))
- for libs in $(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIBS))); do \
+ @echo "Copy external toolchain libraries to target..."
+ @$(call copy_toolchain_lib_root, $(EXTERNAL_LIBC), /lib, $(BR2_TOOLCHAIN_EXTERNAL_STRIP))
+ @for libs in $(EXTERNAL_LIBS); do \
$(call copy_toolchain_lib_root, $$libs, /lib, $(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
done
- $(call copy_toolchain_sysroot)
+ @echo "Copy external toolchain sysroot to staging..."
+ @$(call copy_toolchain_sysroot)