summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 08:48:35 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 08:48:35 +0200
commit82bf777ed73f449587aea59a6ce5b41164a6819f (patch)
treebcd117cc49810f411ca1647070a2f63098df0138 /toolchain
parent28aa0b47fb5bcb46ddcc24fdb5cc5466c094024f (diff)
external toolchain: respect $(Q)
Use $(Q) in external toolchain support so that the user can get the full output by passing V=1 to make, and still get a nice and clean output by default. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index e772cda7e..c9692a1ab 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -203,18 +203,18 @@ ifeq ($(strip $(SYSROOT_DIR)),)
exit 1
endif
ifeq ($(BR2_arm),y)
- @$(call check_arm_abi)
+ $(Q)$(call check_arm_abi)
endif
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
- @$(call check_uclibc,$(SYSROOT_DIR))
+ $(Q)$(call check_uclibc,$(SYSROOT_DIR))
else
- @$(call check_glibc,$(SYSROOT_DIR))
+ $(Q)$(call check_glibc,$(SYSROOT_DIR))
endif
mkdir -p $(TARGET_DIR)/lib
@echo "Copy external toolchain libraries to target..."
- @for libs in $(EXTERNAL_LIBS); do \
+ $(Q)for libs in $(EXTERNAL_LIBS); do \
$(call copy_toolchain_lib_root,$(SYSROOT_DIR),$$libs,/lib,$(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
done
@echo "Copy external toolchain sysroot to staging..."
- @$(call copy_toolchain_sysroot,$(SYSROOT_DIR))
+ $(Q)$(call copy_toolchain_sysroot,$(SYSROOT_DIR))
@touch $@