summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-24 16:34:28 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-24 16:34:28 +0000
commit134a26b0faf10a4aabf5ce6023f2d84fdcf2c4bb (patch)
tree73b529e10fd9659894d0a532cb586b4aa6ec72c6 /toolchain
parent049f3fc20a6149b4794965b401cfd6a341b42d42 (diff)
- adjust lzma arguments for current version
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/kernel-headers/linux-2.6.21.5-002-lzma-vmlinuz.01.patch54
-rw-r--r--toolchain/kernel-headers/linux-2.6.22.1-002-lzma-vmlinuz.01.patch21
2 files changed, 75 insertions, 0 deletions
diff --git a/toolchain/kernel-headers/linux-2.6.21.5-002-lzma-vmlinuz.01.patch b/toolchain/kernel-headers/linux-2.6.21.5-002-lzma-vmlinuz.01.patch
new file mode 100644
index 000000000..05361ff9d
--- /dev/null
+++ b/toolchain/kernel-headers/linux-2.6.21.5-002-lzma-vmlinuz.01.patch
@@ -0,0 +1,54 @@
+diff -rdup linux-2.6.21.5.oorig/arch/i386/boot/compressed/Makefile linux-2.6.21.5/arch/i386/boot/compressed/Makefile
+--- linux-2.6.21.5.oorig/arch/i386/boot/compressed/Makefile 2007-07-24 13:08:51.000000000 +0200
++++ linux-2.6.21.5/arch/i386/boot/compressed/Makefile 2007-07-24 14:54:38.000000000 +0200
+@@ -4,7 +4,7 @@
+ # create a compressed vmlinux image from the original vmlinux
+ #
+
+-tragets := head.o lzma_misc.o piggy.o \
++targets := head.o lzma_misc.o piggy.o \
+ vmlinux.bin.all vmlinux.relocs \
+ vmlinux vmlinux.bin vmlinux.bin.gz
+ EXTRA_AFLAGS := -traditional
+diff -rdup linux-2.6.21.5.oorig/scripts/gen_lzma_initramfs_list.sh linux-2.6.21.5/scripts/gen_lzma_initramfs_list.sh
+--- linux-2.6.21.5.oorig/scripts/gen_lzma_initramfs_list.sh 2007-07-24 13:08:51.000000000 +0200
++++ linux-2.6.21.5/scripts/gen_lzma_initramfs_list.sh 2007-07-24 15:12:10.000000000 +0200
+@@ -253,7 +253,7 @@ while [ $# -gt 0 ]; do
+ shift
+ ;;
+ "-s")
+- opt="-d16"
++ #opt="-d16" ? what was that supposed to do?
+ ;;
+ "-d") # display default initramfs list
+ default_list="$arg"
+@@ -286,7 +286,7 @@ if [ ! -z ${output_file} ]; then
+ cpio_tfile=${cpio_file}
+ fi
+ rm ${cpio_list}
+- lzma e ${cpio_tfile} ${output_file} ${opt}
++ lzma -z ${cpio_tfile} ${opt} -c > ${output_file}
+ [ -z ${cpio_file} ] && rm ${cpio_tfile}
+ fi
+ exit 0
+--- linux-2.6.21.5.oorig/arch/i386/boot/compressed/lzma_misc.c 2007-07-24 15:24:44.000000000 +0200
++++ linux-2.6.21.5/arch/i386/boot/compressed/lzma_misc.c 2007-07-24 17:09:40.000000000 +0200
+@@ -241,7 +241,6 @@ static int lzma_unzip(uch* output)
+
+ static int read_byte(void *object, const unsigned char **buffer, SizeT *bufferSize)
+ {
+- static unsigned int i = 0;
+ static unsigned char val;
+ *bufferSize = 1;
+ val = get_byte();
+--- linux-2.6.21.5.oorig/scripts/Makefile.lib 2007-07-24 15:24:44.000000000 +0200
++++ linux-2.6.21.5/scripts/Makefile.lib 2007-07-24 18:03:57.000000000 +0200
+@@ -165,6 +165,7 @@ cmd_gzip = gzip -f -9 < $< > $@
+ # LZMA
+ #
+ quiet_cmd_lzma = LZMA $@
+-cmd_lzma = lzma e $< $@ -lc7 -lp0 -pb0 2>/dev/null
++#cmd_lzma = lzma e $< $@ -lc7 -lp0 -pb0 2>/dev/null
++cmd_lzma = lzma -z $< -c > $@
+
+
diff --git a/toolchain/kernel-headers/linux-2.6.22.1-002-lzma-vmlinuz.01.patch b/toolchain/kernel-headers/linux-2.6.22.1-002-lzma-vmlinuz.01.patch
index 5949a1136..05361ff9d 100644
--- a/toolchain/kernel-headers/linux-2.6.22.1-002-lzma-vmlinuz.01.patch
+++ b/toolchain/kernel-headers/linux-2.6.22.1-002-lzma-vmlinuz.01.patch
@@ -31,3 +31,24 @@ diff -rdup linux-2.6.21.5.oorig/scripts/gen_lzma_initramfs_list.sh linux-2.6.21.
[ -z ${cpio_file} ] && rm ${cpio_tfile}
fi
exit 0
+--- linux-2.6.21.5.oorig/arch/i386/boot/compressed/lzma_misc.c 2007-07-24 15:24:44.000000000 +0200
++++ linux-2.6.21.5/arch/i386/boot/compressed/lzma_misc.c 2007-07-24 17:09:40.000000000 +0200
+@@ -241,7 +241,6 @@ static int lzma_unzip(uch* output)
+
+ static int read_byte(void *object, const unsigned char **buffer, SizeT *bufferSize)
+ {
+- static unsigned int i = 0;
+ static unsigned char val;
+ *bufferSize = 1;
+ val = get_byte();
+--- linux-2.6.21.5.oorig/scripts/Makefile.lib 2007-07-24 15:24:44.000000000 +0200
++++ linux-2.6.21.5/scripts/Makefile.lib 2007-07-24 18:03:57.000000000 +0200
+@@ -165,6 +165,7 @@ cmd_gzip = gzip -f -9 < $< > $@
+ # LZMA
+ #
+ quiet_cmd_lzma = LZMA $@
+-cmd_lzma = lzma e $< $@ -lc7 -lp0 -pb0 2>/dev/null
++#cmd_lzma = lzma e $< $@ -lc7 -lp0 -pb0 2>/dev/null
++cmd_lzma = lzma -z $< -c > $@
+
+