summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-10-14 09:50:02 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-15 23:01:03 +0200
commit211916ed46e99c8b5c82ddba62f20371e6a86b01 (patch)
tree1d8c06c5b2a5cb536147f3400b8872cc732f468b /toolchain
parentbde4564fa74cc25a088aa4173709894d2acf5844 (diff)
dependencies: additional check for PERL_MM_OPT
When the user has Perl local::lib installed, its environment contains a PERL_MM_OPT variables which defines INSTALL_BASE="/some/location". Unfortunately, having this makes the build of libxml-parser-perl (and probably other Perl related packages) fail, because it complains that both PREFIX (passed in our .mk file) and INSTALL_BASE (passed from the PERL_MM_OPT environment variable) are defined. Since in Buildroot we want our PREFIX to be considered, we error out when the user has PERL_MM_OPT defined. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rwxr-xr-xtoolchain/dependencies/dependencies.sh8
1 files changed, 8 insertions, 0 deletions
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index 410f663fa..2b9c0b373 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -40,6 +40,14 @@ if test -n "$PATH" ; then
fi
fi;
+if test -n "$PERL_MM_OPT" ; then
+ /bin/echo -e "\nYou have PERL_MM_OPT defined because Perl local::lib"
+ /bin/echo -e "is installed on your system. Please unset this variable"
+ /bin/echo -e "before starting Buildroot, otherwise the compilation of"
+ /bin/echo -e "Perl related packages will fail"
+ exit 1
+fi
+
# Verify that which is installed
if ! which which > /dev/null ; then
/bin/echo -e "\nYou must install 'which' on your build machine\n";