summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-15 22:35:26 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-15 22:35:26 +0000
commit406eeeeeb7483b2ca02415e4e77db92fd4b39a09 (patch)
tree6d994d009b07ac34ff729922aab86229df8342ad /toolchain
parente4bbaa38c30f9284f66c18203708a32dcfa27c3f (diff)
Allow user to configure PROGRAM_INVOCATION_NAME
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/Config.in9
-rw-r--r--toolchain/uClibc/uclibc.mk5
2 files changed, 14 insertions, 0 deletions
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index a43161ca7..455731c70 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -82,3 +82,12 @@ config BR2_PTHREAD_DEBUG
default n
help
Build the thread library with debugging enabled.
+
+config BR2_UCLIBC_PROGRAM_INVOCATION
+ bool "Enable 'program invocation name'"
+ default n
+ help
+ Support for the GNU-specific program_invocation_name and
+ program_invocation_short_name strings. Some GNU packages
+ (like tar and coreutils) utilize these for extra useful
+ output, but in general are not required.
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index ebcc56862..395558f9b 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -229,6 +229,11 @@ ifeq ($(BR2_USE_WCHAR),y)
else
$(SED) 's,^.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=n,g' $(UCLIBC_DIR)/.oldconfig
endif
+ifeq ($(BR2_UCLIBC_PROGRAM_INVOCATION),y)
+ echo "UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y" >> $(UCLIBC_DIR)/.oldconfig
+else
+ echo "# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set" >> $(UCLIBC_DIR)/.oldconfig
+endif
ifeq ("$(KERNEL_ARCH)","i386")
/bin/echo "# CONFIG_GENERIC_386 is not set" >> $(UCLIBC_DIR)/.oldconfig
/bin/echo "# CONFIG_386 is not set" >> $(UCLIBC_DIR)/.oldconfig