summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-21 11:50:10 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-21 11:50:10 +0000
commit50399135542bfb1d7f49ff276f47081313d1426d (patch)
tree79567b3ef56e9f8ae1490b24aa8ad854003de8fa /toolchain
parentec150063edd58288158f3a38f534798cfa30ea73 (diff)
- handle all gcc-4.x for the softfloat case.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile.in6
1 files changed, 2 insertions, 4 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 1dcfcba12..41e23cf59 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -22,6 +22,7 @@ endif
ifeq ($(strip $(BR2_GCC_USE_SJLJ_EXCEPTIONS)),y)
GCC_USE_SJLJ_EXCEPTIONS:=--enable-sjlj-exceptions
endif
+
ifeq ($(BR2_SOFT_FLOAT),y)
# gcc 3.4.x soft float configuration is different than previous versions.
ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
@@ -30,10 +31,7 @@ else
SOFT_FLOAT_CONFIG_OPTION:=--without-float
endif
# again... there must be a better way
-ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
-SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
-endif
-ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
+ifeq ($(findstring 4.,$(GCC_VERSION)),4.)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
endif
TARGET_SOFT_FLOAT:=-msoft-float