summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 21:28:56 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 21:28:56 +0000
commit581bc450f558f7df0c0e90788b44422472f22bdf (patch)
tree052660885190c86cc525b36e526cc26a459c7ec6 /toolchain
parentbb05a9ad46cd8c743ccdda99578ca424073f7a4d (diff)
Fixup SOFT_FLOAT handling
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in5
-rw-r--r--toolchain/gcc/Makefile.in2
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk6
3 files changed, 4 insertions, 9 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 719a2ca96..704f74e42 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -38,11 +38,6 @@ config BR2_SOFT_FLOAT
Most people will answer N.
-config SOFT_FLOAT
- string
- depends on BR2_SOFT_FLOAT
- default "true"
-
config BR2_TARGET_OPTIMIZATION
string "Target Optimizations"
default "-Os -pipe"
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 1e62dd26d..752519655 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -6,7 +6,7 @@ TARGET_OPTIMIZATION:=$(strip $(subst ",, $(BR2_TARGET_OPTIMIZATION)))
#""
-ifeq ($(SOFT_FLOAT),true)
+ifeq ($(BR2_SOFT_FLOAT),y)
# gcc 3.4.x soft float configuration is different than previous versions.
ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 2d15b6f3c..fb9794bfd 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -73,7 +73,7 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# However, we still need a patch for arm. There's a similar patch for gcc 3.3.x
# which needs to be integrated so we can kill of libfloat for good, except for
# anyone (?) who might still be using gcc 2.95. mjn3
-ifeq ($(SOFT_FLOAT),true)
+ifeq ($(BR2_SOFT_FLOAT),y)
ifeq ("$(strip $(ARCH))","arm")
toolchain/patch-kernel.sh $(GCC_DIR) toolchain/gcc/$(GCC_VERSION) arm-softfloat.patch.conditional
endif
@@ -190,7 +190,7 @@ endif
#
# Now for the ugly 3.3.x soft float hack...
#
-ifeq ($(SOFT_FLOAT),true)
+ifeq ($(BR2_SOFT_FLOAT),y)
ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
# Make sure we have a soft float specs file for this arch
if [ ! -f toolchain/gcc/$(GCC_VERSION)/specs-$(ARCH)-soft-float ] ; then \
@@ -279,7 +279,7 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
#
# Now for the ugly 3.3.x soft float hack...
#
-ifeq ($(SOFT_FLOAT),true)
+ifeq ($(BR2_SOFT_FLOAT),y)
ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
# Add a specs file that defaults to soft float mode.
cp toolchain/gcc/$(GCC_VERSION)/specs-$(ARCH)-soft-float $(TARGET_DIR)/usr/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs