summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 11:59:44 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 23:54:44 +0100
commit636afc4664238b9555411622f45ff4d00ceffcde (patch)
tree1b4f5c778714622e7ad2b9ef215142d886f0eec3 /toolchain
parent5c6ccd9f20a9aec2d26bcbb32f17a027b333ace3 (diff)
gcc: improve configuration for snapshot versions
Make the selection of a snapshot version a normal gcc version choice, and make sure BR2_GCC_VERSION is properly defined. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in11
-rw-r--r--toolchain/gcc/Makefile.in2
2 files changed, 7 insertions, 6 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 07e42a6da..10cb841a1 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -55,11 +55,11 @@ choice
config BR2_GCC_VERSION_4_4_X
depends on !BR2_avr32 && !BR2_nios2
bool "gcc 4.4.x"
-endchoice
-config BR2_GCC_IS_SNAP
- depends on !BR2_avr32
- bool
+ config BR2_GCC_VERSION_SNAP
+ depends on !BR2_avr32 && !BR2_nios2
+ bool "gcc snapshot"
+endchoice
config BR2_GCC_SUPPORTS_SYSROOT
bool
@@ -72,7 +72,7 @@ config BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
config BR2_GCC_SNAP_DATE
string "GCC snapshot date"
default "20070921"
- depends on BR2_GCC_IS_SNAP
+ depends on BR2_GCC_VERSION_SNAP
help
Enter snapshot date to use for gcc. Format is:
YYYYMMDD
@@ -89,6 +89,7 @@ config BR2_GCC_VERSION
default "4.3.3" if BR2_GCC_VERSION_4_3_3
default "4.3.4" if BR2_GCC_VERSION_4_3_4
default "4.4.2" if BR2_GCC_VERSION_4_4_X
+ default $BR2_GCC_SNAP_DATE if BR2_GCC_VERSION_SNAP
config BR2_TOOLCHAIN_SYSROOT
bool "Enable toolchain with --sysroot support"
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index e92ecbc7b..c3e21cf35 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -8,7 +8,7 @@ GCC_VERSION:=$(call qstrip,$(BR2_GCC_VERSION))
TARGET_OPTIMIZATION:=$(call qstrip,$(BR2_TARGET_OPTIMIZATION))
EXTRA_GCC_CONFIG_OPTIONS:=$(call qstrip,$(BR2_EXTRA_GCC_CONFIG_OPTIONS))
-ifeq ($(call qstrip,$(BR2_GCC_IS_SNAP)),y)
+ifeq ($(call qstrip,$(BR2_GCC_VERSION_SNAP)),y)
GCC_SNAP_DATE:=$(call qstrip,$(BR2_GCC_SNAP_DATE))
else
GCC_SNAP_DATE:=