summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-12 13:38:06 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-12 13:38:06 +0000
commit99cf7293f9eb943e00e2ebca6eee0e36eaa801bd (patch)
tree1ae33b5d2518286eafc5154cdecb2fd9ed0e3f97 /toolchain
parente5b36a686c563bc667406b9e148e9a72948505be (diff)
- add cc-option and use it to check for stuff that is benefical for PREFER_IMA
- backport the libbackend.o gcov-iov.h dependency fixup from 4.2 to 4.0
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Makefile.in3
-rw-r--r--toolchain/gcc/4.0.4/402-libbackend_dep_gcov-iov.h.patch11
2 files changed, 14 insertions, 0 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 1a2c0f26f..84e2ae42f 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -14,5 +14,8 @@ endif
# FIXME -- this is temporary
OPTIMIZE_FOR_CPU=$(ARCH)
+# late binding check to see if the target cc supports -fwhole-program
+CFLAGS_WHOLE_PROGRAM = $(call cc-option,-fwhole-program,)
+
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in
diff --git a/toolchain/gcc/4.0.4/402-libbackend_dep_gcov-iov.h.patch b/toolchain/gcc/4.0.4/402-libbackend_dep_gcov-iov.h.patch
new file mode 100644
index 000000000..89196d9fa
--- /dev/null
+++ b/toolchain/gcc/4.0.4/402-libbackend_dep_gcov-iov.h.patch
@@ -0,0 +1,11 @@
+--- gcc-4.0.4.orig/gcc/Makefile.in 2007-02-12 11:35:43.000000000 +0100
++++ gcc-4.0.4/gcc/Makefile.in 2007-02-12 11:38:04.000000000 +0100
+@@ -2202,7 +2202,7 @@ mips-tdump.o : mips-tdump.c $(CONFIG_H)
+ # FIXME: writing proper dependencies for this is a *LOT* of work.
+ libbackend.o : $(OBJS-common:.o=.c) $(out_file) \
+ insn-config.h insn-flags.h insn-codes.h insn-constants.h \
+- insn-attr.h
++ insn-attr.h gcov-iov.h
+ $(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
+ -DTARGET_NAME=\"$(target_noncanonical)\" \
+ -DLOCALEDIR=\"$(localedir)\" \