summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-30 23:09:39 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-30 23:09:39 +0200
commitd0c3d1cf4365a80ba2ec35eef0c3ed7ac907f320 (patch)
tree5a0fb23dd1ca87094957e5b639b9e1a91fcf4e57 /toolchain
parent57bc22c6b7ebef4b8b203dce6af4966ed719acef (diff)
sed: get rid of host-sed variant
And all the infrastructure surrounding it. A broken sed implementation is quite rare nowadays, as seen by the fact that the current host-sed support has been broken for a while, so just get rid of it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rwxr-xr-xtoolchain/dependencies/check-host-sed.sh35
-rw-r--r--toolchain/dependencies/dependencies.mk6
-rwxr-xr-xtoolchain/dependencies/dependencies.sh33
-rw-r--r--toolchain/uClibc/uclibc.mk2
4 files changed, 16 insertions, 60 deletions
diff --git a/toolchain/dependencies/check-host-sed.sh b/toolchain/dependencies/check-host-sed.sh
deleted file mode 100755
index ed9a1d4db..000000000
--- a/toolchain/dependencies/check-host-sed.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-SEDLIST="/usr/bin/sed /bin/sed sed gnused gsed"
-
-for SED in $SEDLIST
-do
- if ! test -x $SED ; then
- SED=$(which $SED 2> /dev/null)
- if ! test -x "$SED" > /dev/null ; then
- SED=""
- continue
- fi
- fi
-
- tmp=$(mktemp)
- echo "HELLO" > $tmp
- $SED -i -e "s/HELLO/GOODBYE/" $tmp >/dev/null 2>&1
- RESULT=$(cat $tmp)
-
- if test $? != 0 ; then
- SED=""
- elif test -e ".sedtest-e" ; then
- rm -f ".sedtest-e"
- SED=""
- elif [ "x$RESULT" = "x" ] || [ "$RESULT" != "GOODBYE" ] > /dev/null ;
- then
- SED=""
- fi
-
- rm -f $tmp
- if [ ! -z "$SED" ] ; then
- break
- fi
-done
-echo $SED
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index b334811ac..89ffd8823 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -9,13 +9,9 @@ DEPENDENCIES_HOST_PREREQ:=
ifeq ($(BR2_STRIP_sstrip),y)
DEPENDENCIES_HOST_PREREQ+=sstrip_host
endif
-ifneq ($(findstring y,$(BR2_KERNEL_HEADERS_LZMA)),)
-DEPENDENCIES_HOST_PREREQ+=host-lzma
-endif
-dependencies: host-sed $(DEPENDENCIES_HOST_PREREQ)
+dependencies: $(DEPENDENCIES_HOST_PREREQ)
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
- HOST_SED_DIR="$(HOST_SED_DIR)" \
CONFIG_FILE="$(CONFIG_DIR)/.config" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index b47e9d81e..ee21b3780 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -55,14 +55,9 @@ if ! which which > /dev/null ; then
exit 1;
fi;
-# Check sed
-SED=$(toolchain/dependencies/check-host-sed.sh)
-
-if [ -z "$SED" ] ; then
- XSED=$HOST_SED_DIR/bin/sed
- /bin/echo -e "\nSed doesn't work, using buildroot version instead\n"
-else
- XSED=$SED
+if ! which sed > /dev/null ; then
+ /bin/echo -e "\nYou must install 'sed' on your build machine\n"
+ exit 1
fi
# Check make
@@ -71,13 +66,13 @@ if [ -z "$MAKE" ] ; then
/bin/echo -e "\nYou must install 'make' on your build machine\n";
exit 1;
fi;
-MAKE_VERSION=$($MAKE --version 2>&1 | $XSED -e 's/^.* \([0-9\.]\)/\1/g' -e 's/[-\ ].*//g' -e '1q')
+MAKE_VERSION=$($MAKE --version 2>&1 | sed -e 's/^.* \([0-9\.]\)/\1/g' -e 's/[-\ ].*//g' -e '1q')
if [ -z "$MAKE_VERSION" ] ; then
/bin/echo -e "\nYou must install 'make' on your build machine\n";
exit 1;
fi;
-MAKE_MAJOR=$(echo $MAKE_VERSION | $XSED -e "s/\..*//g")
-MAKE_MINOR=$(echo $MAKE_VERSION | $XSED -e "s/^$MAKE_MAJOR\.//g" -e "s/\..*//g" -e "s/[a-zA-Z].*//g")
+MAKE_MAJOR=$(echo $MAKE_VERSION | sed -e "s/\..*//g")
+MAKE_MINOR=$(echo $MAKE_VERSION | sed -e "s/^$MAKE_MAJOR\.//g" -e "s/\..*//g" -e "s/[a-zA-Z].*//g")
if [ $MAKE_MAJOR -lt 3 ] || [ $MAKE_MAJOR -eq 3 -a $MAKE_MINOR -lt 81 ] ; then
/bin/echo -e "\nYou have make '$MAKE_VERSION' installed. GNU make >=3.81 is required\n"
exit 1;
@@ -93,14 +88,14 @@ if [ -z "$COMPILER" ] ; then
exit 1;
fi;
-COMPILER_VERSION=$($COMPILER -v 2>&1 | $XSED -n '/^gcc version/p' |
- $XSED -e 's/^gcc version \([0-9\.]\)/\1/g' -e 's/[-\ ].*//g' -e '1q')
+COMPILER_VERSION=$($COMPILER -v 2>&1 | sed -n '/^gcc version/p' |
+ sed -e 's/^gcc version \([0-9\.]\)/\1/g' -e 's/[-\ ].*//g' -e '1q')
if [ -z "$COMPILER_VERSION" ] ; then
/bin/echo -e "\nYou must install 'gcc' on your build machine\n";
exit 1;
fi;
-COMPILER_MAJOR=$(echo $COMPILER_VERSION | $XSED -e "s/\..*//g")
-COMPILER_MINOR=$(echo $COMPILER_VERSION | $XSED -e "s/^$COMPILER_MAJOR\.//g" -e "s/\..*//g")
+COMPILER_MAJOR=$(echo $COMPILER_VERSION | sed -e "s/\..*//g")
+COMPILER_MINOR=$(echo $COMPILER_VERSION | sed -e "s/^$COMPILER_MAJOR\.//g" -e "s/\..*//g")
if [ $COMPILER_MAJOR -lt 3 -o $COMPILER_MAJOR -eq 2 -a $COMPILER_MINOR -lt 95 ] ; then
echo "\nYou have gcc '$COMPILER_VERSION' installed. gcc >= 2.95 is required\n"
exit 1;
@@ -116,14 +111,14 @@ if [ -z "$CXXCOMPILER" ] ; then
#exit 1
fi
if [ ! -z "$CXXCOMPILER" ] ; then
- CXXCOMPILER_VERSION=$($CXXCOMPILER -v 2>&1 | $XSED -n '/^gcc version/p' |
- $XSED -e 's/^gcc version \([0-9\.]\)/\1/g' -e 's/[-\ ].*//g' -e '1q')
+ CXXCOMPILER_VERSION=$($CXXCOMPILER -v 2>&1 | sed -n '/^gcc version/p' |
+ sed -e 's/^gcc version \([0-9\.]\)/\1/g' -e 's/[-\ ].*//g' -e '1q')
if [ -z "$CXXCOMPILER_VERSION" ] ; then
/bin/echo -e "\nYou may have to install 'g++' on your build machine\n"
fi
- CXXCOMPILER_MAJOR=$(echo $CXXCOMPILER_VERSION | $XSED -e "s/\..*//g")
- CXXCOMPILER_MINOR=$(echo $CXXCOMPILER_VERSION | $XSED -e "s/^$CXXCOMPILER_MAJOR\.//g" -e "s/\..*//g")
+ CXXCOMPILER_MAJOR=$(echo $CXXCOMPILER_VERSION | sed -e "s/\..*//g")
+ CXXCOMPILER_MINOR=$(echo $CXXCOMPILER_VERSION | sed -e "s/^$CXXCOMPILER_MAJOR\.//g" -e "s/\..*//g")
if [ $CXXCOMPILER_MAJOR -lt 3 -o $CXXCOMPILER_MAJOR -eq 2 -a $CXXCOMPILER_MINOR -lt 95 ] ; then
/bin/echo -e "\nYou have g++ '$CXXCOMPILER_VERSION' installed. g++ >= 2.95 is required\n"
exit 1
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 4fb9393a9..1ed40cc67 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -425,7 +425,7 @@ $(UCLIBC_DIR)/lib/libc.a: $(UCLIBC_DIR)/.configured $(gcc_intermediate) $(LIBFLO
all
touch -c $@
-uclibc-menuconfig: host-sed dirs $(UCLIBC_DIR)/.config
+uclibc-menuconfig: dirs $(UCLIBC_DIR)/.config
$(MAKE1) -C $(UCLIBC_DIR) \
ARCH="$(UCLIBC_TARGET_ARCH)" \
PREFIX=$(TOOLCHAIN_DIR)/uClibc_dev/ \