summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 06:13:40 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 06:13:40 +0000
commitf694016136c155f23f5cec2eb7c076c9442d846a (patch)
treed80d83cfd41783a615d5a8d2a587fee376622539 /toolchain
parentae2792b44cea4a9773719d4407be7e1878b73b26 (diff)
final step in buildroot facelift
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/ccache/Config.in8
-rw-r--r--toolchain/ccache/Config.in.28
-rw-r--r--toolchain/ccache/Makefile.in5
-rw-r--r--toolchain/gcc/Config.in.28
-rw-r--r--toolchain/gcc/Makefile.in5
5 files changed, 26 insertions, 8 deletions
diff --git a/toolchain/ccache/Config.in b/toolchain/ccache/Config.in
index 1d27987c4..a265375c4 100644
--- a/toolchain/ccache/Config.in
+++ b/toolchain/ccache/Config.in
@@ -2,15 +2,9 @@
comment "Ccache Options"
-config BR2_HOST_CCACHE
+config BR2_CCACHE
bool "Enable ccache support?"
default y
help
Enable ccache support?
-config BR2_PACKAGE_CCACHE
- bool "Enable ccache support for the Target?"
- default y
- help
- Enable ccache support?
-
diff --git a/toolchain/ccache/Config.in.2 b/toolchain/ccache/Config.in.2
new file mode 100644
index 000000000..713037461
--- /dev/null
+++ b/toolchain/ccache/Config.in.2
@@ -0,0 +1,8 @@
+#
+
+config BR2_PACKAGE_CCACHE_TARGET
+ bool"ccache support in the target filesystem"
+ default n
+ help
+ Add help text here.
+
diff --git a/toolchain/ccache/Makefile.in b/toolchain/ccache/Makefile.in
index 6fa95d422..cc3c15e84 100644
--- a/toolchain/ccache/Makefile.in
+++ b/toolchain/ccache/Makefile.in
@@ -1,3 +1,6 @@
-ifeq ($(strip $(BR2_HOST_CCACHE)),y)
+ifeq ($(strip $(BR2_CCACHE)),y)
+TARGETS+=ccache
+endif
+ifeq ($(strip $(BR2_PACKAGE_CCACHE_TARGET)),y)
TARGETS+=ccache
endif
diff --git a/toolchain/gcc/Config.in.2 b/toolchain/gcc/Config.in.2
new file mode 100644
index 000000000..b83a996b1
--- /dev/null
+++ b/toolchain/gcc/Config.in.2
@@ -0,0 +1,8 @@
+#
+
+config BR2_PACKAGE_GCC_TARGET
+ bool"gcc toolchain in the target filesystem"
+ default n
+ help
+ Add help text here.
+
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 53004d677..1e62dd26d 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -25,3 +25,8 @@ ifeq ($(INSTALL_LIBGCJ),true)
INSTALL_LIBSTDCPP:=true
endif
+
+ifeq ($(strip $(BR2_PACKAGE_GCC_TARGET)),y)
+TARGETS+=gcc_target
+endif
+