summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-14 13:24:43 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-20 22:34:28 +0200
commitfad3b5a7bee8ce6dd1cf17f230de693d8ed9230f (patch)
tree9c6fe3ddd84a9e7fbe8f02a53a1b0342b886afbb /toolchain
parent407616f690a46f50f10d797a8bbc58052f515bba (diff)
external toolchain: check BR2_INSTALL_LIBSTDCPP
Verify that the value of BR2_INSTALL_LIBSTDCPP set by the user in the Buildroot configuration really matches the external toolchain capabilities by checking that a C++ cross-compiler is available. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 2c2562cde..bb4809ccd 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -232,6 +232,15 @@ check_arm_abi = \
fi ; \
#
+# Check that the external toolchain supports C++
+#
+check_cplusplus = \
+ if ! test -x $(TARGET_CXX) ; then \
+ echo "BR2_INSTALL_LIBSTDCPP is selected but C++ support not available in external toolchain" ; \
+ exit 1 ; \
+ fi ; \
+
+#
# Check that the cross-compiler given in the configuration exists
#
check_cross_compiler_exists = \
@@ -288,6 +297,9 @@ endif
ifeq ($(BR2_arm),y)
$(Q)$(call check_arm_abi)
endif
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ $(Q)$(call check_cplusplus)
+endif
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
$(Q)$(call check_uclibc,$(SYSROOT_DIR))
else