summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-22 11:38:07 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-22 11:38:07 +0000
commitfbbea808f595271a2dec949912d3964f0bd716fb (patch)
treebc6f2c8a1a8c3e0f05d00e36725c0d9db84150a1 /toolchain
parent8576c4495f56358046b322db5737cc08df659a1e (diff)
- fix setting the REAL_GCC_VERSION if no snapdate was given (i.e. we're using a svn co of the branch).
sjhill, please verify that this still works for you!
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 00471d71e..0b63bb342 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -336,8 +336,8 @@ ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
endif
ifeq ($(findstring 4.2,$(GCC_VERSION)),4.2)
-ifneq ($(GCC_SNAP_DATE),)
-REAL_GCC_VERSION:=`cat ${GCC_DIR}/gcc/BASE-VER`
+ifneq ($(findstring 4.2.,$(GCC_VERSION)),4.2.)
+REAL_GCC_VERSION=$(shell cat $(GCC_DIR)/gcc/BASE-VER)
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(REAL_GCC_VERSION)
else
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)