summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
commit9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6 (patch)
tree3f0ef80e7c44f59eae59c0fdfb9b56882d454112 /toolchain
parent9fba54740004859fd7e0936cda64d01c2b48633b (diff)
Remove usage of TARGET_LDFLAGS all together. Both TARGET_CFLAGS and TARGET_LDFLAGS are passed with the compilers and linker respectively so that we can pass CFLAGS and LDFLAGS on a per-package basis which was not possible previously and a number of packages failed to build. TARGET_CFLAGS usage in package makefiles will be removed next.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/uclibc.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index c8c23fc7b..19af67afb 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -113,8 +113,6 @@ $(UCLIBC_DIR)/.config: $(UCLIBC_DIR)/.unpacked $(UCLIBC_CONFIG_FILE)
-e 's,^DEVEL_PREFIX=.*,DEVEL_PREFIX=\"/usr/\",g' \
-e 's,^SHARED_LIB_LOADER_PREFIX=.*,SHARED_LIB_LOADER_PREFIX=\"/lib\",g' \
$(UCLIBC_DIR)/.config
- $(SED) 's,^ARCH_CFLAGS=",ARCH_CFLAGS="$(TARGET_CFLAGS) ,g' \
- $(UCLIBC_DIR)/.config
ifeq ($(UCLIBC_TARGET_ARCH),arm)
$(SED) 's/^\(CONFIG_[^_]*[_]*ARM[^=]*\)=.*/# \1 is not set/g' \
$(UCLIBC_DIR)/.config