summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-04-02 16:18:48 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-04-02 16:18:48 +0000
commit323e37f463f9206d2d91e1225e81df8b10f70640 (patch)
treea987dcf788944f66b33647bf258866459d0a085c /toolchain
parent48b3e0c94f54a7d48df5caa85769099875b4bae6 (diff)
- make sure that we do not confuse versions (due to how findstring works)
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index b050f80d8..6390da667 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -25,14 +25,14 @@ endif
ifeq ($(BR2_SOFT_FLOAT),y)
# gcc 3.4.x soft float configuration is different than previous versions.
-ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
+ifeq ($(findstring x3.4.,x$(GCC_VERSION)),x3.4.)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
else
SOFT_FLOAT_CONFIG_OPTION:=--without-float
endif
# again... there must be a better way
-ifeq ($(findstring 4.,$(GCC_VERSION)),4.)
+ifeq ($(findstring x4.,x$(GCC_VERSION)),x4.)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
ifeq ($(BR2_SOFT_FLOAT_FP),y)
TARGET_SOFT_FLOAT:=-mfloat-abi=softfp
@@ -61,7 +61,7 @@ EXTRA_TARGET_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_TARGET_GCC_CONF
ifeq ($(BR2_PREFER_IMA),y)
# >= 4.x
-ifneq ($(findstring 3.,$(GCC_VERSION)),3.)
+ifneq ($(findstring x3.,x$(GCC_VERSION)),x3.)
EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--enable-intermodule
endif
endif # BR2_PREFER_IMA=y