summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--make/lzo.mk65
-rw-r--r--sources/lzo-cross-compile.patch43
2 files changed, 108 insertions, 0 deletions
diff --git a/make/lzo.mk b/make/lzo.mk
new file mode 100644
index 000000000..48e9d7b5d
--- /dev/null
+++ b/make/lzo.mk
@@ -0,0 +1,65 @@
+#############################################################
+#
+# lzo
+#
+# Note: this builds only a static library, it does not provide
+# anything to be installed into the target system.
+#
+#############################################################
+LZO_SOURCE:=lzo_1.08.orig.tar.gz
+LZO_SITE:=http://ftp.debian.org/debian/pool/main/l/lzo
+#LZO_SOURCE:=lzo-1.08.tar.bz2
+#LZO_SITE:=http://www.oberhumer.com/opensource/lzo/download
+LZO_DIR:=$(BUILD_DIR)/lzo-1.08
+LZO_CAT:=zcat
+LZO_PATCH:=$(SOURCE_DIR)/lzo-cross-compile.patch
+
+$(DL_DIR)/$(LZO_SOURCE):
+ $(WGET) -P $(DL_DIR) $(LZO_SITE)/$(LZO_SOURCE)
+
+lzo-source: $(DL_DIR)/$(LZO_SOURCE)
+
+$(LZO_DIR)/.unpacked: $(DL_DIR)/$(LZO_SOURCE)
+ $(LZO_CAT) $(DL_DIR)/$(LZO_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ cat $(LZO_PATCH) | patch -p1 -d $(LZO_DIR)
+ touch $(LZO_DIR)/.unpacked
+
+LZO_CONFIG_SHARED:=--disable-shared
+#LZO_CONFIG_SHARED:=--enable-shared
+
+$(LZO_DIR)/.configured: $(LZO_DIR)/.unpacked
+ (cd $(LZO_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ $(LZO_CONFIG_SHARED) \
+ );
+ touch $(LZO_DIR)/.configured
+
+$(LZO_DIR)/src/liblzo.la: $(LZO_DIR)/.configured
+ $(MAKE) -C $(LZO_DIR)
+
+$(STAGING_DIR)/lib/liblzo.a: $(LZO_DIR)/src/liblzo.la
+ $(MAKE) CC=$(TARGET_CC) DESTDIR=$(STAGING_DIR) -C $(LZO_DIR) install
+
+lzo: uclibc $(STAGING_DIR)/lib/liblzo.a
+
+lzo-clean:
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LZO_DIR) uninstall
+ -$(MAKE) -C $(LZO_DIR) clean
+
+lzo-dirclean:
+ rm -rf $(LZO_DIR)
+
diff --git a/sources/lzo-cross-compile.patch b/sources/lzo-cross-compile.patch
new file mode 100644
index 000000000..68a3d0449
--- /dev/null
+++ b/sources/lzo-cross-compile.patch
@@ -0,0 +1,43 @@
+For some reason the lzo autoconf script uses a local macro that does
+a test for cross-compiles, and assumes that if the build target name
+and the host target name are the same that --host was not specified to
+the configure script. In the uClibc buildroot, this is not the case.
+
+--- lzo-1.08/aclocal.m4 2002-07-12 18:31:52.000000000 -0700
++++ lzo-1.08/aclocal.m4.new 2004-03-10 15:32:42.000000000 -0700
+@@ -205,12 +205,6 @@
+ [
+ AC_REQUIRE([AC_PROG_CC])
+
+-if test "X$cross_compiling" = Xyes; then
+- if test "X$build" = "X$host"; then
+- AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
+- fi
+-fi
+-
+ ])
+
+
+--- lzo-1.08/configure-dist 2004-03-11 02:18:28.000000000 -0600
++++ lzo-1.08/configure 2004-03-11 02:19:16.000000000 -0600
+@@ -2282,13 +2282,13 @@
+
+
+
+-if test "X$cross_compiling" = Xyes; then
+- if test "X$build" = "X$host"; then
+- { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
+-echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
+- { (exit 1); exit 1; }; }
+- fi
+-fi
++#if test "X$cross_compiling" = Xyes; then
++# if test "X$build" = "X$host"; then
++# { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
++#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
++# { (exit 1); exit 1; }; }
++# fi
++#fi
+
+
+