summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--package/Makefile.autotools.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c23ec7160..8cadf5c3a 100644
--- a/Makefile
+++ b/Makefile
@@ -350,7 +350,7 @@ _source-check:
external-deps:
@$(MAKE) -Bs BR2_WGET=$(TOPDIR)/toolchain/wget-show-external-deps.sh \
- source
+ SPIDER=--spider source
#############################################################
#
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 16fc37192..5e94b447e 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -131,7 +131,7 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
# support make source-check/external-deps
-ifeq ($(MAKELEVEL),1)
+ifneq ($(SPIDER),)
$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
$(if $($(PKG)_PATCH),$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
else