summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--TODO10
-rw-r--r--package/config/.gitignore4
-rw-r--r--package/coreutils/Config.in4
-rw-r--r--package/coreutils/coreutils-7.4-rename-m4-fix.patch25
-rw-r--r--package/coreutils/coreutils.mk7
-rw-r--r--package/tar/Config.in4
-rw-r--r--target/device/ARMLTD/integrator926/integrator926_defconfig2
-rw-r--r--target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig2
-rw-r--r--target/device/Atmel/at91rm9200df/at91rm9200df_defconfig2
-rw-r--r--target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig2
-rw-r--r--target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig2
-rw-r--r--target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig2
-rw-r--r--target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig2
-rw-r--r--target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig2
-rw-r--r--target/device/Atmel/atngw100-base/atngw100-base_defconfig2
-rw-r--r--target/device/Atmel/atngw100/atngw100_defconfig2
-rw-r--r--target/device/Atmel/atstk1005/atstk1005_defconfig2
-rw-r--r--target/device/Atmel/atstk100x/atstk100x_defconfig2
-rw-r--r--target/device/KwikByte/kb9202/kb9202_defconfig2
-rw-r--r--target/device/valka/v100sc2_defconfig2
-rw-r--r--target/device/x86/i686/i386_defconfig2
-rw-r--r--target/device/x86/i686/i686_defconfig2
-rw-r--r--target/generic/Config.in4
-rw-r--r--toolchain/Config.in.210
-rw-r--r--toolchain/external-toolchain/ext-tool.mk4
-rw-r--r--toolchain/kernel-headers/Config.in4
-rw-r--r--toolchain/uClibc/Config.in8
-rw-r--r--toolchain/uClibc/uclibc.mk2
28 files changed, 81 insertions, 37 deletions
diff --git a/TODO b/TODO
index 4de15ab27..bf98fea1b 100644
--- a/TODO
+++ b/TODO
@@ -5,3 +5,13 @@ Buildroot2 TODOs
- convert all packages that use autoconf to use the infrastructure of
packages/Makefile.autotools.in
- fix setting of flags for packages
+
+- coreutils: use make install-strip to install the packages. For now,
+ it fails beause even if we pass STRIP="/path/to/$(ARCH)-strip", the
+ coreutils build system uses the host strip to strip target
+ binaries. The ./configure execution done by Buildroot properly
+ detects the cross-strip, but when running make, build-aux/missing
+ gets run, complains about aclocal-1.10c and atuomake-1.10c not being
+ present, and rerun the configuration... with the wrong environment
+ variables (STRIP= is missing). An autoreconf on this package is
+ probably necessary.
diff --git a/package/config/.gitignore b/package/config/.gitignore
index 9067e6885..161a19ada 100644
--- a/package/config/.gitignore
+++ b/package/config/.gitignore
@@ -1,6 +1,10 @@
/buildroot-config
/conf
/mconf
+/qconf
+/qconf.moc
+/.tmp_qtcheck
+/lkc_defs.h
/lex.zconf.c
/zconf.hash.c
/zconf.tab.c
diff --git a/package/coreutils/Config.in b/package/coreutils/Config.in
index 5dfe43c9d..a7159cf9e 100644
--- a/package/coreutils/Config.in
+++ b/package/coreutils/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_COREUTILS
bool "coreutils"
- depends on BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION
+ depends on BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION
help
All of the basic file/text/shell utilities. These are the
core utilities which are expected to exist on every system.
@@ -14,4 +14,4 @@ config BR2_PACKAGE_COREUTILS
http://www.gnu.org/software/coreutils/
comment "coreutils requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
- depends on !(BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION)
+ depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
diff --git a/package/coreutils/coreutils-7.4-rename-m4-fix.patch b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
new file mode 100644
index 000000000..f869f439c
--- /dev/null
+++ b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
@@ -0,0 +1,25 @@
+Commit 7fcb389fb4cd5ba26e330fef991ffdc05392f289 from gnulib, to fix
+the rename bugs detection macros.
+---
+ m4/rename.m4 | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: coreutils-7.4/m4/rename.m4
+===================================================================
+--- coreutils-7.4.orig/m4/rename.m4
++++ coreutils-7.4/m4/rename.m4
+@@ -51,12 +51,12 @@
+ AC_LIBOBJ([rename])
+ AC_DEFINE([rename], [rpl_rename],
+ [Define to rpl_rename if the replacement function should be used.])
+- if test $gl_cv_func_rename_trailing_slash_bug; then
++ if test $gl_cv_func_rename_trailing_slash_bug = yes; then
+ AC_DEFINE([RENAME_TRAILING_SLASH_BUG], [1],
+ [Define if rename does not work for source file names with a trailing
+ slash, like the one from SunOS 4.1.1_U1.])
+ fi
+- if test $gl_cv_func_rename_dest_exists_bug; then
++ if test $gl_cv_func_rename_dest_exists_bug = yes; then
+ AC_DEFINE([RENAME_DEST_EXISTS_BUG], [1],
+ [Define if rename does not work when the destination file exists,
+ as on Windows.])
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index 31de2d5b8..2c9c0d3b3 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -3,11 +3,11 @@
# coreutils
#
#############################################################
-COREUTILS_VERSION:=6.9
-COREUTILS_SOURCE:=coreutils-$(COREUTILS_VERSION).tar.bz2
+COREUTILS_VERSION:=7.4
+COREUTILS_SOURCE:=coreutils-$(COREUTILS_VERSION).tar.gz
#COREUTILS_SITE:=ftp://alpha.gnu.org/gnu/coreutils/
COREUTILS_SITE:=$(BR2_GNU_MIRROR)/coreutils
-COREUTILS_CAT:=$(BZCAT)
+COREUTILS_CAT:=$(ZCAT)
COREUTILS_DIR:=$(BUILD_DIR)/coreutils-$(COREUTILS_VERSION)
COREUTILS_BINARY:=src/vdir
COREUTILS_TARGET_BINARY:=bin/vdir
@@ -59,6 +59,7 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
ac_cv_func_mkstemp=yes \
utils_cv_func_mkstemp_limitations=no \
utils_cv_func_mkdir_trailing_slash_bug=no \
+ gl_cv_func_rename_dest_exists_bug=no \
ac_cv_func_memcmp_working=yes \
ac_cv_have_decl_malloc=yes \
gl_cv_func_malloc_0_nonnull=yes \
diff --git a/package/tar/Config.in b/package/tar/Config.in
index a25794939..20529e378 100644
--- a/package/tar/Config.in
+++ b/package/tar/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_TAR
bool "tar"
- depends on BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION
+ depends on BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION
help
A program that saves many files together into a single tape or disk
archive, and can restore individual files from the archive.
@@ -8,4 +8,4 @@ config BR2_PACKAGE_TAR
http://www.gnu.org/software/tar/
comment "tar requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
- depends on !(BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION)
+ depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
diff --git a/target/device/ARMLTD/integrator926/integrator926_defconfig b/target/device/ARMLTD/integrator926/integrator926_defconfig
index c90f2f8ab..652b93565 100644
--- a/target/device/ARMLTD/integrator926/integrator926_defconfig
+++ b/target/device/ARMLTD/integrator926/integrator926_defconfig
@@ -185,7 +185,7 @@ BR2_UCLIBC_CONFIG="target/device/ARMLTD/uClibc.integrator926.config"
BR2_PTHREADS_OLD=y
# BR2_PTHREADS_NATIVE is not set
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig b/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
index ba7dd13b3..fdbabe06b 100644
--- a/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
+++ b/target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
@@ -185,7 +185,7 @@ BR2_UCLIBC_CONFIG="target/device/ARMLTD/uClibc.integrator926.config"
BR2_PTHREADS_OLD=y
# BR2_PTHREADS_NATIVE is not set
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
index f372d94ba..255f81a6e 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
+++ b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
@@ -237,7 +237,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
# BR2_UCLIBC_VERSION_SNAPSHOT is not set
BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.30.config"
# BR2_PTHREAD_DEBUG is not set
-BR2_UCLIBC_PROGRAM_INVOCATION=y
+BR2_PROGRAM_INVOCATION=y
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig b/target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig
index bc1a4a927..e2a5ae870 100644
--- a/target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig
+++ b/target/device/Atmel/at91sam9260dfc/arm_toolchain_defconfig
@@ -232,7 +232,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
# BR2_UCLIBC_VERSION_SNAPSHOT is not set
BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.30.config"
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
index 38e240218..dc5892dcb 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
+++ b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
@@ -255,7 +255,7 @@ BR2_ENABLE_LOCALE=y
BR2_PTHREADS_OLD=y
# BR2_PTHREADS_NATIVE is not set
# BR2_PTHREAD_DEBUG is not set
-BR2_UCLIBC_PROGRAM_INVOCATION=y
+BR2_PROGRAM_INVOCATION=y
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
index 31af7986f..4427334ea 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
+++ b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
@@ -258,7 +258,7 @@ BR2_ENABLE_LOCALE=y
BR2_PTHREADS_OLD=y
# BR2_PTHREADS_NATIVE is not set
# BR2_PTHREAD_DEBUG is not set
-BR2_UCLIBC_PROGRAM_INVOCATION=y
+BR2_PROGRAM_INVOCATION=y
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig b/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
index c5cc5ef77..e4e1e111b 100644
--- a/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
+++ b/target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
@@ -251,7 +251,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
# BR2_UCLIBC_VERSION_SNAPSHOT is not set
BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.30.config"
# BR2_PTHREAD_DEBUG is not set
-BR2_UCLIBC_PROGRAM_INVOCATION=y
+BR2_PROGRAM_INVOCATION=y
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig b/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
index 3c358be33..97df4fe6f 100644
--- a/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
+++ b/target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
@@ -251,7 +251,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
# BR2_UCLIBC_VERSION_SNAPSHOT is not set
BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.30.config"
# BR2_PTHREAD_DEBUG is not set
-BR2_UCLIBC_PROGRAM_INVOCATION=y
+BR2_PROGRAM_INVOCATION=y
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/atngw100-base/atngw100-base_defconfig b/target/device/Atmel/atngw100-base/atngw100-base_defconfig
index 6e668eb77..716cb190d 100644
--- a/target/device/Atmel/atngw100-base/atngw100-base_defconfig
+++ b/target/device/Atmel/atngw100-base/atngw100-base_defconfig
@@ -191,7 +191,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
BR2_UCLIBC_VERSION_STRING="0.9.30"
BR2_UCLIBC_CONFIG="target/device/Atmel/uClibc.config.avr32"
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/atngw100/atngw100_defconfig b/target/device/Atmel/atngw100/atngw100_defconfig
index 540439201..cbb6cc472 100644
--- a/target/device/Atmel/atngw100/atngw100_defconfig
+++ b/target/device/Atmel/atngw100/atngw100_defconfig
@@ -192,7 +192,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
BR2_UCLIBC_VERSION_STRING="0.9.30"
BR2_UCLIBC_CONFIG="target/device/Atmel/uClibc.config.avr32"
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/atstk1005/atstk1005_defconfig b/target/device/Atmel/atstk1005/atstk1005_defconfig
index 425479616..4ccc3c67a 100644
--- a/target/device/Atmel/atstk1005/atstk1005_defconfig
+++ b/target/device/Atmel/atstk1005/atstk1005_defconfig
@@ -197,7 +197,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
# BR2_UCLIBC_VERSION_SNAPSHOT is not set
BR2_UCLIBC_CONFIG="target/device/Atmel/uClibc.config.avr32"
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/Atmel/atstk100x/atstk100x_defconfig b/target/device/Atmel/atstk100x/atstk100x_defconfig
index ebe00cec4..abb86f807 100644
--- a/target/device/Atmel/atstk100x/atstk100x_defconfig
+++ b/target/device/Atmel/atstk100x/atstk100x_defconfig
@@ -191,7 +191,7 @@ BR2_UCLIBC_VERSION_0_9_30=y
BR2_UCLIBC_VERSION_STRING="0.9.30"
BR2_UCLIBC_CONFIG="target/device/Atmel/uClibc.config.avr32"
# BR2_PTHREAD_DEBUG is not set
-BR2_UCLIBC_PROGRAM_INVOCATION=y
+BR2_PROGRAM_INVOCATION=y
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/KwikByte/kb9202/kb9202_defconfig b/target/device/KwikByte/kb9202/kb9202_defconfig
index 636b2145e..45c1c66be 100644
--- a/target/device/KwikByte/kb9202/kb9202_defconfig
+++ b/target/device/KwikByte/kb9202/kb9202_defconfig
@@ -189,7 +189,7 @@ BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.29.config"
BR2_PTHREADS_OLD=y
# BR2_PTHREADS_NATIVE is not set
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
#
# Binutils Options
diff --git a/target/device/valka/v100sc2_defconfig b/target/device/valka/v100sc2_defconfig
index e7686ddd9..03ab78b6f 100644
--- a/target/device/valka/v100sc2_defconfig
+++ b/target/device/valka/v100sc2_defconfig
@@ -172,7 +172,7 @@ BR2_ENABLE_LOCALE=y
BR2_PTHREADS_OLD=y
# BR2_PTHREADS_NATIVE is not set
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/x86/i686/i386_defconfig b/target/device/x86/i686/i386_defconfig
index a4d6ae96a..6f0a2c96c 100644
--- a/target/device/x86/i686/i386_defconfig
+++ b/target/device/x86/i686/i386_defconfig
@@ -178,7 +178,7 @@ BR2_UCLIBC_VERSION_0_9_30_1=y
BR2_UCLIBC_VERSION_STRING="0.9.30.1"
BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.29.config"
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/device/x86/i686/i686_defconfig b/target/device/x86/i686/i686_defconfig
index 116d0a283..463e5b786 100644
--- a/target/device/x86/i686/i686_defconfig
+++ b/target/device/x86/i686/i686_defconfig
@@ -178,7 +178,7 @@ BR2_UCLIBC_VERSION_0_9_30_1=y
BR2_UCLIBC_VERSION_STRING="0.9.30.1"
BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.30.config"
# BR2_PTHREAD_DEBUG is not set
-# BR2_UCLIBC_PROGRAM_INVOCATION is not set
+# BR2_PROGRAM_INVOCATION is not set
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
#
diff --git a/target/generic/Config.in b/target/generic/Config.in
index 5f5110ca5..5de581104 100644
--- a/target/generic/Config.in
+++ b/target/generic/Config.in
@@ -18,7 +18,7 @@ config BR2_TARGET_GENERIC_FIREWALL
config BR2_TARGET_GENERIC_DEV_SYSTEM
bool "Generic development system"
- depends on BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION
+ depends on BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION
select BR2_CCACHE
select BR2_PACKAGE_GDB
select BR2_PACKAGE_GDB_SERVER
@@ -59,7 +59,7 @@ config BR2_TARGET_GENERIC_DEV_SYSTEM
Board support for a generic development system.
comment "Generic development system requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
- depends on !(BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION)
+ depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
menuconfig BR2_TARGET_GENERIC_GETTY
bool "Generic serial port config"
diff --git a/toolchain/Config.in.2 b/toolchain/Config.in.2
index 5df04e01b..2a9ce24ef 100644
--- a/toolchain/Config.in.2
+++ b/toolchain/Config.in.2
@@ -119,6 +119,16 @@ choice
bool "Native POSIX Threading (NPTL)"
endchoice
+config BR2_PROGRAM_INVOCATION
+ bool "Enable 'program invocation name'"
+ help
+ Support for the GNU-specific program_invocation_name and
+ program_invocation_short_name strings. Some GNU packages
+ (like tar and coreutils) utilize these for extra useful
+ output, but in general are not required.
+ If you have an external binary toolchain that has been built
+ with program invocation support then enable this option.
+
config BR2_GCC_CROSS_CXX
bool
help
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index d441a9252..568ac3a35 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -115,7 +115,8 @@ check_glibc = \
$(call check_glibc_feature,BR2_INET_IPV6,IPv6 support) ;\
$(call check_glibc_feature,BR2_INET_RPC,RPC support) ;\
$(call check_glibc_feature,BR2_ENABLE_LOCALE,Locale support) ;\
- $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support)
+ $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support) ;\
+ $(call check_glibc_feature,BR2_PROGRAM_INVOCATION,Program invocation support)
#
# Check the conformity of Buildroot configuration with regard to the
@@ -160,6 +161,7 @@ check_uclibc = \
$(call check_uclibc_feature,__UCLIBC_HAS_RPC__,BR2_INET_RPC,$${UCLIBC_CONFIG_FILE},RPC support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_LOCALE__,BR2_ENABLE_LOCALE,$${UCLIBC_CONFIG_FILE},Locale support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_WCHAR__,BR2_USE_WCHAR,$${UCLIBC_CONFIG_FILE},Wide char support) ;\
+ $(call check_uclibc_feature,__UCLIBC_HAS_PROGRAM_INVOCATION_NAME__,BR2_PROGRAM_INVOCATION,$${UCLIBC_CONFIG_FILE},Program invocation support) ;\
#
# Check that the Buildroot configuration of the ABI matches the
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index 689c85dd5..ad78b0067 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -49,9 +49,9 @@ config BR2_KERNEL_HEADERS_RT
config BR2_DEFAULT_KERNEL_HEADERS
string
default "2.6.26.8" if BR2_KERNEL_HEADERS_2_6_26
- default "2.6.27.28" if BR2_KERNEL_HEADERS_2_6_27
+ default "2.6.27.29" if BR2_KERNEL_HEADERS_2_6_27
default "2.6.28.10" if BR2_KERNEL_HEADERS_2_6_28
default "2.6.29.6" if BR2_KERNEL_HEADERS_2_6_29
- default "2.6.30.3" if BR2_KERNEL_HEADERS_2_6_30
+ default "2.6.30.4" if BR2_KERNEL_HEADERS_2_6_30
default "2.6" if BR2_KERNEL_HEADERS_SNAP
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index b7678a356..d0486abd6 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -68,14 +68,6 @@ config BR2_PTHREAD_DEBUG
help
Build the thread library with debugging enabled.
-config BR2_UCLIBC_PROGRAM_INVOCATION
- bool "Enable 'program invocation name'"
- help
- Support for the GNU-specific program_invocation_name and
- program_invocation_short_name strings. Some GNU packages
- (like tar and coreutils) utilize these for extra useful
- output, but in general are not required.
-
config BR2_UCLIBC_INSTALL_TEST_SUITE
bool "Compile and install uClibc tests"
select BR2_PACKAGE_MAKE
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 80d7d9861..de8e1d562 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -353,7 +353,7 @@ ifeq ($(BR2_USE_WCHAR),y)
else
$(SED) 's,^.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=n,g' $(UCLIBC_DIR)/.oldconfig
endif
-ifeq ($(BR2_UCLIBC_PROGRAM_INVOCATION),y)
+ifeq ($(BR2_PROGRAM_INVOCATION),y)
$(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y,g' $(UCLIBC_DIR)/.oldconfig
else
$(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=n,g' $(UCLIBC_DIR)/.oldconfig