summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES28
-rw-r--r--docs/download.html8
-rw-r--r--docs/news.html13
-rw-r--r--package/Config.in1
-rw-r--r--package/gamin/gamin-0.1.10-configure.patch (renamed from package/gamin/gamin-0.1.9-configure.patch)31
-rw-r--r--package/gamin/gamin.mk2
-rw-r--r--package/iw/Config.in7
-rw-r--r--package/iw/iw.mk27
-rw-r--r--package/ltp-testsuite/ltp-testsuite-sched-getaffinity.patch11
-rw-r--r--package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch11
-rw-r--r--package/ltp-testsuite/ltp-testsuite-uclibc-syscalls.patch11
-rw-r--r--package/ltp-testsuite/ltp-testsuite.mk5
-rw-r--r--package/ltp-testsuite/ltp-testsuite.patch73
-rw-r--r--package/webkit/Config.in21
-rw-r--r--package/webkit/webkit.mk23
15 files changed, 169 insertions, 103 deletions
diff --git a/CHANGES b/CHANGES
index 4c3d4032d..0c1f667b1 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,4 +1,6 @@
-2009.08, Not yet released:
+2009.08-rc1, Released August 2nd, 2009:
+
+ Fixes all over the tree and new features.
Improvement of external toolchain support:
- Support for glibc toolchains.
@@ -12,6 +14,26 @@
New QT-based configurator, usable using 'make xconfig'.
+ Support for the Xtensa architecture.
+
+ Toolchain: GCC 4.4.1, 2.6.30 kernel headers, removed < 2.6.26
+ headers.
+
+ New packages: bmon, ctorrent, dosfstools, enchant,
+ gst-plugins-bad, iw, libmms, libnl, netstat-nat, ntfsprogs,
+ sdl_gfx, spawn-fcgi.
+
+ Updated packages: bind, busybox, coreutils, sqlite, directfb,
+ expat, gamin, gnuconfig, haserl, ipsec-tools, classpath,
+ libcurl, libglib2, liblockfile, libpng, libsoup, libxml2,
+ lighttpd, ltp-testsuite, lvm2, matchbox, memstat,
+ gst-plugins-good, gstreamer, libogg, libvorbis, mplayer,
+ neon, openssl, pciutils, php, qt, ruby, sawman, webkit,
+ wpa-supplicant, xdriver_xf86-input-synaptics,
+ xdriver_xf86-video-intel, xlib_libXfont, xlib_libXft,
+ xlib_libXt, xproto_xproto, xserver-xorg, xutil_makedepend,
+ xutil_util-macros.
+
Issues resolved (http://bugs.uclibc.org):
#83: liblockfile fails to compile due to eaccess redefinition
@@ -22,6 +44,7 @@
#247: ntfsprogs: new package
#271: Library 'libgcc_s.so.1' not installed in search path
#287: New package libnl
+ #289: New package iw
#331: Update MPlayer to version 1.0rc2
#333: Bump sqlite package to 3.6.15
#349: update libsoup to version 2.26.2
@@ -44,6 +67,8 @@
#417: New package spawn-fcgi
#419: Bump lighttpd package to 1.4.23
#421: toolchain: Clean up toolchain locale support menu
+ #427: webkit: Update to WebKit svn r44552
+ #437: ltp-testsuite: Bump version to 20090630
#451: Upgrade from unmaintained dosfstools-2.11 to dosfstools-3.0.3
#467: DirectFB 1.4.1
#473: memstat_0.5.tar.gz has install with -D and that fails "make"
@@ -52,6 +77,7 @@
#497: OpenSSL RSA key generation hangs on x86_64
#509: Bump sqlite package to 3.6.16
#523: pciutils broken with external toolchain
+ #533: Update gamin to 0.1.10 to fix compilation
2009.05, Released June 1st, 2009:
diff --git a/docs/download.html b/docs/download.html
index 349a7cd47..0c34f4adc 100644
--- a/docs/download.html
+++ b/docs/download.html
@@ -14,6 +14,14 @@ or
<a href="/downloads/buildroot-2009.05.tar.bz2">buildroot-2009.05.tar.bz2</a>.
<p>
+The latest release candidate is <b>2009.08-rc1</b>, which can be
+downloaded here:<p>
+
+<a href="/downloads/buildroot-2009.08-rc1.tar.gz">buildroot-2009.08-rc1.tar.gz</a>
+or
+<a href="/downloads/buildroot-2009.08-rc1.tar.bz2">buildroot-2009.08-rc1.tar.bz2</a>.
+<p>
+
This and earlier releases can always be dowloaded from
<a href="/downloads/">http://buildroot.net/downloads/</a>.
diff --git a/docs/news.html b/docs/news.html
index 65fd89266..bb6e2e2a2 100644
--- a/docs/news.html
+++ b/docs/news.html
@@ -5,6 +5,19 @@
<p>
<ul>
+ <li><b>2 August 2009 -- 2009.08-rc1 released</b>
+
+ <p>We have a new release candidate! Lots of changes all over the
+ tree, see the <a
+ href="http://git.buildroot.net/buildroot/plain/CHANGES?id=2009.08_rc1">CHANGES</a>
+ file for details.
+
+ <p>Head to the <a href="/downloads/">downloads page</a> to pick up the
+ <a href="/downloads/buildroot-2009.08-rc1.tar.bz2">2009.08-rc1
+ release candidate</a>, and report any problems found to the <a
+ href="lists.html">mailing list</a> or <a
+ href="https://bugs.uclibc.org">bug tracker</a>.</p>
+
<li><b>1 June 2009 -- 2009.05 released</b>
<p>The stable 2009.05 release is out - Thanks to everyone
diff --git a/package/Config.in b/package/Config.in
index cb5e9e055..f5f776063 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -150,6 +150,7 @@ source "package/iperf/Config.in"
source "package/iproute2/Config.in"
source "package/ipsec-tools/Config.in"
source "package/iptables/Config.in"
+source "package/iw/Config.in"
source "package/kismet/Config.in"
source "package/l2tp/Config.in"
source "package/libcgi/Config.in"
diff --git a/package/gamin/gamin-0.1.9-configure.patch b/package/gamin/gamin-0.1.10-configure.patch
index 1a8b7dc4c..b4e45039e 100644
--- a/package/gamin/gamin-0.1.9-configure.patch
+++ b/package/gamin/gamin-0.1.10-configure.patch
@@ -1,6 +1,6 @@
---- a/configure 2007-07-27 10:27:34.000000000 -0400
-+++ b/configure 2008-02-13 15:00:27.000000000 -0500
-@@ -23161,89 +23161,6 @@ ac_compile='$CC -c $CFLAGS $CPPFLAGS con
+--- a/configure.fixed 2009-08-02 18:00:54.000000000 +0200
++++ b/configure 2008-11-24 16:23:27.000000000 +0100
+@@ -23581,100 +23581,6 @@
ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
ac_compiler_gnu=$ac_cv_c_compiler_gnu
@@ -60,13 +60,22 @@
-}
-_ACEOF
-rm -f conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-- (eval $ac_link) 2>&5
+-if { (ac_try="$ac_link"
+-case "(($ac_try" in
+- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+- *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+- (eval "$ac_link") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
-- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-- (eval $ac_try) 2>&5
+- { (case "(($ac_try" in
+- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+- *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+- (eval "$ac_try") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
@@ -79,14 +88,16 @@
-( exit $ac_status )
-have_abstract_sockets=no
-fi
--rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
+-
+-
-ac_ext=c
-ac_cpp='$CPP $CPPFLAGS'
-ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
-ac_compiler_gnu=$ac_cv_c_compiler_gnu
-
- echo "$as_me:$LINENO: result: $have_abstract_sockets" >&5
- echo "${ECHO_T}$have_abstract_sockets" >&6
+ { echo "$as_me:$LINENO: result: $have_abstract_sockets" >&5
+ echo "${ECHO_T}$have_abstract_sockets" >&6; }
diff --git a/package/gamin/gamin.mk b/package/gamin/gamin.mk
index 180d89e92..ffd9be80d 100644
--- a/package/gamin/gamin.mk
+++ b/package/gamin/gamin.mk
@@ -3,7 +3,7 @@
# gamin
#
#############################################################
-GAMIN_VERSION = 0.1.9
+GAMIN_VERSION = 0.1.10
GAMIN_SOURCE = gamin-$(GAMIN_VERSION).tar.gz
GAMIN_SITE = http://www.gnome.org/~veillard/gamin/sources
GAMIN_AUTORECONF = NO
diff --git a/package/iw/Config.in b/package/iw/Config.in
new file mode 100644
index 000000000..81584e781
--- /dev/null
+++ b/package/iw/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_IW
+ bool "iw"
+ select BR2_PACKAGE_LIBNL
+ help
+ Utility for wireless devices using the mac80211 kernel stack
+
+ http://wireless.kernel.org/en/users/Documentation/iw
diff --git a/package/iw/iw.mk b/package/iw/iw.mk
new file mode 100644
index 000000000..dab6eeeea
--- /dev/null
+++ b/package/iw/iw.mk
@@ -0,0 +1,27 @@
+#############################################################
+#
+# iw
+#
+#############################################################
+
+IW_VERSION = 0.9.15
+IW_SOURCE = iw-$(IW_VERSION).tar.bz2
+IW_SITE = http://wireless.kernel.org/download/iw
+IW_DEPENDENCIES = libnl
+IW_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
+IW_CONFIG = $(IW_DIR)/.config
+IW_MAKE_ENV = PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+ GIT_DIR=$(IW_DIR)
+
+$(eval $(call AUTOTARGETS,package,iw))
+
+$(IW_TARGET_CONFIGURE):
+ echo "CC = $(TARGET_CC)" >$(IW_CONFIG)
+ echo "CFLAGS = $(TARGET_CFLAGS)" >>$(IW_CONFIG)
+ echo "LDFLAGS = $(TARGET_LDFLAGS)" >>$(IW_CONFIG)
+ touch $@
+
+$(IW_TARGET_UNINSTALL):
+ $(call MESSAGE,"Uninstalling")
+ rm -f $(TARGET_DIR)/usr/bin/iw
+ rm -f $(IW_TARGET_INSTALL_TARGET) $(IW_HOOK_POST_INSTALL)
diff --git a/package/ltp-testsuite/ltp-testsuite-sched-getaffinity.patch b/package/ltp-testsuite/ltp-testsuite-sched-getaffinity.patch
new file mode 100644
index 000000000..9e4a9d837
--- /dev/null
+++ b/package/ltp-testsuite/ltp-testsuite-sched-getaffinity.patch
@@ -0,0 +1,11 @@
+--- ltp-full-20090630/testcases/kernel/syscalls/sched_getaffinity/Makefile 2009-06-15 19:38:04.000000000 +0100
++++ ltp-full-20090630.mod/testcases/kernel/syscalls/sched_getaffinity/Makefile 2009-07-02 15:02:33.000000000 +0100
+@@ -16,7 +16,7 @@
+ # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ #
+
+-CFLAGS += -I../../../../include -Wall
++CFLAGS += -I../../../../include -Wall -D_GNU_SOURCE
+ LDLIBS += -L../../../../lib -lltp
+
+ SRCS = $(wildcard *.c)
diff --git a/package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch b/package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch
deleted file mode 100644
index a6f98ac13..000000000
--- a/package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ltp-full-20061121/IDcheck.sh.orig 2006-12-07 22:31:29.000000000 -0700
-+++ ltp-full-20061121/IDcheck.sh 2006-12-07 22:32:58.000000000 -0700
-@@ -85,7 +85,7 @@
- fi
-
- whoami | grep root > /dev/null
--if [ $? == "0" ]; then
-+if [ $? = "0" ]; then
- I_AM_ROOT=1
- fi
-
diff --git a/package/ltp-testsuite/ltp-testsuite-uclibc-syscalls.patch b/package/ltp-testsuite/ltp-testsuite-uclibc-syscalls.patch
new file mode 100644
index 000000000..866a56cc4
--- /dev/null
+++ b/package/ltp-testsuite/ltp-testsuite-uclibc-syscalls.patch
@@ -0,0 +1,11 @@
+--- ltp-full-20090630/testcases/kernel/syscalls/Makefile 2009-02-26 11:37:28.000000000 +0000
++++ ltp-full-20090630.mod/testcases/kernel/syscalls/Makefile 2009-07-02 14:57:30.000000000 +0100
+@@ -25,7 +25,7 @@
+ #
+ # Commented this out since there are directories here we don't want built by default
+ #
+-SUBDIR = `ls */Makefile | sed "s/Makefile//g"`
++SUBDIR = `ls */Makefile | sed "s/Makefile//g" | grep -vE "^clock_nanosleep|quotactl|sched_getaffinity|sigreturn|unshare"`
+ UCLINUX_SUBDIR = `ls */Makefile | sed "s/Makefile//g" | grep -vE "^fork|epoll|capget|capset|chmod|chown|llseek|nftw|clone|profil|getcontext|remap_file_pages"`
+
+ all:
diff --git a/package/ltp-testsuite/ltp-testsuite.mk b/package/ltp-testsuite/ltp-testsuite.mk
index 178983201..7cb51c211 100644
--- a/package/ltp-testsuite/ltp-testsuite.mk
+++ b/package/ltp-testsuite/ltp-testsuite.mk
@@ -3,7 +3,7 @@
# ltp-testsuite
#
#############################################################
-LTP_TESTSUITE_VERSION:=20070228
+LTP_TESTSUITE_VERSION:=20090630
LTP_TESTSUITE_SOURCE:=ltp-full-$(LTP_TESTSUITE_VERSION).tgz
LTP_TESTSUITE_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ltp
LTP_TESTSUITE_CAT:=$(ZCAT)
@@ -15,7 +15,8 @@ LTP_TESTSUITE_DIR:=$(LTP_TESTSUITE_ROOT)/ltp-full-$(LTP_TESTSUITE_VERSION)
#
LTP_PATCHES:=ltp-testsuite-generate-needs-bash.patch \
ltp-testsuite-sh-is-not-C-code.patch \
- ltp-testsuite.patch
+ ltp-testsuite-sched-getaffinity.patch \
+ ltp-testsuite-uclibc-syscalls.patch
ifeq ($(BR2_PTHREADS_NATIVE),y)
LTP_PATCHES+=ltp-testsuite-enable-openposix-for-nptl.patch
diff --git a/package/ltp-testsuite/ltp-testsuite.patch b/package/ltp-testsuite/ltp-testsuite.patch
deleted file mode 100644
index ce6cff3ea..000000000
--- a/package/ltp-testsuite/ltp-testsuite.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -ur ltp-full-20061121/testcases/kernel/syscalls/fmtmsg/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/fmtmsg/Makefile
---- ltp-full-20061121/testcases/kernel/syscalls/fmtmsg/Makefile 2006-11-21 14:31:28.000000000 -0600
-+++ ltp-full-20061121-patched/testcases/kernel/syscalls/fmtmsg/Makefile 2006-12-02 00:16:36.830948316 -0600
-@@ -20,7 +20,7 @@
- LDLIBS += -L../../../../lib -lltp
-
- SRCS = $(wildcard *.c)
--TARGETS = $(patsubst %.c,%,$(SRCS))
-+TARGETS =#$(patsubst %.c,%,$(SRCS))
-
- all: $(TARGETS)
-
-diff -ur ltp-full-20061121/testcases/kernel/syscalls/getcontext/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/getcontext/Makefile
---- ltp-full-20061121/testcases/kernel/syscalls/getcontext/Makefile 2006-11-21 14:31:27.000000000 -0600
-+++ ltp-full-20061121-patched/testcases/kernel/syscalls/getcontext/Makefile 2006-12-02 00:16:50.072004501 -0600
-@@ -20,7 +20,7 @@
- LDLIBS += -L../../../../lib -lltp
-
- SRCS = $(wildcard *.c)
--TARGETS = $(patsubst %.c,%,$(SRCS))
-+TARGETS =#$(patsubst %.c,%,$(SRCS))
-
- all: $(TARGETS)
-
-diff -ur ltp-full-20061121/testcases/kernel/syscalls/profil/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/profil/Makefile
---- ltp-full-20061121/testcases/kernel/syscalls/profil/Makefile 2006-11-21 14:31:28.000000000 -0600
-+++ ltp-full-20061121-patched/testcases/kernel/syscalls/profil/Makefile 2006-12-02 00:17:03.301059744 -0600
-@@ -20,7 +20,7 @@
- LDLIBS += -L../../../../lib -lltp
-
- SRCS = $(wildcard *.c)
--TARGETS = $(patsubst %.c,%,$(SRCS))
-+TARGETS =#$(patsubst %.c,%,$(SRCS))
-
- all: $(TARGETS)
-
-diff -ur ltp-full-20061121/testcases/kernel/syscalls/pselect/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/pselect/Makefile
---- ltp-full-20061121/testcases/kernel/syscalls/pselect/Makefile 2006-11-21 14:31:29.000000000 -0600
-+++ ltp-full-20061121-patched/testcases/kernel/syscalls/pselect/Makefile 2006-12-02 00:17:14.661965984 -0600
-@@ -20,7 +20,7 @@
- LDLIBS += -L../../../../lib -lltp
-
- SRCS = $(wildcard *.c)
--TARGETS = $(patsubst %.c,%,$(SRCS))
-+TARGETS =#$(patsubst %.c,%,$(SRCS))
-
- all: $(TARGETS)
-
-diff -ur ltp-full-20061121/testcases/kernel/syscalls/swapon/swapon02.c ltp-full-20061121-patched/testcases/kernel/syscalls/swapon/swapon02.c
---- ltp-full-20061121/testcases/kernel/syscalls/swapon/swapon02.c 2006-11-21 14:31:29.000000000 -0600
-+++ ltp-full-20061121-patched/testcases/kernel/syscalls/swapon/swapon02.c 2006-12-02 00:18:12.422573631 -0600
-@@ -85,9 +85,7 @@
- #include <sys/wait.h>
- #include <sys/stat.h>
- #include <sys/swap.h>
--#ifdef OLDER_DISTRO_RELEASE
--#include <linux/swap.h>
--#endif
-+#define MAX_SWAPFILES 32
- #include <fcntl.h>
- #include <pwd.h>
- #include <string.h>
-@@ -96,10 +94,6 @@
- #include "test.h"
- #include "usctest.h"
-
--#ifndef OLDER_DISTRO_RELEASE
--#define MAX_SWAPFILES 32
--#endif
--
- static void setup();
- static void cleanup();
- static int setup01();
diff --git a/package/webkit/Config.in b/package/webkit/Config.in
index 9e3419aa7..e436f9acf 100644
--- a/package/webkit/Config.in
+++ b/package/webkit/Config.in
@@ -8,10 +8,27 @@ config BR2_PACKAGE_WEBKIT
select BR2_PACKAGE_LIBXML2
select BR2_PACKAGE_LIBXSLT
select BR2_PACKAGE_SQLITE
+ select BR2_PACKAGE_ENCHANT
+ select BR2_PACKAGE_LIBSOUP
help
- WebKit is an open source, standards compliant web browser engine.
+ WebKit is an open source, standards compliant web browser engine.
- http://webkit.org/
+ http://webkit.org/
comment "webkit requires a toolchain with C++ support and WCHAR enabled"
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR
+
+choice
+ prompt "Rendering target"
+ default BR2_PACKAGE_WEBKIT_X
+ help
+ Selects which rendering target will be used.
+
+config BR2_PACKAGE_WEBKIT_X11
+ bool "X11"
+
+config BR2_PACKAGE_WEBKIT_DIRECTFB
+ bool "DirectFB"
+ select BR2_PACKAGE_DIRECTFB
+
+endchoice
diff --git a/package/webkit/webkit.mk b/package/webkit/webkit.mk
index b070c1d14..17f1318f9 100644
--- a/package/webkit/webkit.mk
+++ b/package/webkit/webkit.mk
@@ -3,7 +3,7 @@
# webkit
#
#############################################################
-WEBKIT_VERSION = r31321
+WEBKIT_VERSION = r44552
WEBKIT_SOURCE = WebKit-$(WEBKIT_VERSION).tar.bz2
WEBKIT_SITE = http://nightly.webkit.org/files/trunk/src/
@@ -11,7 +11,24 @@ WEBKIT_INSTALL_STAGING = YES
WEBKIT_INSTALL_TARGET = YES
WEBKIT_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install
-WEBKIT_AUTORECONF = YES
-WEBKIT_DEPENDENCIES = icu curl libxml2 libxslt libgtk2 sqlite
+WEBKIT_DEPENDENCIES = icu curl libxml2 libxslt libgtk2 sqlite enchant \
+ libsoup
+
+ifeq ($(BR2_PACKAGE_WEBKIT_X11),y)
+WEBKIT_CONF_OPT = --with-target=x11
+endif
+
+ifeq ($(BR2_PACKAGE_WEBKIT_DIRECTFB),y)
+WEBKIT_CONF_OPT = --with-target=directfb
+endif
+
+WEBKIT_CONF_OPT += --disable-video
$(eval $(call AUTOTARGETS,package,webkit))
+
+$(WEBKIT_HOOK_POST_EXTRACT):
+ $(SED) 's/AUTOMAKE_FLAGS=.*/AUTOMAKE_FLAGS="--foreign --add-missing --copy"/' $(WEBKIT_DIR)/autogen.sh
+ $(SED) 's/LIBTOOLIZE_FLAGS=.*/LIBTOOLIZE_FLAGS="--force --automake --copy"/' $(WEBKIT_DIR)/autogen.sh
+ # Don't run the configure step yet
+ cd $(WEBKIT_DIR); AUTOGEN_CONFIGURE_ARGS=--version ./autogen.sh
+ touch $@