summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/directfb/Config.in13
-rw-r--r--package/directfb/directfb.mk15
2 files changed, 27 insertions, 1 deletions
diff --git a/package/directfb/Config.in b/package/directfb/Config.in
index fce9ed46c..5e847ed49 100644
--- a/package/directfb/Config.in
+++ b/package/directfb/Config.in
@@ -11,7 +11,18 @@ config BR2_PACKAGE_DIRECTFB_MULTI
select BR2_PACKAGE_LINUX_FUSION
help
Enable use of multiple concurrent DirectFB applications
- http://www.directfb.org/
+
+config BR2_PACKAGE_DIRECTFB_DEBUG
+ bool "directfb debugging"
+ depends on BR2_PACKAGE_DIRECTFB
+ help
+ Compile DirectFB with lots of debug output
+
+config BR2_PACKAGE_DIRECTFB_TRACE
+ bool "directfb call trace support"
+ depends on BR2_PACKAGE_DIRECTFB
+ help
+ Enable call tracing for DirectFB applications
config BR2_PACKAGE_DIRECTFB_XSERVER
bool "build with X server backend"
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index 93b45938d..2407743dd 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -19,6 +19,19 @@ else
DIRECTFB_MULTI:=
DIRECTFB_FUSION:=
endif
+
+ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
+DIRECTFB_DEBUG:=--enable-debug
+else
+DIRECTFB_DEBUG:=
+endif
+
+ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
+DIRECTFB_TRACE:=--enable-trace
+else
+DIRECTFB_TRACE:=
+endif
+
ifeq ($(BR2_PACKAGE_XSERVER),y)
DIRECTFB_X:=--enable-x11
else
@@ -111,6 +124,8 @@ DIRECTFB_CONF_OPT = \
--enable-shared \
--disable-explicit-deps \
$(DIRECTFB_MULTI) \
+ $(DIRECTFB_DEBUG) \
+ $(DIRECTFB_TRACE) \
$(DIRECTFB_X) \
$(DIRECTFB_JPEG) \
$(DIRECTFB_PNG) \