summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/database/sqlite/sqlite.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/database/sqlite/sqlite.mk b/package/database/sqlite/sqlite.mk
index 00e55598b..3375ca984 100644
--- a/package/database/sqlite/sqlite.mk
+++ b/package/database/sqlite/sqlite.mk
@@ -11,6 +11,15 @@ SQLITE_INSTALL_STAGING = YES
SQLITE_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
SQLITE_LIBTOOL_PATCH = NO
+ifneq ($(BR2_LARGEFILE),y)
+# the sqlite configure script fails to define SQLITE_DISABLE_LFS when
+# --disable-largefile is passed, breaking the build. Work around it by
+# simply adding it to CFLAGS for configure instead
+SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DSQLITE_DISABLE_LFS"
+# changing CFLAGS doesn't work with config.cache
+SQLITE_USE_CONFIG_CACHE = NO
+endif
+
SQLITE_CONF_OPT = --enable-shared \
--enable-static \
--enable-tempstore=yes \