summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--make/gcc_target.mk2
-rw-r--r--make/tar.mk6
2 files changed, 5 insertions, 3 deletions
diff --git a/make/gcc_target.mk b/make/gcc_target.mk
index 2e60b81f7..5d9cb25b7 100644
--- a/make/gcc_target.mk
+++ b/make/gcc_target.mk
@@ -385,9 +385,11 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
rm -f $(TARGET_DIR)/usr/lib/*.la*
# gcc "fixincludes" step is totally broken and takes unwanted
# stuff from the host system. Fix that here.
+ifeq ($(USE_UCLIBC_TOOLCHAIN),true)
rm -rf $(TARGET_DIR)/usr/lib/gcc-lib/$(GNU_TARGET_NAME)/*/include/*
-cp -a $(STAGING_DIR)/usr/lib/gcc-lib/$(GNU_TARGET_NAME)/*/include/* \
$(TARGET_DIR)/usr/lib/gcc-lib/$(GNU_TARGET_NAME)/*/include/
+endif
touch -c $(TARGET_DIR)/usr/bin/gcc
gcc_target: uclibc_target binutils_target $(TARGET_DIR)/usr/bin/gcc
diff --git a/make/tar.mk b/make/tar.mk
index 1e31c1082..168f2543b 100644
--- a/make/tar.mk
+++ b/make/tar.mk
@@ -3,9 +3,9 @@
# tar
#
#############################################################
-GNUTAR_SOURCE:=tar-1.13.tar.gz
-GNUTAR_SITE:=ftp://ftp.gnu.org/gnu/tar
-GNUTAR_DIR:=$(BUILD_DIR)/tar-1.13
+GNUTAR_SOURCE:=tar-1.13.25.tar.gz
+GNUTAR_SITE:=ftp://alpha.gnu.org/gnu/tar
+GNUTAR_DIR:=$(BUILD_DIR)/tar-1.13.25
GNUTAR_CAT:=zcat
GNUTAR_BINARY:=src/tar
GNUTAR_TARGET_BINARY:=bin/tar