summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES6
-rw-r--r--Makefile1
-rw-r--r--package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch27
-rw-r--r--package/at/at-3.1.12-0007-include-config-h.patch16
-rw-r--r--package/multimedia/alsa-lib/Config.in4
-rw-r--r--package/rsync/rsync.mk4
-rwxr-xr-xscripts/get_linux_config.sh1
7 files changed, 57 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index c8ddc6eae..5de44dc15 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,9 @@
+2010.02-rc2, Not yet released:
+
+ Fixes all over the tree and new features.
+
+ Updated/fixed packages: argus, at, libpcap
+
2010.02-rc1, Released February 9th, 2010:
Fixes all over the tree and new features.
diff --git a/Makefile b/Makefile
index a0c18ba7c..76eeddb91 100644
--- a/Makefile
+++ b/Makefile
@@ -371,6 +371,7 @@ ifneq ($(BR2_TOOLCHAIN_EXTERNAL),y)
endif
endif
@mkdir -p $(STAGING_DIR)/usr/include
+ @mkdir -p $(STAGING_DIR)/usr/bin
$(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
diff --git a/package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch b/package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch
new file mode 100644
index 000000000..2060c9363
--- /dev/null
+++ b/package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch
@@ -0,0 +1,27 @@
+Instead of hardcoding a wrong prototype for a libcap function, include
+the correct header.
+
+Index: argus-3.0.0.rc.34/argus/ArgusSource.c
+===================================================================
+--- argus-3.0.0.rc.34.orig/argus/ArgusSource.c 2010-02-09 22:57:21.000000000 +0100
++++ argus-3.0.0.rc.34/argus/ArgusSource.c 2010-02-09 22:57:29.000000000 +0100
+@@ -53,6 +53,7 @@
+ #define PPP_HDRLEN 4 /* length of PPP header */
+ #endif
+
++#include <pcap.h>
+
+ void ArgusGetInterfaceStatus (struct ArgusSourceStruct *src);
+
+Index: argus-3.0.0.rc.34/argus/ArgusSource.h
+===================================================================
+--- argus-3.0.0.rc.34.orig/argus/ArgusSource.h 2010-02-09 22:57:35.000000000 +0100
++++ argus-3.0.0.rc.34/argus/ArgusSource.h 2010-02-09 22:57:54.000000000 +0100
+@@ -381,7 +381,6 @@
+
+ int ArgusCreatePktFromFddi(const struct fddi_header *, struct ether_header *, int);
+
+-extern char *bpf_image(struct bpf_insn *, int);
+
+
+ #else /* defined(ArgusSource) */
diff --git a/package/at/at-3.1.12-0007-include-config-h.patch b/package/at/at-3.1.12-0007-include-config-h.patch
new file mode 100644
index 000000000..8afc502c8
--- /dev/null
+++ b/package/at/at-3.1.12-0007-include-config-h.patch
@@ -0,0 +1,16 @@
+Make sure to include config.h so that NEEDS_* macros are properly
+taken into account. This was a problem for NEEDS_YYWRAP, which was set
+to 1 in config.h, but the corresponding code wasn't compiled in.
+
+Index: at-3.1.12/parsetime.l
+===================================================================
+--- at-3.1.12.orig/parsetime.l 2010-02-10 00:17:46.000000000 +0100
++++ at-3.1.12/parsetime.l 2010-02-10 00:18:07.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include <time.h>
+ #include "y.tab.h"
+ #include "parsetime.h"
++#include "config.h"
+
+ char *last_token = NULL;
+ char **my_argv;
diff --git a/package/multimedia/alsa-lib/Config.in b/package/multimedia/alsa-lib/Config.in
index 84629e66a..98b83139d 100644
--- a/package/multimedia/alsa-lib/Config.in
+++ b/package/multimedia/alsa-lib/Config.in
@@ -1,5 +1,9 @@
config BR2_PACKAGE_ALSA_LIB
bool "alsa-lib"
+ # Temporary until
+ # https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4913
+ # is fixed
+ select BR2_PACKAGE_ALSA_LIB_PCM
help
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
functionality to the Linux operating system.
diff --git a/package/rsync/rsync.mk b/package/rsync/rsync.mk
index 1ed681219..e1bb28e0d 100644
--- a/package/rsync/rsync.mk
+++ b/package/rsync/rsync.mk
@@ -4,9 +4,9 @@
#
#############################################################
-RSYNC_VERSION:=3.0.6
+RSYNC_VERSION:=3.0.7
RSYNC_SOURCE:=rsync-$(RSYNC_VERSION).tar.gz
-RSYNC_SITE:=http://rsync.samba.org/ftp/rsync
+RSYNC_SITE:=http://rsync.samba.org/ftp/rsync/src
RSYNC_INSTALL_STAGING:=NO
RSYNC_INSTALL_TARGET:=YES
RSYNC_CONF_OPT=$(if $(BR2_ENABLE_DEBUG),--enable-debug,--disable-debug)
diff --git a/scripts/get_linux_config.sh b/scripts/get_linux_config.sh
index 1950e9d2e..5cd0e371f 100755
--- a/scripts/get_linux_config.sh
+++ b/scripts/get_linux_config.sh
@@ -35,6 +35,7 @@ function linux_version()
KERNEL=`echo ${KCONFIG} | sed s/.*linux-2.6./linux-2.6./g -`
THIS_MAJOR=${KERNEL:10:2}
THIS_MINOR=${KERNEL:13}
+ THIS_MINOR=${THIS_MINOR:=0}
}
# Try to be careful...