summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES11
-rw-r--r--package/Config.in1
-rw-r--r--package/games/Config.in1
-rw-r--r--package/games/vice/Config.in8
-rw-r--r--package/games/vice/vice-1.22-remove-bzero.patch20
-rw-r--r--package/games/vice/vice.mk15
-rw-r--r--package/hostapd/hostapd.mk1
-rw-r--r--package/less/less.mk1
-rw-r--r--package/libnl/libnl-1.1-netlink-local-fix.patch19
-rw-r--r--package/netplug/netplug-1.2.9-disable-werror.patch22
-rw-r--r--package/x11r7/libxcb/libxcb.mk2
-rw-r--r--package/xvkbd/Config.in1
-rw-r--r--package/xvkbd/xvkbd.mk4
13 files changed, 54 insertions, 52 deletions
diff --git a/CHANGES b/CHANGES
index bd769810a..03eed655c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -3,10 +3,13 @@
Fixes all over the tree.
Updated/fixed packages: busybox, customize, hal, hostapd,
- libxcb, mplayer, pciutils, xdriver_xf86-video-openchrome,
- usb_modeswitch, usbutils, wpa_supplicant, xapp_bdftopcf,
- xapp_mkfontdir, xfont_encodings, xlib_libX11, xlib_libXfont,
- xlib_xtrans, xproto_fontcacheproto, xproto_fontsproto.
+ less, libnl, libxcb, mplayer, netplug, pciutils,
+ xdriver_xf86-video-openchrome, usb_modeswitch, usbutils,
+ wpa_supplicant, xapp_bdftopcf, xapp_mkfontdir,
+ xfont_encodings, xlib_libX11, xlib_libXfont, xlib_xtrans,
+ xproto_fontcacheproto, xproto_fontsproto, xvkbd
+
+ Removed packages: vice
Issues resolved (http://bugs.uclibc.org):
diff --git a/package/Config.in b/package/Config.in
index 6848f9ffe..d3c43160a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -81,7 +81,6 @@ source "package/games/lxdoom/Config.in"
source "package/games/magiccube4d/Config.in"
source "package/games/prboom/Config.in"
source "package/games/rubix/Config.in"
-source "package/games/vice/Config.in"
endmenu
menu "Graphic libraries and applications (graphic/text)"
diff --git a/package/games/Config.in b/package/games/Config.in
index 16924a47e..ed799ab4e 100644
--- a/package/games/Config.in
+++ b/package/games/Config.in
@@ -6,5 +6,4 @@ source "package/games/lxdoom/Config.in"
source "package/games/magiccube4d/Config.in"
source "package/games/prboom/Config.in"
source "package/games/rubix/Config.in"
-source "package/games/vice/Config.in"
endmenu
diff --git a/package/games/vice/Config.in b/package/games/vice/Config.in
deleted file mode 100644
index e4c5621c5..000000000
--- a/package/games/vice/Config.in
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_PACKAGE_VICE
- bool "vice"
- depends on BROKEN # doesn't build, wrong dependencies
- # remove before 2010.02 release
- help
- VICE is a Commodore emulator
-
- http://www.viceteam.org/online
diff --git a/package/games/vice/vice-1.22-remove-bzero.patch b/package/games/vice/vice-1.22-remove-bzero.patch
deleted file mode 100644
index 5836a9fce..000000000
--- a/package/games/vice/vice-1.22-remove-bzero.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/src/network.c 2007-07-15 18:49:24.000000000 -0400
-+++ b/src/network.c 2008-03-01 21:29:40.000000000 -0500
-@@ -742,7 +742,7 @@ int network_start_server(void)
-
- #ifdef HAVE_IPV6
- if (netplay_ipv6) {
-- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
-+ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
- server_addr6.sin6_port = htons(server_port);
- server_addr6.sin6_family = PF_INET6;
- server_addr6.sin6_addr=in6addr_any;
-@@ -853,7 +853,7 @@ int network_connect_client(void)
- }
- #ifdef HAVE_IPV6
- if (netplay_ipv6) {
-- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
-+ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
- server_addr6.sin6_port = htons(server_port);
- server_addr6.sin6_family = PF_INET6;
- memcpy(&server_addr6.sin6_addr, server_hostent->h_addr, server_hostent->h_length);
diff --git a/package/games/vice/vice.mk b/package/games/vice/vice.mk
deleted file mode 100644
index 305809d2c..000000000
--- a/package/games/vice/vice.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#############################################################
-#
-# vice
-#
-#############################################################
-VICE_VERSION = 1.22
-VICE_SOURCE = vice-$(VICE_VERSION).tar.gz
-VICE_SITE = http://www.viceteam.org/online
-VICE_INSTALL_STAGING = NO
-VICE_INSTALL_TARGET = YES
-
-VICE_CONF_OPT = --without-resid --with-alsa
-
-$(eval $(call AUTOTARGETS,package/games,vice))
-
diff --git a/package/hostapd/hostapd.mk b/package/hostapd/hostapd.mk
index 2359fd348..bde3766d7 100644
--- a/package/hostapd/hostapd.mk
+++ b/package/hostapd/hostapd.mk
@@ -45,6 +45,7 @@ endif
# We take care of that in Config.in
ifneq ($(BR2_PACKAGE_OPENSSL),y)
echo "CONFIG_CRYPTO=internal" >>$(HOSTAPD_CONFIG)
+ echo "CONFIG_INTERNAL_LIBTOMMATH=y" >>$(HOSTAPD_CONFIG)
echo "CONFIG_TLS=internal" >>$(HOSTAPD_CONFIG)
endif
# WPS
diff --git a/package/less/less.mk b/package/less/less.mk
index 706a3e026..bae1cf654 100644
--- a/package/less/less.mk
+++ b/package/less/less.mk
@@ -6,6 +6,7 @@
LESS_VERSION = 436
LESS_SITE = http://www.greenwoodsoftware.com/less
+LESS_DEPENDENCIES = ncurses
$(eval $(call AUTOTARGETS,package,less))
diff --git a/package/libnl/libnl-1.1-netlink-local-fix.patch b/package/libnl/libnl-1.1-netlink-local-fix.patch
new file mode 100644
index 000000000..79cda2850
--- /dev/null
+++ b/package/libnl/libnl-1.1-netlink-local-fix.patch
@@ -0,0 +1,19 @@
+Fixes the ULONG_MAX definition problem:
+
+In file included from cache.c:43:
+../include/netlink-local.h: In function '__str2type':../include/netlink-local.h:218: error: 'ULONG_MAX' undeclared (first use in this function)
+
+Patch borrowed from OpenEmbedded, recipes/libnl/files/netlink-local-fix.patch.
+
+Index: libnl-1.1/include/netlink-local.h
+===================================================================
+--- libnl-1.1.orig/include/netlink-local.h 2009-06-18 15:28:32.614209645 +0400
++++ libnl-1.1/include/netlink-local.h 2009-06-18 15:28:44.094190518 +0400
+@@ -26,6 +26,7 @@
+ #include <sys/socket.h>
+ #include <inttypes.h>
+ #include <assert.h>
++#include <limits.h>
+
+ #include <arpa/inet.h>
+ #include <netdb.h>
diff --git a/package/netplug/netplug-1.2.9-disable-werror.patch b/package/netplug/netplug-1.2.9-disable-werror.patch
new file mode 100644
index 000000000..d8a3e15a1
--- /dev/null
+++ b/package/netplug/netplug-1.2.9-disable-werror.patch
@@ -0,0 +1,22 @@
+netplug uses nested functions, and gcc generates a warning that
+is turned into an error:
+
+cc1: warnings being treated as errors
+if_info.c: In function 'ifsm_scriptdone':
+if_info.c:289: error: generating trampoline in object (requires executable stack)
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: netplug-1.2.9/Makefile
+===================================================================
+--- netplug-1.2.9.orig/Makefile 2010-05-09 21:07:40.000000000 +0200
++++ netplug-1.2.9/Makefile 2010-05-09 21:09:32.000000000 +0200
+@@ -9,7 +9,7 @@
+
+ install_opts :=
+
+-CFLAGS += -Wall -Werror -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
++CFLAGS += -Wall -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
+ -DNP_SCRIPT_DIR='"$(scriptdir)"' -ggdb3 -O3 -DNP_VERSION='"$(version)"'
+
+ netplugd: config.o netlink.o lib.o if_info.o main.o
diff --git a/package/x11r7/libxcb/libxcb.mk b/package/x11r7/libxcb/libxcb.mk
index c8b70ea18..4f9b3233c 100644
--- a/package/x11r7/libxcb/libxcb.mk
+++ b/package/x11r7/libxcb/libxcb.mk
@@ -13,7 +13,7 @@ LIBXCB_AUTORECONF = NO
LIBXCB_LIBTOOL_PATCH = NO
LIBXCB_DEPENDENCIES = host-libxslt pthread-stubs xcb-proto xlib_libXdmcp xlib_libXau
LIBXCB_CONF_ENV = STAGING_DIR="$(STAGING_DIR)"
-HOST_PYTHON_VERSION=$(shell python --version 2>&1 | sed 's/Python \(2\.[0-9]\)\..*/\1/')
+HOST_PYTHON_VERSION=$(shell python --version 2>&1 | sed 's/Python \([0-9]\.[^\.]\).*/\1/')
LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb XCBPROTO_XCBPYTHONDIR=$(STAGING_DIR)/usr/lib/python$(HOST_PYTHON_VERSION)/site-packages
$(eval $(call AUTOTARGETS,package/x11r7,libxcb))
diff --git a/package/xvkbd/Config.in b/package/xvkbd/Config.in
index 888367a2d..8a4b84765 100644
--- a/package/xvkbd/Config.in
+++ b/package/xvkbd/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_XVKBD
bool "xvkbd"
depends on BR2_PACKAGE_XORG7
+ select BR2_PACKAGE_XLIB_LIBXAW
help
on-screen keyboard for X
diff --git a/package/xvkbd/xvkbd.mk b/package/xvkbd/xvkbd.mk
index 8f0202181..b7da396db 100644
--- a/package/xvkbd/xvkbd.mk
+++ b/package/xvkbd/xvkbd.mk
@@ -3,7 +3,7 @@
# xvkbd
#
#############################################################
-XVKBD_VERSION = 2.8
+XVKBD_VERSION = 3.2
XVKBD_SOURCE = xvkbd-$(XVKBD_VERSION).tar.gz
XVKBD_SITE = http://homepage3.nifty.com/tsato/xvkbd
XVKBD_AUTORECONF = NO
@@ -15,7 +15,7 @@ XVKBD_MAKE_OPT = CC=$(TARGET_CC) CXX=$(TARGET_CXX) LD=$(TARGET_CC) \
XVKBD_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
-XVKBD_DEPENDENCIES = xserver_xorg-server
+XVKBD_DEPENDENCIES = xserver_xorg-server xlib_libXaw
$(eval $(call AUTOTARGETS,package,xvkbd))