summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES6
-rw-r--r--Makefile2
-rw-r--r--package/multimedia/aumix/aumix.mk2
-rw-r--r--package/ntp/ntp-optional-ipv6.patch24
-rw-r--r--package/qt/qt.mk2
-rw-r--r--target/Makefile.in2
6 files changed, 33 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index 5b0065cfc..7a3fe09f4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,11 @@
Fixes all over the tree.
- Updated/fixed packages: avahi, busybox, mtd-utils
+ Updated/fixed packages: aumix, avahi, busybox, mtd-utils, ntp, qt
+
+ Issues resolved (http://bugs.uclibc.org):
+
+ #1693: NTP trys IPV6 even if not configured error: 'IPV6_MULTICAST...
2010.05-rc2, Released May 11th, 2010:
diff --git a/Makefile b/Makefile
index a4bf4b570..d59ea45be 100644
--- a/Makefile
+++ b/Makefile
@@ -320,8 +320,6 @@ ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
TARGETS+=target-purgelocales
endif
-include fs/common.mk
-
# target stuff is last so it can override anything else
include target/Makefile.in
diff --git a/package/multimedia/aumix/aumix.mk b/package/multimedia/aumix/aumix.mk
index e28a72037..65d9d396c 100644
--- a/package/multimedia/aumix/aumix.mk
+++ b/package/multimedia/aumix/aumix.mk
@@ -6,7 +6,7 @@
AUMIX_VERSION=2.8
AUMIX_SOURCE=aumix-$(AUMIX_VERSION).tar.bz2
-AUMIX_SITE=http://jpj.net/~trevor/aumix
+AUMIX_SITE=http://jpj.net/~trevor/aumix/releases
AUMIX_AUTORECONF=YES
AUMIX_CONF_OPT = \
diff --git a/package/ntp/ntp-optional-ipv6.patch b/package/ntp/ntp-optional-ipv6.patch
new file mode 100644
index 000000000..20d6edfad
--- /dev/null
+++ b/package/ntp/ntp-optional-ipv6.patch
@@ -0,0 +1,24 @@
+[PATCH] ntpd: fix build without ipv6 support
+
+ntp_io.c was checkin the non-existing DISABLE_IPV6 define rather
+than WANT_IPV6 as defined in config.h, breaking the build if
+the toolchain doesn't have ipv6 support.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ ntpd/ntp_io.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: ntp-4.2.4p5/ntpd/ntp_io.c
+===================================================================
+--- ntp-4.2.4p5.orig/ntpd/ntp_io.c
++++ ntp-4.2.4p5/ntpd/ntp_io.c
+@@ -55,7 +55,7 @@
+ * Set up some macros to look for IPv6 and IPv6 multicast
+ */
+
+-#if defined(ISC_PLATFORM_HAVEIPV6) && !defined(DISABLE_IPV6)
++#if defined(ISC_PLATFORM_HAVEIPV6) && defined(WANT_IPV6)
+
+ #define INCLUDE_IPV6_SUPPORT
+
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 4f42e59e8..aaf965e3c 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -372,7 +372,7 @@ BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
# x86x86fix
# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
# host. It's unclear if this would happen on other hosts.
-ifneq ($(findstring unknown-linux,$(GNU_HOST_NAME)),)
+ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),)
QT_CONFIGURE+= -platform linux-g++
endif
diff --git a/target/Makefile.in b/target/Makefile.in
index afe96a7f0..ffcdbb64e 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -62,6 +62,8 @@ ifeq ($(BR2_TARGET_UBOOT),y)
include target/u-boot/Makefile.in
endif
+include fs/common.mk
+
# kernel rules
# We already did add the kernel target to TARGETS and now just pull in the rules
# to actually build this target.