summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--boot/u-boot/u-boot.mk4
-rw-r--r--package/qt/Config.sql.in7
-rw-r--r--package/qt/qt.mk5
-rw-r--r--toolchain/sstrip/sstrip.c3
5 files changed, 14 insertions, 6 deletions
diff --git a/CHANGES b/CHANGES
index 35e7fde1d..e1f8a0e0b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -59,6 +59,7 @@
#2155: Compression lzo don't set for ubifs
#2166: [SECURITY] Update libpng to 1.2.44
#2167: Bump busybox to 1.17.0, convert to gentargets, drop 1.12, ...
+ #2221: Qt does not compile (dependencies not taken into account?)
2010.05, Released May 30th, 2010:
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index 37ed21557..c21166fe7 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -35,7 +35,7 @@ U_BOOT_TARGETS:=$(BINARIES_DIR)/$(U_BOOT_BIN) $(MKIMAGE)
U_BOOT_ARCH=$(KERNEL_ARCH)
# u-boot in the past used arch=ppc for powerpc
-ifneq ($(findstring x200,$(UBOOT_VERSION))$(findstring x2010.03,$(UBOOT_VERSION)),)
+ifneq ($(findstring x200,x$(U_BOOT_VERSION))$(findstring x2010.03,x$(U_BOOT_VERSION)),)
U_BOOT_ARCH=$(KERNEL_ARCH:powerpc=ppc)
endif
@@ -81,8 +81,6 @@ ifeq ($(U_BOOT_BOARD_NAME),)
$(error NO U-Boot board name set. Check your BR2_TARGET_UBOOT_BOARDNAME setting)
endif
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
$(U_BOOT_CONFIGURE_OPTS) \
$(MAKE) -C $(U_BOOT_DIR) \
$(U_BOOT_BOARD_NAME)_config
diff --git a/package/qt/Config.sql.in b/package/qt/Config.sql.in
index 2ce8d7964..b982fdb4d 100644
--- a/package/qt/Config.sql.in
+++ b/package/qt/Config.sql.in
@@ -6,24 +6,30 @@ menuconfig BR2_PACKAGE_QT_SQL_MODULE
if BR2_PACKAGE_QT_SQL_MODULE
config BR2_PACKAGE_QT_MYSQL
bool "MySQL Driver"
+ select BR2_PACKAGE_MYSQL_CLIENT
+ select BR2_PACKAGE_NCURSES
+ select BR2_PACKAGE_READLINE
help
Build MySQL driver
If unsure, say n.
config BR2_PACKAGE_QT_IBASE
bool "iBase Driver"
+ depends on BROKEN # libfbclient not in BR
help
Build iBase driver
If unsure, say n.
config BR2_PACKAGE_QT_ODBC
bool "ODBC Driver"
+ depends on BROKEN # libodbc not in BR
help
Build ODBC driver
If unsure, say n.
config BR2_PACKAGE_QT_PSQL
bool "PostgreSQL Driver"
+ depends on BROKEN # libpgsql not in BR
help
Build PostgreSQL driver
If unsure, say n.
@@ -36,6 +42,7 @@ config BR2_PACKAGE_QT_SQLITE
config BR2_PACKAGE_QT_SQLITE2
bool "SQLite 2 Driver"
+ depends on BROKEN # sqlite2 not in BR
help
Build SQLite 2 driver
If unsure, say n.
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index b4b6b2995..864e79bb6 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -115,6 +115,7 @@ QT_CONFIGURE += -no-gfx-multiscreen
endif
ifeq ($(BR2_PACKAGE_QT_GFX_DIRECTFB),y)
QT_CONFIGURE += -qt-gfx-directfb
+QT_DEP_LIBS+=directfb
else
QT_CONFIGURE += -no-gfx-directfb
endif
@@ -272,7 +273,9 @@ ifeq ($(BR2_PACKAGE_QT_IBASE),y)
QT_CONFIGURE+= -qt-sql-ibase
endif
ifeq ($(BR2_PACKAGE_QT_MYSQL),y)
-QT_CONFIGURE+= -qt-sql-mysql
+QT_CONFIGURE+= -qt-sql-mysql -I $(STAGING_DIR)/usr/include/mysql -L $(STAGING_DIR)/usr/lib/mysql
+
+QT_DEP_LIBS+=mysql_client
endif
ifeq ($(BR2_PACKAGE_QT_ODBC),y)
QT_CONFIGURE+= -qt-sql-odbc
diff --git a/toolchain/sstrip/sstrip.c b/toolchain/sstrip/sstrip.c
index 1842f053c..03adc0eac 100644
--- a/toolchain/sstrip/sstrip.c
+++ b/toolchain/sstrip/sstrip.c
@@ -253,8 +253,7 @@ static int modifyheaders ## CLASS (Elf ## CLASS ## _Ehdr *ehdr, \
ESET(phdr->p_offset,newsize); \
ESET(phdr->p_filesz,0); \
} else if (EGET(phdr->p_offset) + EGET(phdr->p_filesz) > newsize) { \
- newsize -= EGET(phdr->p_offset); \
- ESET(phdr->p_filesz, newsize); \
+ ESET(phdr->p_filesz, newsize - EGET(phdr->p_offset)); \
} \
} \
\