summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--Makefile27
-rw-r--r--package/busybox/Config.in2
-rw-r--r--package/busybox/busybox-1.17.3/busybox-1.17.3-dnsd.patch12
-rw-r--r--package/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch13
-rw-r--r--package/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch30
-rw-r--r--package/busybox/busybox-1.17.3/busybox-1.17.3-sort.patch12
-rw-r--r--package/busybox/busybox-1.17.3/busybox-1.17.3-unicode.patch12
-rw-r--r--package/qt/qt-4.7.1-pthread_getattr_np.patch (renamed from package/qt/qt-4.7.0-pthread_getattr_np.patch)0
-rw-r--r--package/qt/qt-4.7.1-pthread_getattr_np_webkit.patch (renamed from package/qt/qt-4.7.0-pthread_getattr_np_webkit.patch)0
-rw-r--r--package/qt/qt.mk2
-rw-r--r--package/zlib/zlib.mk44
-rw-r--r--toolchain/kernel-headers/Config.in6
-rw-r--r--toolchain/kernel-headers/linux-2.6.32.26-scsi-use-__uX-types-for-headers-exported-to-user-space.patch (renamed from toolchain/kernel-headers/linux-2.6.32.25-scsi-use-__uX-types-for-headers-exported-to-user-space.patch)0
-rw-r--r--toolchain/kernel-headers/linux-2.6.35.9-scsi-use-__uX-types-for-headers-exported-to-user-space.patch (renamed from toolchain/kernel-headers/linux-2.6.35.8-scsi-use-__uX-types-for-headers-exported-to-user-space.patch)0
15 files changed, 32 insertions, 130 deletions
diff --git a/CHANGES b/CHANGES
index d8046bc1b..8a560fe0a 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,7 +4,7 @@
Updated/fixed packages: bash, bind, busybox, libglib2,
libcurl, libmad, midori, module-init-tools, mtd-utils,
- openssh, openssl, pciutils, qt, sqlite, sysstat, webkit
+ openssh, openssl, pciutils, qt, sqlite, sysstat, webkit, zlib
Issues resolved (http://bugs.uclibc.org):
diff --git a/Makefile b/Makefile
index 8669eefa6..ef130de8a 100644
--- a/Makefile
+++ b/Makefile
@@ -75,7 +75,6 @@ EXTRAMAKEARGS = O=$(O)
NEED_WRAPPER=y
endif
-# $(shell find . -name *_defconfig |sed 's/.*\///')
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
-include $(CONFIG_DIR)/.config
@@ -289,9 +288,6 @@ include package/Makefile.in
all: world
-# In this section, we need .config
--include $(CONFIG_DIR)/.config.cmd
-
# We also need the various per-package makefiles, which also add
# each selected package to TARGETS if that package was selected
# in the .config file.
@@ -489,28 +485,19 @@ COMMON_CONFIG_ENV = \
xconfig: $(BUILD_DIR)/buildroot-config/qconf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
- @if ! $(COMMON_CONFIG_ENV) $< $(CONFIG_CONFIG_IN); then \
- test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
- fi
+ @$(COMMON_CONFIG_ENV) $< $(CONFIG_CONFIG_IN)
gconfig: $(BUILD_DIR)/buildroot-config/gconf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
- @if ! $(COMMON_CONFIG_ENV) srctree=$(TOPDIR) \
- $< $(CONFIG_CONFIG_IN); then \
- test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
- fi
+ @$(COMMON_CONFIG_ENV) srctree=$(TOPDIR) $< $(CONFIG_CONFIG_IN)
menuconfig: $(BUILD_DIR)/buildroot-config/mconf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
- @if ! $(COMMON_CONFIG_ENV) $< $(CONFIG_CONFIG_IN); then \
- test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
- fi
+ @$(COMMON_CONFIG_ENV) $< $(CONFIG_CONFIG_IN)
nconfig: $(BUILD_DIR)/buildroot-config/nconf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
- @if ! $(COMMON_CONFIG_ENV) $< $(CONFIG_CONFIG_IN); then \
- test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
- fi
+ @$(COMMON_CONFIG_ENV) $< $(CONFIG_CONFIG_IN)
config: $(BUILD_DIR)/buildroot-config/conf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
@@ -603,10 +590,7 @@ endif
ifeq ($(O),output)
rm -rf $(O)
endif
- rm -rf $(CONFIG_DIR)/.config $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.config.cmd $(CONFIG_DIR)/.auto.deps
-
-flush:
- rm -f $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
+ rm -rf $(CONFIG_DIR)/.config $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.auto.deps
configured: dirs kernel-headers uclibc-config busybox-config linux26-config
@@ -640,7 +624,6 @@ help:
@echo ' source - download all sources needed for offline-build'
@echo ' source-check - check all packages for valid download URLs'
@echo ' external-deps - list external packages used'
- @echo ' flush - flush configuration cache'
@echo
@$(foreach b, $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig)), \
printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index 784ad52ca..e53046e58 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -45,7 +45,7 @@ config BR2_BUSYBOX_VERSION
default "1.14.4" if BR2_BUSYBOX_VERSION_1_14_X
default "1.15.3" if BR2_BUSYBOX_VERSION_1_15_X
default "1.16.2" if BR2_BUSYBOX_VERSION_1_16_X
- default "1.17.3" if BR2_BUSYBOX_VERSION_1_17_X
+ default "1.17.4" if BR2_BUSYBOX_VERSION_1_17_X
config BR2_PACKAGE_BUSYBOX_FULLINSTALL
bool "Run BusyBox's own full installation"
diff --git a/package/busybox/busybox-1.17.3/busybox-1.17.3-dnsd.patch b/package/busybox/busybox-1.17.3/busybox-1.17.3-dnsd.patch
deleted file mode 100644
index b135c1463..000000000
--- a/package/busybox/busybox-1.17.3/busybox-1.17.3-dnsd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urpN busybox-1.17.3/networking/dnsd.c busybox-1.17.3-dnsd/networking/dnsd.c
---- busybox-1.17.3/networking/dnsd.c 2010-10-09 21:57:14.000000000 +0200
-+++ busybox-1.17.3-dnsd/networking/dnsd.c 2010-10-29 00:37:43.066043841 +0200
-@@ -388,7 +388,7 @@ static int process_packet(struct dns_ent
- query_len = strlen(query_string) + 1;
- /* may be unaligned! */
- unaligned_type_class = (void *)(query_string + query_len);
-- query_len += sizeof(unaligned_type_class);
-+ query_len += sizeof(*unaligned_type_class);
- /* where to append answer block */
- answb = (void *)(unaligned_type_class + 1);
-
diff --git a/package/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch b/package/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch
deleted file mode 100644
index 03c749f38..000000000
--- a/package/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -urpN busybox-1.17.3/networking/libiproute/iproute.c busybox-1.17.3-iproute/networking/libiproute/iproute.c
---- busybox-1.17.3/networking/libiproute/iproute.c 2010-10-09 21:57:14.000000000 +0200
-+++ busybox-1.17.3-iproute/networking/libiproute/iproute.c 2010-11-04 09:13:06.307919550 +0100
-@@ -791,8 +791,8 @@ static int iproute_get(char **argv)
- }
- req.r.rtm_dst_len = addr.bitlen;
- }
-- argv++;
- }
-+ argv++;
- }
-
- if (req.r.rtm_dst_len == 0) {
diff --git a/package/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch b/package/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch
deleted file mode 100644
index 1c4f89516..000000000
--- a/package/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -urpN busybox-1.17.3/coreutils/ls.c busybox-1.17.3-ls/coreutils/ls.c
---- busybox-1.17.3/coreutils/ls.c 2010-10-09 21:57:13.000000000 +0200
-+++ busybox-1.17.3-ls/coreutils/ls.c 2010-11-06 00:26:48.467049575 +0100
-@@ -184,7 +184,7 @@ static const unsigned opt_flags[] = {
- LIST_INO, /* i */
- LIST_LONG | STYLE_LONG, /* l - remember LS_DISP_HR in mask! */
- LIST_SHORT | STYLE_SINGLE, /* 1 */
-- 0, /* g (don't show group) - handled via OPT_g */
-+ 0, /* g (don't show owner) - handled via OPT_g */
- LIST_ID_NUMERIC, /* n */
- LIST_BLOCKS, /* s */
- DISP_ROWS, /* x */
-@@ -621,7 +621,7 @@ static NOINLINE unsigned list_single(con
- if (all_fmt & LIST_ID_NAME) {
- if (option_mask32 & OPT_g) {
- column += printf("%-8.8s ",
-- get_cached_username(dn->dstat.st_uid));
-+ get_cached_groupname(dn->dstat.st_gid));
- } else {
- column += printf("%-8.8s %-8.8s ",
- get_cached_username(dn->dstat.st_uid),
-@@ -631,7 +631,7 @@ static NOINLINE unsigned list_single(con
- #endif
- if (all_fmt & LIST_ID_NUMERIC) {
- if (option_mask32 & OPT_g)
-- column += printf("%-8u ", (int) dn->dstat.st_uid);
-+ column += printf("%-8u ", (int) dn->dstat.st_gid);
- else
- column += printf("%-8u %-8u ",
- (int) dn->dstat.st_uid,
diff --git a/package/busybox/busybox-1.17.3/busybox-1.17.3-sort.patch b/package/busybox/busybox-1.17.3/busybox-1.17.3-sort.patch
deleted file mode 100644
index ebc9bf9f9..000000000
--- a/package/busybox/busybox-1.17.3/busybox-1.17.3-sort.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urpN busybox-1.17.3/coreutils/sort.c busybox-1.17.3-sort/coreutils/sort.c
---- busybox-1.17.3/coreutils/sort.c 2010-10-09 21:57:13.000000000 +0200
-+++ busybox-1.17.3-sort/coreutils/sort.c 2010-10-20 15:17:35.320293543 +0200
-@@ -412,7 +412,7 @@ int sort_main(int argc UNUSED_PARAM, cha
- #if ENABLE_FEATURE_SORT_BIG
- /* Open output file _after_ we read all input ones */
- if (option_mask32 & FLAG_o)
-- xmove_fd(xopen3(str_o, O_WRONLY, 0666), STDOUT_FILENO);
-+ xmove_fd(xopen3(str_o, O_WRONLY|O_CREAT|O_TRUNC, 0666), STDOUT_FILENO);
- #endif
- flag = (option_mask32 & FLAG_z) ? '\0' : '\n';
- for (i = 0; i < linecount; i++)
diff --git a/package/busybox/busybox-1.17.3/busybox-1.17.3-unicode.patch b/package/busybox/busybox-1.17.3/busybox-1.17.3-unicode.patch
deleted file mode 100644
index dc3b02e22..000000000
--- a/package/busybox/busybox-1.17.3/busybox-1.17.3-unicode.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urpN busybox-1.17.3/libbb/unicode.c busybox-1.17.3-unicode/libbb/unicode.c
---- busybox-1.17.3/libbb/unicode.c 2010-10-09 21:58:13.000000000 +0200
-+++ busybox-1.17.3-unicode/libbb/unicode.c 2010-10-29 00:48:36.951494079 +0200
-@@ -1006,7 +1006,7 @@ static char* FAST_FUNC unicode_conv_to_p
- }
- }
- if (stats)
-- stats->byte_count = stats->unicode_count = (d - dst);
-+ stats->byte_count = stats->unicode_count = stats->unicode_width = (d - dst);
- return dst;
- }
-
diff --git a/package/qt/qt-4.7.0-pthread_getattr_np.patch b/package/qt/qt-4.7.1-pthread_getattr_np.patch
index 5cbd7d203..5cbd7d203 100644
--- a/package/qt/qt-4.7.0-pthread_getattr_np.patch
+++ b/package/qt/qt-4.7.1-pthread_getattr_np.patch
diff --git a/package/qt/qt-4.7.0-pthread_getattr_np_webkit.patch b/package/qt/qt-4.7.1-pthread_getattr_np_webkit.patch
index e2bc18843..e2bc18843 100644
--- a/package/qt/qt-4.7.0-pthread_getattr_np_webkit.patch
+++ b/package/qt/qt-4.7.1-pthread_getattr_np_webkit.patch
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index a18ebd469..e344259ae 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -12,7 +12,7 @@
#
######################################################################
-QT_VERSION:=4.7.0
+QT_VERSION:=4.7.1
QT_SOURCE:=qt-everywhere-opensource-src-$(QT_VERSION).tar.gz
QT_SITE:=http://get.qt.nokia.com/qt/source
QT_CAT:=$(ZCAT)
diff --git a/package/zlib/zlib.mk b/package/zlib/zlib.mk
index 751cfc122..016752e03 100644
--- a/package/zlib/zlib.mk
+++ b/package/zlib/zlib.mk
@@ -10,7 +10,7 @@ ZLIB_INSTALL_STAGING=YES
ifeq ($(BR2_PREFER_STATIC_LIB),y)
ZLIB_PIC :=
-ZLIB_SHARED :=
+ZLIB_SHARED := --static
else
ZLIB_PIC := -fPIC
ZLIB_SHARED := --shared
@@ -42,42 +42,40 @@ define HOST_ZLIB_CONFIGURE_CMDS
endef
define ZLIB_BUILD_CMDS
- $(MAKE1) -C $(@D) all libz.a
+ $(MAKE1) -C $(@D)
endef
define HOST_ZLIB_BUILD_CMDS
- $(MAKE1) -C $(@D) all libz.a
+ $(MAKE1) -C $(@D)
endef
define ZLIB_INSTALL_STAGING_CMDS
- $(INSTALL) -D $(@D)/libz.a $(STAGING_DIR)/usr/lib/libz.a
- $(INSTALL) -D $(@D)/zlib.h $(STAGING_DIR)/usr/include/zlib.h
- $(INSTALL) $(@D)/zconf.h $(STAGING_DIR)/usr/include/
- cp -dpf $(@D)/libz.so* $(STAGING_DIR)/usr/lib/
+ $(MAKE1) -C $(@D) DESTDIR=$(STAGING_DIR) install
+endef
+
+define ZLIB_INSTALL_TARGET_CMDS
+ $(MAKE1) -C $(@D) DESTDIR=$(TARGET_DIR) install
endef
define HOST_ZLIB_INSTALL_CMDS
- $(INSTALL) -D $(@D)/libz.a $(HOST_DIR)/usr/lib/libz.a
- $(INSTALL) -D $(@D)/zlib.h $(HOST_DIR)/usr/include/zlib.h
- $(INSTALL) $(@D)/zconf.h $(HOST_DIR)/usr/include/
- cp -dpf $(@D)/libz.so* $(HOST_DIR)/usr/lib/
+ $(MAKE1) -C $(@D) install
endef
-ifeq ($(BR2_HAVE_DEVFILES),y)
-define ZLIB_INSTALL_TARGET_HEADERS
- $(INSTALL) -D $(@D)/zlib.h $(TARGET_DIR)/usr/include/zlib.h
- $(INSTALL) $(@D)/zconf.h $(TARGET_DIR)/usr/include/
+define ZLIB_CLEAN_CMDS
+ -$(MAKE1) -C $(@D) clean
endef
-endif
-define ZLIB_INSTALL_TARGET_CMDS
- mkdir -p $(TARGET_DIR)/usr/lib
- cp -dpf $(@D)/libz.so* $(TARGET_DIR)/usr/lib
- -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libz.so*
- $(INSTALL) -D $(@D)/libz.a $(TARGET_DIR)/usr/lib/libz.a
- $(ZLIB_INSTALL_TARGET_HEADERS)
+define ZLIB_UNINSTALL_STAGING_CMDS
+ $(MAKE1) -C $(@D) DESTDIR=$(STAGING_DIR) uninstall
+endef
+
+define ZLIB_UNINSTALL_TARGET_CMDS
+ $(MAKE1) -C $(@D) DESTDIR=$(TARGET_DIR) uninstall
+endef
+
+define HOST_ZLIB_UNINSTALL_TARGET_CMDS
+ $(MAKE1) -C $(@D) uninstall
endef
$(eval $(call GENTARGETS,package,zlib))
$(eval $(call GENTARGETS,package,zlib,host))
-
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index d3cde7609..5bba7a60e 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -59,10 +59,10 @@ config BR2_DEFAULT_KERNEL_HEADERS
string
default "2.6.30.10" if BR2_KERNEL_HEADERS_2_6_30
default "2.6.31.14" if BR2_KERNEL_HEADERS_2_6_31
- default "2.6.32.25" if BR2_KERNEL_HEADERS_2_6_32
+ default "2.6.32.26" if BR2_KERNEL_HEADERS_2_6_32
default "2.6.33.7" if BR2_KERNEL_HEADERS_2_6_33
default "2.6.34.7" if BR2_KERNEL_HEADERS_2_6_34
- default "2.6.35.8" if BR2_KERNEL_HEADERS_2_6_35
- default "2.6.36" if BR2_KERNEL_HEADERS_2_6_36
+ default "2.6.35.9" if BR2_KERNEL_HEADERS_2_6_35
+ default "2.6.36.1" if BR2_KERNEL_HEADERS_2_6_36
default "2.6" if BR2_KERNEL_HEADERS_SNAP
default $BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION
diff --git a/toolchain/kernel-headers/linux-2.6.32.25-scsi-use-__uX-types-for-headers-exported-to-user-space.patch b/toolchain/kernel-headers/linux-2.6.32.26-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
index 2fc6176e8..2fc6176e8 100644
--- a/toolchain/kernel-headers/linux-2.6.32.25-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
+++ b/toolchain/kernel-headers/linux-2.6.32.26-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
diff --git a/toolchain/kernel-headers/linux-2.6.35.8-scsi-use-__uX-types-for-headers-exported-to-user-space.patch b/toolchain/kernel-headers/linux-2.6.35.9-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
index 1089c7106..1089c7106 100644
--- a/toolchain/kernel-headers/linux-2.6.35.8-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
+++ b/toolchain/kernel-headers/linux-2.6.35.9-scsi-use-__uX-types-for-headers-exported-to-user-space.patch