summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--target/ubifs/Config.in18
-rw-r--r--target/ubifs/ubifsroot.mk6
2 files changed, 12 insertions, 12 deletions
diff --git a/target/ubifs/Config.in b/target/ubifs/Config.in
index 903753940..bd8ecc342 100644
--- a/target/ubifs/Config.in
+++ b/target/ubifs/Config.in
@@ -36,25 +36,25 @@ config BR2_TARGET_ROOTFS_UBIFS_OUTPUT
choice
prompt "ubifs runtime compression"
- default BR2_TARGET_ROOTFS_UBIFS_LZO
+ default BR2_TARGET_ROOTFS_UBIFS_RT_LZO
depends on BR2_TARGET_ROOTFS_UBIFS
help
- Select compressor for ubifs filesystem of the root filesystem
+ Select which compression format to use at run-time within the ubifs file system.
-config BR2_TARGET_ROOTFS_UBIFS_NONE
+config BR2_TARGET_ROOTFS_UBIFS_RT_NONE
bool "no compression"
help
- Do not compress the ubifs filesystem.
+ Don't use run-time compression.
-config BR2_TARGET_ROOTFS_UBIFS_ZLIB
+config BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB
bool "gzip"
help
- Compress the ubifs filesystem with zlib.
+ Use zlib compression at run-time.
-config BR2_TARGET_ROOTFS_UBIFS_LZO
+config BR2_TARGET_ROOTFS_UBIFS_RT_LZO
bool "lzo"
help
- Compress the ext2 filesystem with lzo.
+ Use lzo compression at run-time.
endchoice
@@ -63,7 +63,7 @@ choice
default BR2_TARGET_ROOTFS_UBIFS_NONE
depends on BR2_TARGET_ROOTFS_UBIFS
help
- Select compressor for ubifs filesystem of the root filesystem
+ Select which compression format to compress the final image into.
config BR2_TARGET_ROOTFS_UBIFS_NONE
bool "no compression"
diff --git a/target/ubifs/ubifsroot.mk b/target/ubifs/ubifsroot.mk
index 457e97a81..85f67a5be 100644
--- a/target/ubifs/ubifsroot.mk
+++ b/target/ubifs/ubifsroot.mk
@@ -41,13 +41,13 @@ UBIFS_OPTS := -e $(BR2_TARGET_ROOTFS_UBIFS_LEBSIZE) -c $(BR2_TARGET_ROOTFS_UBIFS
UBIFS_BASE := $(subst ",,$(BR2_TARGET_ROOTFS_UBIFS_OUTPUT))
#")
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_ZLIB),y)
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB),y)
UBIFS_OPTS += -x zlib
endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_LZI),y)
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_LZI),y)
UBIFS_OPTS += -x lzo
endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_NONE),y)
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_NONE),y)
UBIFS_OPTS += -x none
endif