summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--boot/barebox/barebox.mk2
-rw-r--r--package/hostapd/hostapd.mk5
-rw-r--r--package/iw/iw-libnl-30-support.patch47
-rw-r--r--package/kismet/kismet-libnl-30-support.patch123
-rw-r--r--package/libnl/libnl-1.1-flags.patch36
-rw-r--r--package/libnl/libnl-1.1-minor-leaks.patch40
-rw-r--r--package/libnl/libnl-1.1-netlink-local-fix.patch19
-rw-r--r--package/libnl/libnl.mk4
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk1
9 files changed, 179 insertions, 98 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 7a2e02e44..f3e769f4c 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -4,7 +4,7 @@
#
#############################################################
-BAREBOX_VERSION:=2011.04.0
+BAREBOX_VERSION:=2011.05.0
BAREBOX_SOURCE:=barebox-$(BAREBOX_VERSION).tar.bz2
BAREBOX_SITE:=http://www.barebox.org/download/
BAREBOX_DIR:=$(BUILD_DIR)/barebox-$(BAREBOX_VERSION)
diff --git a/package/hostapd/hostapd.mk b/package/hostapd/hostapd.mk
index 4c9506670..f097e75e6 100644
--- a/package/hostapd/hostapd.mk
+++ b/package/hostapd/hostapd.mk
@@ -10,6 +10,10 @@ HOSTAPD_SUBDIR = hostapd
HOSTAPD_CONFIG = $(HOSTAPD_DIR)/$(HOSTAPD_SUBDIR)/.config
HOSTAPD_DEPENDENCIES = libnl
+define HOSTAPD_LIBNL_CONFIG
+ echo "CONFIG_LIBNL20=y" >>$(HOSTAPD_CONFIG)
+endef
+
define HOSTAPD_CRYPTO_CONFIG
echo "CONFIG_CRYPTO=internal" >>$(HOSTAPD_CONFIG)
echo "CONFIG_INTERNAL_LIBTOMMATH=y" >>$(HOSTAPD_CONFIG)
@@ -82,6 +86,7 @@ define HOSTAPD_CONFIGURE_CMDS
$(HOSTAPD_RADIUS_IPV6_CONFIG)
$(HOSTAPD_EAP_CONFIG)
$(HOSTAPD_WPS_CONFIG)
+ $(HOSTAPD_LIBNL_CONFIG)
endef
define HOSTAPD_INSTALL_TARGET_CMDS
diff --git a/package/iw/iw-libnl-30-support.patch b/package/iw/iw-libnl-30-support.patch
new file mode 100644
index 000000000..48a179fb2
--- /dev/null
+++ b/package/iw/iw-libnl-30-support.patch
@@ -0,0 +1,47 @@
+---
+ Makefile | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -24,6 +24,7 @@
+
+ NL1FOUND := $(shell $(PKG_CONFIG) --atleast-version=1 libnl-1 && echo Y)
+ NL2FOUND := $(shell $(PKG_CONFIG) --atleast-version=2 libnl-2.0 && echo Y)
++NL3FOUND := $(shell $(PKG_CONFIG) --atleast-version=3 libnl-3.0 && echo Y)
+
+ ifeq ($(NL1FOUND),Y)
+ NLLIBNAME = libnl-1
+@@ -35,6 +36,12 @@
+ NLLIBNAME = libnl-2.0
+ endif
+
++ifeq ($(NL3FOUND),Y)
++CFLAGS += -DCONFIG_LIBNL20
++LIBS += -lnl-genl
++NLLIBNAME = libnl-3.0
++endif
++
+ ifeq ($(NLLIBNAME),)
+ $(error Cannot find development files for any supported version of libnl)
+ endif
+@@ -53,6 +60,8 @@
+ all: version_check $(ALL)
+
+ version_check:
++ifeq ($(NL3FOUND),Y)
++else
+ ifeq ($(NL2FOUND),Y)
+ else
+ ifeq ($(NL1FOUND),Y)
+@@ -60,6 +69,7 @@
+ $(error No libnl found)
+ endif
+ endif
++endif
+
+
+ VERSION_OBJS := $(filter-out version.o, $(OBJS))
+
diff --git a/package/kismet/kismet-libnl-30-support.patch b/package/kismet/kismet-libnl-30-support.patch
new file mode 100644
index 000000000..cf3c845f6
--- /dev/null
+++ b/package/kismet/kismet-libnl-30-support.patch
@@ -0,0 +1,123 @@
+---
+ configure | 79 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-
+ 1 file changed, 78 insertions(+), 1 deletion(-)
+
+Index: b/configure
+===================================================================
+--- a/configure
++++ b/configure
+@@ -601,6 +601,8 @@
+ libnl1_CFLAGS
+ libnl20_LIBS
+ libnl20_CFLAGS
++libnl30_LIBS
++libnl30_CFLAGS
+ PKG_CONFIG_LIBDIR
+ PKG_CONFIG_PATH
+ PKG_CONFIG
+@@ -712,6 +714,8 @@
+ PKG_CONFIG
+ PKG_CONFIG_PATH
+ PKG_CONFIG_LIBDIR
++libnl30_CFLAGS
++libnl30_LIBS
+ libnl20_CFLAGS
+ libnl20_LIBS
+ libnl1_CFLAGS
+@@ -1361,6 +1365,10 @@
+ directories to add to pkg-config's search path
+ PKG_CONFIG_LIBDIR
+ path overriding pkg-config's built-in search path
++ libnl30_CFLAGS
++ C compiler flags for libnl30, overriding pkg-config
++ libnl30_LIBS
++ linker flags for libnl30, overriding pkg-config
+ libnl20_CFLAGS
+ C compiler flags for libnl20, overriding pkg-config
+ libnl20_LIBS
+@@ -6760,6 +6768,75 @@
+ fi
+ fi
+
++#libnl-3.0
++pkg_failed=no
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnl30" >&5
++$as_echo_n "checking for libnl30... " >&6; }
++
++if test -n "$libnl30_CFLAGS"; then
++ pkg_cv_libnl20_CFLAGS="$libnl30_CFLAGS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnl-3.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "libnl-3.0") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_libnl30_CFLAGS=`$PKG_CONFIG --cflags "libnl-3.0" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++if test -n "$libnl30_LIBS"; then
++ pkg_cv_libnl20_LIBS="$libnl30_LIBS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnl-3.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "libnl-3.0") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_libnl30_LIBS=`$PKG_CONFIG --libs "libnl-3.0" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++
++if test $pkg_failed = yes; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++ _pkg_short_errors_supported=yes
++else
++ _pkg_short_errors_supported=no
++fi
++ if test $_pkg_short_errors_supported = yes; then
++ libnl30_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "libnl-3.0" 2>&1`
++ else
++ libnl30_PKG_ERRORS=`$PKG_CONFIG --print-errors "libnl-3.0" 2>&1`
++ fi
++ # Put the nasty error message in config.log where it belongs
++ echo "$libnl30_PKG_ERRORS" >&5
++
++ libnl30=no
++elif test $pkg_failed = untried; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++ libnl30=no
++else
++ libnl30_CFLAGS=$pkg_cv_libnl30_CFLAGS
++ libnl30_LIBS=$pkg_cv_libnl30_LIBS
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++ libnl30=yes
++fi
++
++# libnl-2.0
+ pkg_failed=no
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnl20" >&5
+ $as_echo_n "checking for libnl20... " >&6; }
+@@ -6897,7 +6974,7 @@
+ $as_echo "yes" >&6; }
+ libnl1=yes
+ fi
+- if test "$libnl20" = "yes"; then
++ if test "$libnl20" = "yes" -o "$libnl30" = "yes"; then
+
+ $as_echo "#define HAVE_LIBNL 1" >>confdefs.h
+
+
diff --git a/package/libnl/libnl-1.1-flags.patch b/package/libnl/libnl-1.1-flags.patch
deleted file mode 100644
index 8c376dfc7..000000000
--- a/package/libnl/libnl-1.1-flags.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From f124a6ff6a19d5c6b6709d38dd2ffa8275abbd5f Mon Sep 17 00:00:00 2001
-From: Gustavo Zacarias <gustavo@zacarias.com.ar>
-Date: Mon, 18 Oct 2010 12:16:27 -0300
-Subject: [PATCH] Make libnl.so mode 0755 when installing, and respect LDFLAGS
-
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
----
- lib/Makefile | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/lib/Makefile b/lib/Makefile
-index 0bf8af7..0098906 100644
---- a/lib/Makefile
-+++ b/lib/Makefile
-@@ -48,7 +48,7 @@ all:
-
- $(OUT_SLIB): ../Makefile.opts $(OBJ)
- @echo " LD $(OUT_SLIB)"; \
-- $(CC) -shared -Wl,-soname,libnl.so.1 -o $(OUT_SLIB) $(OBJ) $(LIBNL_LIB) -lc
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,libnl.so.1 -o $(OUT_SLIB) $(OBJ) $(LIBNL_LIB) -lc
- @echo " LN $(OUT_SLIB) $(LN1_SLIB)"; \
- rm -f $(LN1_SLIB) ; $(LN) -s $(OUT_SLIB) $(LN1_SLIB)
- @echo " LN $(LN1_SLIB) $(LN_SLIB)"; \
-@@ -65,7 +65,7 @@ distclean:
-
- install:
- mkdir -p $(DESTDIR)$(libdir)/
-- install -m 0644 $(OUT_SLIB) $(DESTDIR)$(libdir)
-+ install -m 0755 $(OUT_SLIB) $(DESTDIR)$(libdir)
- rm -f $(DESTDIR)$(libdir)/$(LN1_SLIB)
- $(LN) -s $(OUT_SLIB) $(DESTDIR)$(libdir)/$(LN1_SLIB)
- rm -f $(DESTDIR)$(libdir)/$(LN_SLIB)
---
-1.7.2.2
-
diff --git a/package/libnl/libnl-1.1-minor-leaks.patch b/package/libnl/libnl-1.1-minor-leaks.patch
deleted file mode 100644
index 855a6ab39..000000000
--- a/package/libnl/libnl-1.1-minor-leaks.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From: Patrick McHardy <kaber@trash.net>
-Date: Fri, 18 Jan 2008 16:55:49 +0000 (+0100)
-Subject: [LIBNL]: Fix minor memleaks on exit
-X-Git-Url: http://git.kernel.org/?p=libs%2Fnetlink%2Flibnl.git;a=commitdiff_plain;h=b64f15d6f947839236fa276d473d238f8c9b9d57;hp=e91bb2ffb090955d443e643a25b250bf3d33534a
-
-[LIBNL]: Fix minor memleaks on exit
-
-Make valgrind happy ...
-
-Signed-off-by: Patrick McHardy <kaber@trash.net>
----
-
-diff --git a/lib/route/route_utils.c b/lib/route/route_utils.c
-index a12d169..1386cda 100644
---- a/lib/route/route_utils.c
-+++ b/lib/route/route_utils.c
-@@ -63,6 +63,11 @@ static void __init init_routing_table_names(void)
- add_routing_table_name(RT_TABLE_LOCAL, "local");
- };
-
-+static void __exit release_routing_table_names(void)
-+{
-+ __trans_list_clear(&table_names);
-+}
-+
- int rtnl_route_read_table_names(const char *path)
- {
- __trans_list_clear(&table_names);
-@@ -104,6 +109,11 @@ static void __init init_proto_names(void)
- add_proto_name(RTPROT_STATIC, "static");
- };
-
-+static void __exit release_proto_names(void)
-+{
-+ __trans_list_clear(&proto_names);
-+}
-+
- int rtnl_route_read_protocol_names(const char *path)
- {
- __trans_list_clear(&proto_names);
diff --git a/package/libnl/libnl-1.1-netlink-local-fix.patch b/package/libnl/libnl-1.1-netlink-local-fix.patch
deleted file mode 100644
index 79cda2850..000000000
--- a/package/libnl/libnl-1.1-netlink-local-fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Fixes the ULONG_MAX definition problem:
-
-In file included from cache.c:43:
-../include/netlink-local.h: In function '__str2type':../include/netlink-local.h:218: error: 'ULONG_MAX' undeclared (first use in this function)
-
-Patch borrowed from OpenEmbedded, recipes/libnl/files/netlink-local-fix.patch.
-
-Index: libnl-1.1/include/netlink-local.h
-===================================================================
---- libnl-1.1.orig/include/netlink-local.h 2009-06-18 15:28:32.614209645 +0400
-+++ libnl-1.1/include/netlink-local.h 2009-06-18 15:28:44.094190518 +0400
-@@ -26,6 +26,7 @@
- #include <sys/socket.h>
- #include <inttypes.h>
- #include <assert.h>
-+#include <limits.h>
-
- #include <arpa/inet.h>
- #include <netdb.h>
diff --git a/package/libnl/libnl.mk b/package/libnl/libnl.mk
index 54b9ff276..767e957e5 100644
--- a/package/libnl/libnl.mk
+++ b/package/libnl/libnl.mk
@@ -4,9 +4,9 @@
#
#############################################################
-LIBNL_VERSION = 1.1
+LIBNL_VERSION = 3.0
LIBNL_SOURCE = libnl-$(LIBNL_VERSION).tar.gz
-LIBNL_SITE = http://distfiles.gentoo.org/distfiles
+LIBNL_SITE = http://www.infradead.org/~tgr/libnl/files/
LIBNL_INSTALL_STAGING = YES
define LIBNL_UNINSTALL_TARGET_CMDS
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 698e36522..443a35853 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -16,6 +16,7 @@ ifeq ($(BR2_PACKAGE_LIBNL),y)
WPA_SUPPLICANT_DEPENDENCIES += libnl
define WPA_SUPPLICANT_LIBNL_CONFIG
$(SED) "s/^#CONFIG_DRIVER_NL80211/CONFIG_DRIVER_NL80211/" $(WPA_SUPPLICANT_CONFIG)
+ echo "CONFIG_LIBNL20=y" >>$(WPA_SUPPLICANT_CONFIG)
endef
endif