summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--make/dnsmasq.mk4
-rw-r--r--sources/dnsmasq2-100-config.patch14
2 files changed, 9 insertions, 9 deletions
diff --git a/make/dnsmasq.mk b/make/dnsmasq.mk
index c59204992..af747af06 100644
--- a/make/dnsmasq.mk
+++ b/make/dnsmasq.mk
@@ -6,8 +6,8 @@
DNSMASQ_SITE=http://thekelleys.org.uk/dnsmasq
ifeq ($(filter $(TARGETS),dnsmasq1),)
-DNSMASQ_SOURCE=dnsmasq-2.6.tar.gz
-DNSMASQ_DIR=$(BUILD_DIR)/dnsmasq-2.6
+DNSMASQ_SOURCE=dnsmasq-2.15.tar.gz
+DNSMASQ_DIR=$(BUILD_DIR)/dnsmasq-2.15
DNSMASQ_VER=dnsmasq2
else
DNSMASQ_SOURCE=dnsmasq-1.18.tar.gz
diff --git a/sources/dnsmasq2-100-config.patch b/sources/dnsmasq2-100-config.patch
index 07266b735..270c22740 100644
--- a/sources/dnsmasq2-100-config.patch
+++ b/sources/dnsmasq2-100-config.patch
@@ -1,7 +1,7 @@
-diff -urN dnsmasq-2.6/src/config.h dnsmasq-2.6-new/src/config.h
---- dnsmasq-2.6/src/config.h 2004-04-03 14:03:39.000000000 -0600
-+++ dnsmasq-2.6-new/src/config.h 2004-04-03 19:56:01.000000000 -0600
-@@ -74,6 +74,11 @@
+diff -ur dnsmasq-2.15.orig/src/config.h dnsmasq-2.15/src/config.h
+--- dnsmasq-2.15.orig/src/config.h 2004-10-08 11:41:34.757371880 -0400
++++ dnsmasq-2.15/src/config.h 2004-10-08 11:43:49.074952504 -0400
+@@ -78,6 +78,11 @@
/* We assume that systems which don't have IPv6
headers don't have ntop and pton either */
@@ -10,10 +10,10 @@ diff -urN dnsmasq-2.6/src/config.h dnsmasq-2.6-new/src/config.h
+# define NO_IPV6
+#endif
+
- #if defined(INET6_ADDRSTRLEN) && !defined(NO_IPV6)
+ #if defined(INET6_ADDRSTRLEN) && defined(IPV6_V6ONLY) && !defined(NO_IPV6)
# define HAVE_IPV6
# define ADDRSTRLEN INET6_ADDRSTRLEN
-@@ -191,7 +196,7 @@
+@@ -194,7 +199,7 @@
/* platform dependent options. */
/* Must preceed __linux__ since uClinux defines __linux__ too. */
@@ -22,7 +22,7 @@ diff -urN dnsmasq-2.6/src/config.h dnsmasq-2.6-new/src/config.h
#undef HAVE_LINUX_IPV6_PROC
#define HAVE_GETOPT_LONG
#undef HAVE_ARC4RANDOM
-@@ -205,6 +210,24 @@
+@@ -208,6 +213,24 @@
# define NO_FORK
#endif