diff options
-rw-r--r-- | Config.in | 10 | ||||
-rw-r--r-- | Makefile | 7 |
2 files changed, 17 insertions, 0 deletions
@@ -334,6 +334,16 @@ config BR2_HAVE_DEVFILES Install headers and static libraries in the target filesystem +config BR2_PACKAGE_OVERRIDE_FILE + string "location of a package override file" + default "$(TOPDIR)/local.mk" + help + A package override file is a short makefile that contains + variable definitions of the form <pkg>_OVERRIDE_SRCDIR, + which allows to tell Buildroot to use an existing directory + as the source directory for a particular package. See the + Buildroot documentation for more details on this feature. + endmenu source "toolchain/Config.in" @@ -309,6 +309,13 @@ else ifeq ($(BR2_TOOLCHAIN_CTNG),y) include toolchain/toolchain-crosstool-ng.mk endif +# Include the package override file if one has been provided in the +# configuration. +PACKAGE_OVERRIDE_FILE=$(call qstrip,$(BR2_PACKAGE_OVERRIDE_FILE)) +ifneq ($(PACKAGE_OVERRIDE_FILE),) +-include $(PACKAGE_OVERRIDE_FILE) +endif + include package/*/*.mk include boot/common.mk |