summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES6
-rw-r--r--Makefile1
-rw-r--r--package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch27
-rw-r--r--package/at/at-3.1.12-0007-include-config-h.patch16
4 files changed, 50 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index c8ddc6eae..5de44dc15 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,9 @@
+2010.02-rc2, Not yet released:
+
+ Fixes all over the tree and new features.
+
+ Updated/fixed packages: argus, at, libpcap
+
2010.02-rc1, Released February 9th, 2010:
Fixes all over the tree and new features.
diff --git a/Makefile b/Makefile
index a0c18ba7c..76eeddb91 100644
--- a/Makefile
+++ b/Makefile
@@ -371,6 +371,7 @@ ifneq ($(BR2_TOOLCHAIN_EXTERNAL),y)
endif
endif
@mkdir -p $(STAGING_DIR)/usr/include
+ @mkdir -p $(STAGING_DIR)/usr/bin
$(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
diff --git a/package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch b/package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch
new file mode 100644
index 000000000..2060c9363
--- /dev/null
+++ b/package/argus/argus-3.0.0.rc.34-01-use-pcap-header.patch
@@ -0,0 +1,27 @@
+Instead of hardcoding a wrong prototype for a libcap function, include
+the correct header.
+
+Index: argus-3.0.0.rc.34/argus/ArgusSource.c
+===================================================================
+--- argus-3.0.0.rc.34.orig/argus/ArgusSource.c 2010-02-09 22:57:21.000000000 +0100
++++ argus-3.0.0.rc.34/argus/ArgusSource.c 2010-02-09 22:57:29.000000000 +0100
+@@ -53,6 +53,7 @@
+ #define PPP_HDRLEN 4 /* length of PPP header */
+ #endif
+
++#include <pcap.h>
+
+ void ArgusGetInterfaceStatus (struct ArgusSourceStruct *src);
+
+Index: argus-3.0.0.rc.34/argus/ArgusSource.h
+===================================================================
+--- argus-3.0.0.rc.34.orig/argus/ArgusSource.h 2010-02-09 22:57:35.000000000 +0100
++++ argus-3.0.0.rc.34/argus/ArgusSource.h 2010-02-09 22:57:54.000000000 +0100
+@@ -381,7 +381,6 @@
+
+ int ArgusCreatePktFromFddi(const struct fddi_header *, struct ether_header *, int);
+
+-extern char *bpf_image(struct bpf_insn *, int);
+
+
+ #else /* defined(ArgusSource) */
diff --git a/package/at/at-3.1.12-0007-include-config-h.patch b/package/at/at-3.1.12-0007-include-config-h.patch
new file mode 100644
index 000000000..8afc502c8
--- /dev/null
+++ b/package/at/at-3.1.12-0007-include-config-h.patch
@@ -0,0 +1,16 @@
+Make sure to include config.h so that NEEDS_* macros are properly
+taken into account. This was a problem for NEEDS_YYWRAP, which was set
+to 1 in config.h, but the corresponding code wasn't compiled in.
+
+Index: at-3.1.12/parsetime.l
+===================================================================
+--- at-3.1.12.orig/parsetime.l 2010-02-10 00:17:46.000000000 +0100
++++ at-3.1.12/parsetime.l 2010-02-10 00:18:07.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include <time.h>
+ #include "y.tab.h"
+ #include "parsetime.h"
++#include "config.h"
+
+ char *last_token = NULL;
+ char **my_argv;