summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--target/u-boot/Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index 005d935c6..6ba5c0f10 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -47,7 +47,8 @@ $(U_BOOT_DIR)/.unpacked: $(DL_DIR)/$(U_BOOT_SOURCE)
$(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
toolchain/patch-kernel.sh $(U_BOOT_DIR) target/u-boot/ \
- u-boot-$(U_BOOT_VERSION)-$(BR2_ARCH)-\*.patch\*
+ u-boot-$(U_BOOT_VERSION)-\*.patch \
+ u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH)),"")
@mkdir -p $(U_BOOT_PATCH_DIR)
cp -dpr $(BR2_TARGET_UBOOT_CUSTOM_PATCH) $(U_BOOT_PATCH_DIR)