summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES8
-rw-r--r--Config.in2
-rw-r--r--Makefile10
-rw-r--r--docs/download.html10
-rw-r--r--docs/news.html10
-rw-r--r--fs/jffs2/Config.in4
-rw-r--r--fs/squashfs/squashfs.mk3
-rw-r--r--package/Config.in1
-rw-r--r--package/games/doom-wad/Config.in2
-rw-r--r--package/games/lxdoom/Config.in5
-rw-r--r--package/games/lxdoom/lxdoom-1.4.4-updated.patch173
-rw-r--r--package/games/lxdoom/lxdoom.mk19
-rw-r--r--package/xstroke/Config.in8
-rw-r--r--package/xstroke/xstroke.mk5
14 files changed, 39 insertions, 221 deletions
diff --git a/CHANGES b/CHANGES
index d9607c2f0..35015046e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,8 +1,12 @@
-2010.08: Not yet released:
+2010.11, Not yet released:
+
+2010.08: Released August 31th, 2010:
Fixes all over the tree.
- Updated/fixed packages: atk
+ Updated/fixed packages: atk, xstroke
+
+ Removed packages: lxdoom
2010.08-rc2, Released August 30th, 2010:
diff --git a/Config.in b/Config.in
index 7d32a2f06..da3619a2a 100644
--- a/Config.in
+++ b/Config.in
@@ -8,7 +8,7 @@ config BR2_HAVE_DOT_CONFIG
config BR2_VERSION
string
- default "2010.08-rc2-git"
+ default "2010.11-git"
source "target/Config.in.arch"
source "target/device/Config.in"
diff --git a/Makefile b/Makefile
index 9cc3c7a18..1ab446d8b 100644
--- a/Makefile
+++ b/Makefile
@@ -399,13 +399,17 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
endif
find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
+ mkdir -p $(TARGET_DIR)/etc
+ # Mandatory configuration file and auxilliary cache directory
+ # for recent versions of ldconfig
+ touch $(TARGET_DIR)/etc/ld.so.conf
+ mkdir -p $(TARGET_DIR)/var/cache/ldconfig
if [ -x "$(TARGET_CROSS)ldconfig" ]; \
then \
- $(TARGET_CROSS)ldconfig -r $(TARGET_DIR) 2>/dev/null; \
+ $(TARGET_CROSS)ldconfig -r $(TARGET_DIR); \
else \
- /sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null; \
+ /sbin/ldconfig -r $(TARGET_DIR); \
fi
- mkdir -p $(TARGET_DIR)/etc
echo $(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion) > \
$(TARGET_DIR)/etc/br-version
diff --git a/docs/download.html b/docs/download.html
index 832e7d292..75abc9269 100644
--- a/docs/download.html
+++ b/docs/download.html
@@ -6,14 +6,14 @@
<p>
-The latest stable release is <b>2010.05</b>, which can be downloaded
+The latest stable release is <b>2010.08</b>, which can be downloaded
here:<p>
-<a href="/downloads/buildroot-2010.05.tar.gz">buildroot-2010.05.tar.gz</a>
+<a href="/downloads/buildroot-2010.08.tar.gz">buildroot-2010.08.tar.gz</a>
or
-<a href="/downloads/buildroot-2010.05.tar.bz2">buildroot-2010.05.tar.bz2</a>.
+<a href="/downloads/buildroot-2010.08.tar.bz2">buildroot-2010.08.tar.bz2</a>.
<p>
-
+<!--
The latest release candidate is <b>2010.08-rc2</b>, which can be
downloaded here:<p>
@@ -21,7 +21,7 @@ downloaded here:<p>
or
<a href="/downloads/buildroot-2010.08-rc2.tar.bz2">buildroot-2010.08-rc2.tar.bz2</a>.
<p>
-
+-->
This and earlier releases can always be downloaded from
<a href="/downloads/">http://buildroot.net/downloads/</a>.
diff --git a/docs/news.html b/docs/news.html
index 3dbf2fd86..9545b86c2 100644
--- a/docs/news.html
+++ b/docs/news.html
@@ -6,6 +6,16 @@
<ul>
+ <li><b>31 August 2010 -- 2010.08 released</b>
+
+ <p>The stable 2010.08 release is out - Thanks to everyone
+ contributing and testing the release candidates. See the
+ <a href="http://git.buildroot.net/buildroot/plain/CHANGES?id=2010.08">CHANGES</a>
+ file for more details, read the
+ <a href="http://lists.busybox.net/pipermail/buildroot/2010-August/037078.html">announcement</a>
+ and go to the <a href="/downloads/">downloads page</a> to pick up the
+ <a href="/downloads/buildroot-2010.08.tar.bz2">2010.08 release</a>.</p>
+
<li><b>30 August 2010 -- 2010.08-rc2 released</b>
<p>RC2 is out with more cleanups and bugfixes, see the <a
diff --git a/fs/jffs2/Config.in b/fs/jffs2/Config.in
index b787ec9d1..3f1656869 100644
--- a/fs/jffs2/Config.in
+++ b/fs/jffs2/Config.in
@@ -81,7 +81,9 @@ config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
the pagesize is not a power of 2
config BR2_JFFS2_TARGET_SREC
- bool "RootFS in SREC file formet"
+ bool "RootFS in SREC file format"
+ help
+ The binary data will be encoded in Motorola's S-record format
config BR2_TARGET_ROOTFS_JFFS2_PAD
bool "Pad output"
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 6117de62a..aae22b6fd 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -19,7 +19,8 @@ endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
- $(ROOTFS_SQUASHFS_ARGS)
+ $(ROOTFS_SQUASHFS_ARGS) && \
+ chmod 0644 $$@
endef
$(eval $(call ROOTFS_TARGET,squashfs))
diff --git a/package/Config.in b/package/Config.in
index d8a730dec..d60d8efd0 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -77,7 +77,6 @@ menu "Games"
source "package/games/ace_of_penguins/Config.in"
source "package/games/gnuchess/Config.in"
source "package/games/magiccube4d/Config.in"
-source "package/games/lxdoom/Config.in"
source "package/games/prboom/Config.in"
source "package/games/doom-wad/Config.in"
source "package/games/rubix/Config.in"
diff --git a/package/games/doom-wad/Config.in b/package/games/doom-wad/Config.in
index 2ca9ec1e7..aa1d029eb 100644
--- a/package/games/doom-wad/Config.in
+++ b/package/games/doom-wad/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_DOOM_WAD
bool "shareware Doom WAD file"
- depends on BR2_PACKAGE_LXDOOM || BR2_PACKAGE_PRBOOM
+ depends on BR2_PACKAGE_PRBOOM
help
This will install the shareware wad data file for the doom game.
diff --git a/package/games/lxdoom/Config.in b/package/games/lxdoom/Config.in
deleted file mode 100644
index ebef9f5e6..000000000
--- a/package/games/lxdoom/Config.in
+++ /dev/null
@@ -1,5 +0,0 @@
-config BR2_PACKAGE_LXDOOM
- bool "lxdoom"
- depends on BR2_PACKAGE_XORG7
- help
- This is the linux version of the popular doom game.
diff --git a/package/games/lxdoom/lxdoom-1.4.4-updated.patch b/package/games/lxdoom/lxdoom-1.4.4-updated.patch
deleted file mode 100644
index cbb4a0a4f..000000000
--- a/package/games/lxdoom/lxdoom-1.4.4-updated.patch
+++ /dev/null
@@ -1,173 +0,0 @@
-diff -Nrup lxdoom-1.4.4/src/m_menu.c lxdoom-1.4.4-avr32/src/m_menu.c
---- a/src/m_menu.c 2000-03-17 15:50:30.000000000 -0500
-+++ b/src/m_menu.c 2007-10-22 17:18:43.000000000 -0400
-@@ -38,6 +38,7 @@ rcsid[] = "$Id: m_menu.c,v 1.24 2000/03/
-
- #include <fcntl.h>
- #include <unistd.h>
-+#include <bits/posix1_lim.h>
-
- #include "doomdef.h"
- #include "doomstat.h"
-diff -Nrup lxdoom-1.4.4/src/p_maputl.c lxdoom-1.4.4-avr32/src/p_maputl.c
---- a/src/p_maputl.c 1999-10-12 09:01:13.000000000 -0400
-+++ b/src/p_maputl.c 2007-10-22 17:20:56.000000000 -0400
-@@ -322,7 +322,7 @@ void P_SetThingPosition(mobj_t *thing)
- //
- // A fast function for testing intersections between things and linedefs.
-
--boolean CONSTFUNC ThingIsOnLine(const mobj_t *t, const line_t *l)
-+boolean ThingIsOnLine(const mobj_t *t, const line_t *l)
- {
- int dx = l->dx >> FRACBITS; // Linedef vector
- int dy = l->dy >> FRACBITS;
-diff -Nrup lxdoom-1.4.4/src/r_data.c lxdoom-1.4.4-avr32/src/r_data.c
---- a/src/r_data.c 2000-01-25 17:40:45.000000000 -0500
-+++ b/src/r_data.c 2007-10-22 17:19:29.000000000 -0400
-@@ -38,6 +38,7 @@ rcsid[] = "$Id: r_data.c,v 1.13 2000/01/
- #include "r_main.h"
- #include "r_sky.h"
- #include "lprintf.h" // jff 08/03/98 - declaration of lprintf
-+#include <bits/posix1_lim.h>
-
- //
- // Graphics.
-diff -Nrup lxdoom-1.4.4/src/r_segs.c lxdoom-1.4.4-avr32/src/r_segs.c
---- a/src/r_segs.c 1999-10-17 04:52:04.000000000 -0400
-+++ b/src/r_segs.c 2007-10-22 17:14:46.000000000 -0400
-@@ -47,15 +47,15 @@ rcsid[] = "$Id: r_segs.c,v 1.14 1999/10/
- // killough 1/6/98: replaced globals with statics where appropriate
-
- // True if any of the segs textures might be visible.
--static boolean segtextured;
--static boolean markfloor; // False if the back side is the same plane.
--static boolean markceiling;
--static boolean maskedtexture;
--static int toptexture;
--static int bottomtexture;
--static int midtexture;
-+boolean segtextured;
-+boolean markfloor; // False if the back side is the same plane.
-+boolean markceiling;
-+boolean maskedtexture;
-+int toptexture;
-+int bottomtexture;
-+int midtexture;
-
--static fixed_t toptexheight, midtexheight, bottomtexheight; // cph
-+fixed_t toptexheight, midtexheight, bottomtexheight; // cph
-
- angle_t rw_normalangle; // angle to line origin
- int rw_angle1;
-@@ -65,28 +65,28 @@ lighttable_t **walllights;
- //
- // regular wall
- //
--static int rw_x;
--static int rw_stopx;
--static angle_t rw_centerangle;
--static fixed_t rw_offset;
--static fixed_t rw_scale;
--static fixed_t rw_scalestep;
--static fixed_t rw_midtexturemid;
--static fixed_t rw_toptexturemid;
--static fixed_t rw_bottomtexturemid;
--static int worldtop;
--static int worldbottom;
--static int worldhigh;
--static int worldlow;
--static fixed_t pixhigh;
--static fixed_t pixlow;
--static fixed_t pixhighstep;
--static fixed_t pixlowstep;
--static fixed_t topfrac;
--static fixed_t topstep;
--static fixed_t bottomfrac;
--static fixed_t bottomstep;
--static short *maskedtexturecol;
-+int rw_x;
-+int rw_stopx;
-+angle_t rw_centerangle;
-+fixed_t rw_offset;
-+fixed_t rw_scale;
-+fixed_t rw_scalestep;
-+fixed_t rw_midtexturemid;
-+fixed_t rw_toptexturemid;
-+fixed_t rw_bottomtexturemid;
-+int worldtop;
-+int worldbottom;
-+int worldhigh;
-+int worldlow;
-+fixed_t pixhigh;
-+fixed_t pixlow;
-+fixed_t pixhighstep;
-+fixed_t pixlowstep;
-+fixed_t topfrac;
-+fixed_t topstep;
-+fixed_t bottomfrac;
-+fixed_t bottomstep;
-+short *maskedtexturecol;
-
- //
- // R_ScaleFromGlobalAngle
---- a/src/wi_stuff.c 2008-02-12 14:02:42.000000000 -0500
-+++ b/src/wi_stuff.c 2008-02-12 14:04:34.000000000 -0500
-@@ -368,7 +368,7 @@ static const patch_t * items;
- static const patch_t * frags;
-
- // Time sucks.
--static const patch_t * time;
-+static const patch_t * mytime;
- static const patch_t * par;
- static const patch_t * sucks;
-
-diff -Nrup lxdoom-1.4.4/src/d_main.c lxdoom-1.4.4-avr32/src/d_main.c
---- a/src/d_main.c 2000-03-27 05:33:49.000000000 -0500
-+++ b/src/d_main.c 2007-10-22 17:18:05.000000000 -0400
-@@ -39,7 +39,7 @@ static const char rcsid[] = "$Id: d_main
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
--
-+#include <bits/posix1_lim.h>
- #include "doomdef.h"
- #include "doomstat.h"
- #include "dstrings.h"
-@@ -228,7 +228,7 @@ void D_Display (void)
- case -1:
- case GS_LEVEL:
- V_SetPalette(0); // cph - use default (basic) palette
-- default:
-+ default:;
- }
-
- switch (gamestate) {
-@@ -241,7 +241,7 @@ void D_Display (void)
- case GS_DEMOSCREEN:
- D_PageDrawer();
- break;
-- default:
-+ default:;
- }
- } else if (gametic) { // In a level
- boolean redrawborderstuff;
-diff -Nrup lxdoom-1.4.4/src/g_game.c lxdoom-1.4.4-avr32/src/g_game.c
---- a/src/g_game.c 2000-03-17 15:50:30.000000000 -0500
-+++ b/src/g_game.c 2007-10-22 17:18:10.000000000 -0400
-@@ -67,6 +67,7 @@ rcsid[] = "$Id: g_game.c,v 1.36 2000/03/
- #include "lprintf.h"
- #include "i_main.h"
- #include "i_system.h"
-+#include <bits/posix1_lim.h>
-
- #define SAVEGAMESIZE 0x20000
- #define SAVESTRINGSIZE 24
-@@ -868,7 +869,7 @@ void G_Ticker (void)
- switch (prevgamestate) {
- case GS_INTERMISSION:
- WI_End();
-- default:
-+ default:;
- }
- prevgamestate = gamestate;
- } \ No newline at end of file
diff --git a/package/games/lxdoom/lxdoom.mk b/package/games/lxdoom/lxdoom.mk
deleted file mode 100644
index b9584b1fb..000000000
--- a/package/games/lxdoom/lxdoom.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#############################################################
-#
-# lxdoom
-#
-#############################################################
-LXDOOM_VERSION = 1.4.4
-LXDOOM_SOURCE = lxdoom-$(LXDOOM_VERSION).tar.gz
-LXDOOM_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/lxdoom
-LXDOOM_INSTALL_STAGING = NO
-LXDOOM_INSTALL_TARGET = YES
-LXDOOM_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
-
-LXDOOM_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) --prefix=/usr \
- --includedir=/usr/include --enable-shared
-
-LXDOOM_DEPENDENCIES = xserver_xorg-server
-
-$(eval $(call AUTOTARGETS,package/games,lxdoom))
diff --git a/package/xstroke/Config.in b/package/xstroke/Config.in
index 3d68b3e2f..5589fe6a4 100644
--- a/package/xstroke/Config.in
+++ b/package/xstroke/Config.in
@@ -1,12 +1,10 @@
config BR2_PACKAGE_XSTROKE
bool "xstroke"
depends on BR2_PACKAGE_XORG7
- depends on BR2_USE_WCHAR # glib2
- select BR2_PACKAGE_DOCKER
+ select BR2_PACKAGE_XLIB_LIBXFT
+ select BR2_PACKAGE_XLIB_LIBXTST
+ select BR2_PACKAGE_XLIB_LIBXPM
help
Handwriting recognition for X
http://avr32linux.org/twiki/pub/Main/XStroke
-
-comment "xstroke requires a toolchain with WCHAR support"
- depends on BR2_PACKAGE_XORG7 && !BR2_USE_WCHAR
diff --git a/package/xstroke/xstroke.mk b/package/xstroke/xstroke.mk
index bfe66ccf4..920ed9cac 100644
--- a/package/xstroke/xstroke.mk
+++ b/package/xstroke/xstroke.mk
@@ -6,12 +6,9 @@
XSTROKE_VERSION = 0.6
XSTROKE_SOURCE = xstroke-$(XSTROKE_VERSION).tar.gz
XSTROKE_SITE = http://avr32linux.org/twiki/pub/Main/XStroke
-XSTROKE_AUTORECONF = NO
-XSTROKE_INSTALL_STAGING = NO
-XSTROKE_INSTALL_TARGET = YES
XSTROKE_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
-XSTROKE_DEPENDENCIES = xserver_xorg-server
+XSTROKE_DEPENDENCIES = xlib_libXft xlib_libXtst xlib_libXpm
$(eval $(call AUTOTARGETS,package,xstroke))