summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/qt/qt.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 37849f98b..ae03fa684 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -315,6 +315,11 @@ else
QT_CONFIGURE+= -no-stl
endif
+# ccache and precompiled headers don't play well together
+ifeq ($(BR2_CCACHE),y)
+QT_CONFIGURE += -no-pch
+endif
+
BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
# Figure out what libs to install in the target