diff options
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 22 |
1 files changed, 22 insertions, 0 deletions
@@ -264,6 +264,10 @@ include package/*/*.mk TARGETS+=target-devfiles +ifeq ($(BR2_ENABLE_LOCALE_PURGE),y) +TARGETS+=target-purgelocales +endif + # target stuff is last so it can override anything else include target/Makefile.in @@ -348,6 +352,24 @@ else find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -delete endif +ifeq ($(BR2_ENABLE_LOCALE_PURGE),y) +LOCALE_WHITELIST=$(PROJECT_BUILD_DIR)/locales.nopurge +LOCALE_NOPURGE=$(strip $(subst ",,$(BR2_ENABLE_LOCALE_WHITELIST))) +#")) + +target-purgelocales: + rm -f $(LOCALE_WHITELIST) + for i in $(LOCALE_NOPURGE); do echo $$i >> $(LOCALE_WHITELIST); done + + for dir in $(wildcard $(addprefix $(TARGET_DIR),/usr/share/locale /usr/share/X11/locale /usr/man /usr/share/man)); \ + do \ + for lang in $$(cd $$dir; ls .|grep -v man); \ + do \ + grep -qx $$lang $(LOCALE_WHITELIST) || rm -rf $$dir/$$lang; \ + done; \ + done +endif + source: $(TARGETS_SOURCE) $(HOST_SOURCE) _source-check: |